aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-07 12:34:06 +0100
committerJustin Lecher <jlec@gentoo.org>2011-03-07 12:34:06 +0100
commite18c4f88722965fd1e34753e074c0a98969dbd1c (patch)
tree9e73644d7d96bf580a17c4a17a68164ff0c94ec3 /sci-misc/salome-gui/salome-gui-5.1.4.ebuild
parentQA STUFF (diff)
downloadsci-e18c4f88722965fd1e34753e074c0a98969dbd1c.tar.gz
sci-e18c4f88722965fd1e34753e074c0a98969dbd1c.tar.bz2
sci-e18c4f88722965fd1e34753e074c0a98969dbd1c.zip
Correct Slots for gtk 3 introduction to tree
(Portage version: 2.2.0_alpha26/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-misc/salome-gui/salome-gui-5.1.4.ebuild')
-rw-r--r--sci-misc/salome-gui/salome-gui-5.1.4.ebuild48
1 files changed, 24 insertions, 24 deletions
diff --git a/sci-misc/salome-gui/salome-gui-5.1.4.ebuild b/sci-misc/salome-gui/salome-gui-5.1.4.ebuild
index d34b36744..728ed6a36 100644
--- a/sci-misc/salome-gui/salome-gui-5.1.4.ebuild
+++ b/sci-misc/salome-gui/salome-gui-5.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,7 +8,7 @@ PYTHON_DEPEND="2:2.4"
inherit eutils flag-o-matic python
-DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. GUI component"
+DESCRIPTION="The Open Source Integration Platform for Numerical Simulation - GUI component"
HOMEPAGE="http://www.salome-platform.org"
SRC_URI="http://files.opencascade.com/Salome/Salome${PV}/src${PV}.tar.gz"
@@ -17,28 +17,28 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="debug doc opengl"
-RDEPEND="opengl? ( virtual/opengl )
- debug? ( dev-util/cppunit )
- >=sci-misc/salome-kernel-${PV}
- >=net-misc/omniORB-4.1.4
- >=dev-python/omniorbpy-3.4
- >=sci-libs/hdf5-1.6.4
- >=dev-libs/boost-1.40.0
- >=x11-libs/qt-core-4.5.2
- >=x11-libs/qt-gui-4.5.2
- >=x11-libs/qt-opengl-4.5.2
- >=x11-libs/qwt-5.2
- >=dev-python/PyQt4-4.5.4
- >=sci-libs/vtk-5.0[python,mpi]
- >=sci-libs/opencascade-6.3
- app-text/dgs"
-
+RDEPEND="
+ >=sci-misc/salome-kernel-${PV}
+ >=net-misc/omniORB-4.1.4
+ >=dev-python/omniorbpy-3.4
+ >=sci-libs/hdf5-1.6.4
+ >=dev-libs/boost-1.40.0
+ >=x11-libs/qt-core-4.5.2
+ >=x11-libs/qt-gui-4.5.2
+ >=x11-libs/qt-opengl-4.5.2
+ >=x11-libs/qwt-5.2
+ >=dev-python/PyQt4-4.5.4
+ >=sci-libs/vtk-5.0[python,mpi]
+ >=sci-libs/opencascade-6.3
+ app-text/dgs
+ opengl? ( virtual/opengl )
+ debug? ( dev-util/cppunit )"
DEPEND="${RDEPEND}
- >=app-doc/doxygen-1.5.6
- media-gfx/graphviz
- >=dev-python/sip-4.8.2
- dev-lang/swig
- dev-libs/libxml2"
+ >=app-doc/doxygen-1.5.6
+ media-gfx/graphviz
+ >=dev-python/sip-4.8.2
+ dev-lang/swig
+ dev-libs/libxml2:2"
MODULE_NAME="GUI"
S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
@@ -104,7 +104,7 @@ src_install() {
doenvd 90${P}
rm adm_local/Makefile adm_local/unix/Makefile adm_local/cmake_files/Makefile \
adm_local/unix/config_files/Makefile
-
+
insinto "${INSTALL_DIR}"
doins -r adm_local
use doc && dodoc AUTHORS INSTALL NEWS README