aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEtienne Lorriaux <etienne.lorriaux@gmail.com>2010-04-05 01:03:18 +0200
committerEtienne Lorriaux <etienne.lorriaux@gmail.com>2010-04-05 01:03:18 +0200
commit4423c859702d6ae0ccb3140e3027979ba0430829 (patch)
treec23d071e80d3f0bf3c59ae217230d7c3b4ccb30e /sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild
parentChanged DEPEND of media-libs/SoQt from 1.4.2_alpha4181 to 1.4.2_alpha1841 (diff)
downloadsci-4423c859702d6ae0ccb3140e3027979ba0430829.tar.gz
sci-4423c859702d6ae0ccb3140e3027979ba0430829.tar.bz2
sci-4423c859702d6ae0ccb3140e3027979ba0430829.zip
sci-misc/salome-*: changed fetch URL + cleaning (thanks Oliver), new
patch + modifs to (partially) solve med_int issues on amd64
Diffstat (limited to 'sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild')
-rw-r--r--sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild29
1 files changed, 9 insertions, 20 deletions
diff --git a/sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild b/sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild
index f88a1aad3..126d32cb2 100644
--- a/sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild
+++ b/sci-misc/salome-smesh/salome-smesh-5.1.3.ebuild
@@ -5,11 +5,11 @@
EAPI=2
PYTHON_DEPEND="2:2.4"
-inherit distutils eutils
+inherit eutils flag-o-matic python
DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. SMESH Component"
HOMEPAGE="http://www.salome-platform.org"
-SRC_URI="http://www.stasyan.com/devel/distfiles/src${PV}.tar.gz"
+SRC_URI="http://files.opencascade.com/Salome/Salome${PV}/src${PV}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
@@ -42,40 +42,37 @@ DEPEND="${RDEPEND}
>=dev-python/docutils-0.4"
MODULE_NAME="SMESH"
-MY_S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
SMESH_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
pkg_setup() {
- PYVER=$(python_get_version)
- [[ ${PYVER} > 2.4 ]] && \
+ [[ $(python_get_version) > 2.4 ]] && \
ewarn "Python 2.4 is highly recommended for Salome..."
}
src_prepare() {
- cd "${MY_S}"
-
rm -r -f autom4te.cache
./build_configure
}
src_configure() {
- cd "${MY_S}"
-
local vtk_suffix=""
has_version ">=sci-libs/vtk-5.0" && vtk_suffix="-5.0"
has_version ">=sci-libs/vtk-5.2" && vtk_suffix="-5.2"
has_version ">=sci-libs/vtk-5.4" && vtk_suffix="-5.4"
+ use amd64 && append-flags -DHAVE_F77INT64
+
# Configuration
econf --prefix=${INSTALL_DIR} \
--datadir=${INSTALL_DIR}/share/salome \
--docdir=${INSTALL_DIR}/doc/salome \
--infodir=${INSTALL_DIR}/share/info \
--libdir=${INSTALL_DIR}/$(get_libdir)/salome \
- --with-python-site=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
- --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
+ --with-python-site=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
+ --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
--with-vtk=${VTKHOME} \
--with-vtk-version=${vtk_suffix} \
--with-qt='/usr' \
@@ -86,15 +83,7 @@ src_configure() {
|| die "econf failed"
}
-src_compile() {
- cd "${MY_S}"
-
- emake || die "emake failed"
-}
-
src_install() {
- cd "${MY_S}"
-
emake DESTDIR="${D}" install || die "emake install failed"
use amd64 && dosym ${INSTALL_DIR}/lib64 ${INSTALL_DIR}/lib
@@ -102,7 +91,7 @@ src_install() {
echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
- echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome" >> ./90${P}
doenvd 90${P}
rm adm_local/Makefile
insinto "${INSTALL_DIR}"