aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-12 14:26:54 +0100
committerJustin Lecher <jlec@gentoo.org>2014-11-12 14:26:54 +0100
commit566bb761a5d23ec0367a7ac35813dbd3accee336 (patch)
tree7daa4265804e95114f724c34ec0c7bd94815109f /sci-misc/stanford-parser/stanford-parser-1.6.ebuild
parentsci-misc/opennlp-tools: Bump to EAPI=5 (diff)
downloadsci-566bb761a5d23ec0367a7ac35813dbd3accee336.tar.gz
sci-566bb761a5d23ec0367a7ac35813dbd3accee336.tar.bz2
sci-566bb761a5d23ec0367a7ac35813dbd3accee336.zip
sci-misc/stanford-parser: Bump to EAPI=5
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-misc/stanford-parser/stanford-parser-1.6.ebuild')
-rw-r--r--sci-misc/stanford-parser/stanford-parser-1.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-misc/stanford-parser/stanford-parser-1.6.ebuild b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
index 7793e3951..3b29f4262 100644
--- a/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
+++ b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
@@ -2,19 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
JAVA_PKG_IUSE="doc source"
inherit eutils java-pkg-2 java-ant-2
MY_PV=2007-08-19
MY_P=${PN}-${MY_PV}
+
DESCRIPTION="Stanfords statistical natural language parsers"
HOMEPAGE="http://www-nlp.stanford.edu/software/"
SRC_URI="http://www-nlp.stanford.edu/software/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE="${IUSE}"
COMMON_DEP=""
@@ -24,6 +26,7 @@ RDEPEND=">=virtual/jre-1.5
${COMMON_DEP}"
S="${WORKDIR}/${MY_P}"
+
EANT_BUILD_TARGET="compile"
src_install() {
@@ -35,11 +38,8 @@ src_install() {
java-pkg_dosrc src
fi
dodoc README.txt README_dependencies.txt cedict_readme.txt
- dodir /usr/share/${PN}
insinto /usr/share/${PN}
- for f in *ser.gz ; do
- doins ${f}
- done
+ doins *ser.gz
java-pkg_dolauncher stanford-lexparser --java_args -Xmx200m --main edu.stanford.nlp.parser.lexparser.LexicalizedParser
java-pkg_dolauncher stanford-lexparser-gui --java_args "-server -Xmx600m" --main edu.stanford.nlp.parser.ui.Parser
}