aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 18:08:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 18:08:24 +0100
commit17a5b8e0de4be077cf57d2f63bfc6b0124d40eb8 (patch)
treef22af92aab42f945b4815002b6264863c7722074 /sci-misc
parentx11-libs/xview-bin: Chop DESCRIPTION to 80 chars (diff)
downloadsci-17a5b8e0de4be077cf57d2f63bfc6b0124d40eb8.tar.gz
sci-17a5b8e0de4be077cf57d2f63bfc6b0124d40eb8.tar.bz2
sci-17a5b8e0de4be077cf57d2f63bfc6b0124d40eb8.zip
sci-misc/simx: Bump to EAPI=6
* Use git-r3.eclass Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/simx/simx-0.2.ebuild24
-rw-r--r--sci-misc/simx/simx-9999.ebuild27
2 files changed, 22 insertions, 29 deletions
diff --git a/sci-misc/simx/simx-0.2.ebuild b/sci-misc/simx/simx-0.2.ebuild
index 232de1a64..3dd4e3ee6 100644
--- a/sci-misc/simx/simx-0.2.ebuild
+++ b/sci-misc/simx/simx-0.2.ebuild
@@ -1,27 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils distutils-r1
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="git://github.com/sim-x/${PN}.git http://github.com/sim-x/${PN}.git"
- inherit git-2
- KEYWORDS=""
-else
- SRC_URI="https://github.com/sim-x/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="a library for developing parallel, discrete-event simulations in Python"
+DESCRIPTION="Library for developing parallel, discrete-event simulations in Python"
HOMEPAGE="https://github.com/sim-x"
+SRC_URI="https://github.com/sim-x/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
IUSE=""
RDEPEND="
@@ -31,7 +24,10 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-util/cmake"
-src_prepare() {
+python_prepare_all() {
# don't do egg install
- sed -i 's/self.do_egg_install()/_install.install.run(self)/' setup.py || die
+ sed \
+ -e 's/self.do_egg_install()/_install.install.run(self)/' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
}
diff --git a/sci-misc/simx/simx-9999.ebuild b/sci-misc/simx/simx-9999.ebuild
index 232de1a64..6054dd466 100644
--- a/sci-misc/simx/simx-9999.ebuild
+++ b/sci-misc/simx/simx-9999.ebuild
@@ -1,27 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils distutils-r1
+inherit cmake-utils distutils-r1 git-r3
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="git://github.com/sim-x/${PN}.git http://github.com/sim-x/${PN}.git"
- inherit git-2
- KEYWORDS=""
-else
- SRC_URI="https://github.com/sim-x/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="a library for developing parallel, discrete-event simulations in Python"
+DESCRIPTION="Library for developing parallel, discrete-event simulations in Python"
HOMEPAGE="https://github.com/sim-x"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/sim-x/${PN}.git http://github.com/sim-x/${PN}.git"
SLOT="0"
LICENSE="LGPL-2.1"
+KEYWORDS=""
IUSE=""
RDEPEND="
@@ -31,7 +25,10 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-util/cmake"
-src_prepare() {
+python_prepare_all() {
# don't do egg install
- sed -i 's/self.do_egg_install()/_install.install.run(self)/' setup.py || die
+ sed \
+ -e 's/self.do_egg_install()/_install.install.run(self)/' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
}