aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2012-08-04 13:02:39 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2012-08-04 13:02:39 -0400
commit33b466cc034c7d9fea2ee8f0cc977ef711046aa9 (patch)
treee3eb121a877ffd5c6d3f59d7ef794052e00688ed /sci-misc
parentdev-ml/lacaml version bump and cleanup old version (diff)
parentscotch in main tree (diff)
downloadsci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.tar.gz
sci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.tar.bz2
sci-33b466cc034c7d9fea2ee8f0cc977ef711046aa9.zip
dev-java/scirenderer version bump
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/foma/ChangeLog7
-rw-r--r--sci-misc/foma/Manifest3
-rw-r--r--sci-misc/foma/foma-0.9.16_alpha.ebuild47
-rw-r--r--sci-misc/hfst/ChangeLog8
-rw-r--r--sci-misc/hfst/Manifest5
-rw-r--r--sci-misc/hfst/hfst-2.2.ebuild4
-rw-r--r--sci-misc/hfst/hfst-3.0.2.ebuild4
-rw-r--r--sci-misc/hfst/hfst-3.3.12.ebuild34
-rw-r--r--sci-misc/hfst/metadata.xml24
-rw-r--r--sci-misc/openfst/ChangeLog7
-rw-r--r--sci-misc/openfst/Manifest3
-rw-r--r--sci-misc/openfst/openfst-1.3.2.ebuild30
-rw-r--r--sci-misc/sfst/ChangeLog7
-rw-r--r--sci-misc/sfst/Manifest7
-rw-r--r--sci-misc/sfst/sfst-1.4.6g.ebuild83
15 files changed, 252 insertions, 21 deletions
diff --git a/sci-misc/foma/ChangeLog b/sci-misc/foma/ChangeLog
index 4918b470c..f5af3ae7c 100644
--- a/sci-misc/foma/ChangeLog
+++ b/sci-misc/foma/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-misc/foma
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*foma-0.9.16_alpha (31 Jul 2012)
+
+ 31 Jul 2012; Flammie Pirinen <flammie@gentoo.org> +foma-0.9.16_alpha.ebuild:
+ Bump foma to version 0.9.16alpha, install headers
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/foma/Manifest b/sci-misc/foma/Manifest
index f0f7c4ebe..8af0fee78 100644
--- a/sci-misc/foma/Manifest
+++ b/sci-misc/foma/Manifest
@@ -1 +1,2 @@
-DIST foma-0.9.14alpha.tar.gz 306549 RMD160 f5fc03910a76bb0e95b3e0a0008cae5d369dca16 SHA1 85947de3c71ad06448dc7848945ff1deef4e540c SHA256 8ae2f9681e1ecd8c1bc5b1914e755736a839c620b6111c5ab38e2e253ef3255f
+DIST foma-0.9.14alpha.tar.gz 306549 SHA256 8ae2f9681e1ecd8c1bc5b1914e755736a839c620b6111c5ab38e2e253ef3255f SHA512 deb1a2086d21020d84941025f4e131b6a20262b816def2a43261dedfa928823e59704336cdecf28a56b5fb270786b8a7cc2f3ad8b861920e3e0d5a6fd51a7add WHIRLPOOL 1eb73691cf0d710b41a6e9f7a54da0794a2afa526f0f4185e689d3e3fdee9fdc6fd946c80af8ab47ca9cfefb66cea07b46ebee9d31d064697c5632591e20dace
+DIST foma-0.9.16alpha.tar.gz 328482 SHA256 dc019dcdf6dc8f7e881394f3d76821006e7f0cf6e3fe1c12ac2887fa48d81208 SHA512 8c33de29be11dbbf808243222369ee1e8c17f4659fb2d88ce7b1e53f1161538415e50792981110cf46e50890933573f70d034b258a7d7c596e3c61317d56f369 WHIRLPOOL 2cf481210eef4f46eb42f8c98f157074985d2030fbf0aea8cf1f89b1827f7fabf43c0607cefe40d831a5fb15f92f81a04b546a878b299939c1895d8a4c829787
diff --git a/sci-misc/foma/foma-0.9.16_alpha.ebuild b/sci-misc/foma/foma-0.9.16_alpha.ebuild
new file mode 100644
index 000000000..81c050324
--- /dev/null
+++ b/sci-misc/foma/foma-0.9.16_alpha.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+MY_P=${P/_alpha/alpha}
+
+DESCRIPTION="Finite state toolkit compatible with Xerox tools"
+HOMEPAGE="http://code.google.com/p/foma/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/libtermcap-compat
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-2.3
+ >=sys-devel/flex-2.5.35"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed \
+ -e "s/^CFLAGS =/CFLAGS = ${CFLAGS} -fPIC/" \
+ -e 's/ltermcap/lcurses/' \
+ -e 's/ldconfig/true/g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake
+ emake libfoma
+}
+
+src_install() {
+ # since install target doesn't have DESTDIR
+ dobin foma flookup cgflookup
+ dolib.so libfoma.so.${PV/_alpha/}
+ insinto /usr/include
+ doins foma.h fomalib.h fomalibconf.h
+ dodoc README README.symbols
+}
diff --git a/sci-misc/hfst/ChangeLog b/sci-misc/hfst/ChangeLog
index a1485e928..67c498d5e 100644
--- a/sci-misc/hfst/ChangeLog
+++ b/sci-misc/hfst/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-misc/hfst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*hfst-3.3.12 (31 Jul 2012)
+
+ 31 Jul 2012; Flammie Pirinen <flammie@gentoo.org> +hfst-3.3.12.ebuild,
+ metadata.xml:
+ Version bump hfst to 3.3.12
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/hfst/Manifest b/sci-misc/hfst/Manifest
index c6dd95cb9..5998805eb 100644
--- a/sci-misc/hfst/Manifest
+++ b/sci-misc/hfst/Manifest
@@ -1,2 +1,3 @@
-DIST hfst-2.2.tar.gz 3608685 RMD160 d10006421670ce3f1c9d44115b6916a84f4b0063 SHA1 51f9ad1008124c310047e79798d76498bc01dbab SHA256 0b63d60dd331f7bcf32908015cada8920127215564735036696a0e877ab69337
-DIST hfst-3.0.2.tar.gz 1110799 RMD160 f068c8a70528201e2b76c9ff406316cadbf486e1 SHA1 1bfc94590fde4ee6ff70466edeae5f983005db4f SHA256 8d02fa5b2ee490c9a6bdf62b7b98918b94cea080c41e8c404a6bce6d123c0a31
+DIST hfst-2.2.tar.gz 3608685 SHA256 0b63d60dd331f7bcf32908015cada8920127215564735036696a0e877ab69337 SHA512 24444ddbf762df9e52a1fe8be5aa7a4be3a18e9ca9f5878a3df18b8fe8b4b1ae84dcf88bfeac749e9b76a9fb364227a6ac52d475f40c4956f7c8ea0026f070c2 WHIRLPOOL 32716d690bf8807644a4c677ff0b254c3ff274ef404e3f338290b79803f3e560ace5ab0604a581ff32a007fb08a129c9c7c268689a3e3b148888be06a2946363
+DIST hfst-3.0.2.tar.gz 1110799 SHA256 8d02fa5b2ee490c9a6bdf62b7b98918b94cea080c41e8c404a6bce6d123c0a31 SHA512 2891f8f45bd410af3ca83f08d93527c5a7e34c80942f8cffb45d9dd83914bf69e778790f114e2b8a3308a25a01b5aa1bb995085ed0f04097ca3f83a764cfeff7 WHIRLPOOL e259cfd6381cf3e4b917e4f6b4a437a6a1acb9bc1830936c666ba430ff33d7a8c1a0cd8424d1543f3482474db56856c88a7d8cc6be70fe22f680a1daebd016b9
+DIST hfst-3.3.12.tar.gz 1419137 SHA256 6424b3055fa4a96ff1b502a39907d30b3fb5be0e48c2ef4670206ace684d6f7a SHA512 b4b754767cb750cb420b9c8eafbc33dd89a6deec58012f5a4aa90c0219d7e0737a08215b7f4c3277f40180a7fe970c9ee9aafc8077520d0e49eba398b7d8f269 WHIRLPOOL 71a9b232fb043db755f1d5cd643936e89877f2eb1d81330a80680a5222fec8dbd1f2eb4fb1be97d62326dc3b23e32d0a79da3238446cb1bb714ae1dab1e6bb91
diff --git a/sci-misc/hfst/hfst-2.2.ebuild b/sci-misc/hfst/hfst-2.2.ebuild
index 7e7d56fbb..dd7a3610d 100644
--- a/sci-misc/hfst/hfst-2.2.ebuild
+++ b/sci-misc/hfst/hfst-2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI=4
DESCRIPTION="Helsinki Finite State Transducer API and tools"
HOMEPAGE="http://hfst.sourceforge.net/"
-SRC_URI="mirror://sourceforge/hfst/hfst-2.2.tar.gz"
+SRC_URI="mirror://sourceforge/hfst/archive/hfst-2.2.tar.gz"
LICENSE="GPL-3"
SLOT="0"
diff --git a/sci-misc/hfst/hfst-3.0.2.ebuild b/sci-misc/hfst/hfst-3.0.2.ebuild
index 9ed89b652..7c1b02bc8 100644
--- a/sci-misc/hfst/hfst-3.0.2.ebuild
+++ b/sci-misc/hfst/hfst-3.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI=4
DESCRIPTION="Helsinki Finite State Transducer API and tools"
HOMEPAGE="http://hfst.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/archive/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
diff --git a/sci-misc/hfst/hfst-3.3.12.ebuild b/sci-misc/hfst/hfst-3.3.12.ebuild
new file mode 100644
index 000000000..45be9b7f3
--- /dev/null
+++ b/sci-misc/hfst/hfst-3.3.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Helsinki Finite State Transducer API and tools"
+HOMEPAGE="http://hfst.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+openfst sfst foma xml +glib"
+
+RDEPEND="
+ openfst? ( >sci-misc/openfst-1.2 )
+ sfst? ( >sci-misc/sfst-1.3 )
+ foma? ( >sci-misc/foma-0.9.13 )
+ xml? ( dev-libs/libxml2 dev-cpp/libxmlpp )
+ glib? ( dev-libs/glib )"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.35
+ sys-devel/bison"
+
+src_configure() {
+ econf \
+ $(use_with openfst) \
+ $(use_with sfst) \
+ $(use_with foma) \
+ $(use_enable xml apertium2fst) \
+ $(use_with glib unicodehandler glib) \
+ --enable-lexc
+}
diff --git a/sci-misc/hfst/metadata.xml b/sci-misc/hfst/metadata.xml
index 4093d00b1..efb69747d 100644
--- a/sci-misc/hfst/metadata.xml
+++ b/sci-misc/hfst/metadata.xml
@@ -6,11 +6,23 @@
traditional FST-based linguistic morphology tools.
</longdescription>
<use>
- <flag name="openfst">Add optional support for openfst backend
- library (<pkg>sci-misc/openfst</pkg>)</flag>
- <!-- <flag name="foma">Add optional support for foma backend
- library (<pkg>sci-misc/foma</pkg>)</flag> -->
- <flag name="sfst">Add optional support for sfst backend
- library (<pkg>sci-misc/sfst</pkg>)</flag>
+ <flag name="openfst">
+ Add optional support for openfst backend library
+ (<pkg>sci-misc/openfst</pkg>)
+ </flag>
+ <flag name="foma">
+ Add optional support for foma backend library
+ (<pkg>sci-misc/foma</pkg>)</flag>
+ <flag name="sfst">
+ Add optional support for sfst backend library
+ (<pkg>sci-misc/sfst</pkg>)
+ </flag>
+ <flag name="glib">
+ Parse UTF-8 and collate unicode using glib instead of
+ homebrewn methods
+ </flag>
+ <flag name="xml">
+ Include parsers for grammars and formats that require XML support
+ </flag>
</use>
</pkgmetadata>
diff --git a/sci-misc/openfst/ChangeLog b/sci-misc/openfst/ChangeLog
index 08df6aa0a..e2ca5a189 100644
--- a/sci-misc/openfst/ChangeLog
+++ b/sci-misc/openfst/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-misc/openfst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*openfst-1.3.2 (30 Jul 2012)
+
+ 30 Jul 2012; Flammie Pirinen <flammie@gentoo.org> +openfst-1.3.2.ebuild:
+ Version bump.
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/openfst/Manifest b/sci-misc/openfst/Manifest
index 244fadf3c..6c0467fd1 100644
--- a/sci-misc/openfst/Manifest
+++ b/sci-misc/openfst/Manifest
@@ -1 +1,2 @@
-DIST openfst-1.2.7.tar.gz 668134 RMD160 a24279f4deb85f79875b237c548f0b600c3a6af8 SHA1 75aa24fe050c295e16aaeb31a216c1d97952c84e SHA256 a38b10a7a1b6c054fb15035f3197f566ac6b23bc2acd5958052165ae7ce5c11c
+DIST openfst-1.2.7.tar.gz 668134 SHA256 a38b10a7a1b6c054fb15035f3197f566ac6b23bc2acd5958052165ae7ce5c11c SHA512 899297a12b51acef51a82148a04160acd4bb4e1925da18e20a810814401542aaa582928ae3b80b96f49890420796cae7acd7cbf1d21fb6bc6c755254f1ae2c67 WHIRLPOOL b9c1d9a7b592a43cd77aa6778451c9de8bbf135f39f1415d467b25279c6a360c9537dcdb8b9795023e482462668e61ad66de8e843f211b72a7986b448d6e200a
+DIST openfst-1.3.2.tar.gz 723259 SHA256 4e1c2e4f6c54aef15cf13f4f01611ac72122a97214dfa7dab0b7d1a7e1214602 SHA512 5cbaebc3e99c2156379bdaeddef6972b37019cbdce7e2744cf5020f300e959410dce8d1fb1b354c3691975a2d1c0f40123feab46ded59919e4b13a010bbb78f0 WHIRLPOOL a0ca8e814ff1f7c09fd64687dacadf66da3945560e3b16f9afc797df391dc85b7d124314354ddd823ee142131b3d7bbd7914f5659e8c6fc49e8b0abac74be0b2
diff --git a/sci-misc/openfst/openfst-1.3.2.ebuild b/sci-misc/openfst/openfst-1.3.2.ebuild
new file mode 100644
index 000000000..98cbaa76e
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die "docs missing"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}
diff --git a/sci-misc/sfst/ChangeLog b/sci-misc/sfst/ChangeLog
index 127bdf946..ac6a40d94 100644
--- a/sci-misc/sfst/ChangeLog
+++ b/sci-misc/sfst/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-misc/sfst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*sfst-1.4.6g (01 Aug 2012)
+
+ 01 Aug 2012; Flammie Pirinen <flammie@gentoo.org> +sfst-1.4.6g.ebuild:
+ Version bump sfst to 1.4.6g.
+
24 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/sfst/Manifest b/sci-misc/sfst/Manifest
index 03d6f2d1e..3fea2be41 100644
--- a/sci-misc/sfst/Manifest
+++ b/sci-misc/sfst/Manifest
@@ -1,3 +1,4 @@
-DIST SFST-1.4.2.tar.gz 490458 RMD160 77b0fd451026067ce91f6837d16cd6f55064ba35 SHA1 948f73fb6e66f30aadfb12311cbd4a8c7101494d SHA256 0f3040f9e79faa7fee083d3344a87db533dfd84340b43eb86e79a208c70ad7be
-DIST sfst.el 4752 RMD160 b322b17fc4a0b9d22938af5438524cfac18f7a02 SHA1 779b36a5f60ea6ff6894950f82cce186397a6802 SHA256 b47ff59f5ff24482dbbb2f1e71a8b9ca234c4154487f83eb2118f1a62bb9eb5f
-DIST vim-mode.tar.gz 1104 RMD160 c7e3f79fb5bd466724c3d456a92fbeb07d355515 SHA1 83b9651a7e4ca9642b16be416e616734e8c3f88c SHA256 a62ba91c40da75be389a334db62cc2b4904bedfac657b185012b10f3f55dfe09
+DIST SFST-1.4.2.tar.gz 490458 SHA256 0f3040f9e79faa7fee083d3344a87db533dfd84340b43eb86e79a208c70ad7be SHA512 9466d929e33141db7e2e19eb9dbcdf095a561677ba0e0ae9158a813a92ac3b389462a47a253fca5c61d14413c2559e0f1cfe3d3222f456836b5b5f93b33b42ea WHIRLPOOL e1aa43b8902812a75aa8d4ac598aa029cf38e23e52c9cc8c140eda03d5b514bcc5cc60f820b0eedd00d060b175aff74e05ce72c860337297553a228ab3b6425b
+DIST SFST-1.4.6g.tar.gz 486283 SHA256 5ed88df7ca993fc62e9ca85464ffc78fde83425344826e26debc984f32621bf8 SHA512 cd92a952389e5ec1cf965362b249f992bc20dca58c9dd3f8cc873ccbdc80507d4962681725943d2611956d92c116338a0b46f18653d89486f0a4986fb58fbd13 WHIRLPOOL 79f0dadb16f12507b58bf3971df0b6aba42f2f7b5fe95a796e6d2c15ddfdf95fc30dea4e387f77080f440810acdbfbba0ebe29f3fe7de1102f79edfec540129c
+DIST sfst.el 4752 SHA256 b47ff59f5ff24482dbbb2f1e71a8b9ca234c4154487f83eb2118f1a62bb9eb5f SHA512 88c808044919d49b7c647c16caffb0e67d6fae9ae948434247dbcef7d78168a7b67e7a5b64c5dbeb634f273d6b8ccb93d449af097a1418a6d48a7852f6ad9bbe WHIRLPOOL c8075858fde4c0986acdebab6e5935b1a8022065db09f722d0844d5a020414e8b19d3f321a6f1eeb96e4609643ed4dc62375d8c11be471b5d2e6b7212f6af273
+DIST vim-mode.tar.gz 1104 SHA256 a62ba91c40da75be389a334db62cc2b4904bedfac657b185012b10f3f55dfe09 SHA512 8b808553dbf7a6d6aebb0d6382339bfbe56584effe0b1b0b9096969f81324305e4b66760188dc8fdfbb69118aa5688c66e2bd880dabb57b494068fd620ff540d WHIRLPOOL 252b7bd1110f3522caf0e2921550a52a552611227fd0da0029485f6eaf467ad476758deaee2774cf3c0e882d5dca63b82362e3e5a8fd378171286f7c1682fa77
diff --git a/sci-misc/sfst/sfst-1.4.6g.ebuild b/sci-misc/sfst/sfst-1.4.6g.ebuild
new file mode 100644
index 000000000..6222fddd1
--- /dev/null
+++ b/sci-misc/sfst/sfst-1.4.6g.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit elisp-common eutils
+
+MY_PN="SFST"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Uni Stuttgart Finite State Transducer tools"
+HOMEPAGE="http://www.ims.uni-stuttgart.de/projekte/gramotron/SOFTWARE/SFST.html"
+SRC_URI="
+ ftp://ftp.ims.uni-stuttgart.de/pub/corpora/${MY_PN}/${MY_P}.tar.gz
+ vim-syntax? ( ftp://ftp.ims.uni-stuttgart.de/pub/corpora/${MY_PN}/vim-mode.tar.gz )
+ emacs? ( http://www.cis.uni-muenchen.de/~wastl/emacs/sfst.el )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="emacs vim-syntax"
+
+RDEPEND="sys-libs/readline"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/sed
+ emacs? ( virtual/emacs )"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # settings in makefile are a bit hacky
+ #epatch "${FILESDIR}"/SFST-1.3-gcc43.patch || die "patch failed"
+ sed \
+ -e "s/^CFLAGS = -O3/CFLAGS = ${CFLAGS}/g" \
+ -e "s/local//g" \
+ -e 's/strip/echo strip removed: /g' \
+ -e 's/# FPIC/FPIC/' \
+ -e 's/ $(PREFIX/ $(DESTDIR)$(PREFIX/g' \
+ -e 's/ldconfig/true/' \
+ -e 's/$(INSTALL_LIBS)/$(INSTALL_DIR) $(DESTDIR)$(PREFIX)\/lib\n\t\0/' \
+ -i "${S}"/src/Makefile || die "sed failed"
+ cd "${S}"
+ if use emacs ; then
+ cp "${DISTDIR}/sfst.el" "${S}"
+ fi
+ if use vim-syntax ; then
+ mv "${WORKDIR}"/INSTALL "${S}"/INSTALL-vim-syntax
+ mv "${WORKDIR}"/sfst.vim "${S}"/
+ fi
+}
+
+src_compile() {
+ emake -C "${S}/src"
+ if use emacs ; then
+ cd "${S}"
+ elisp-compile *.el || die "could not compile elisp"
+ fi
+}
+
+src_install() {
+ cd "${S}/src"
+ # destdir works but prefix fails
+ emake DESTDIR="${D}" install maninstall libinstall
+ cd "${S}"
+ dodoc README
+ insinto /usr/share/doc/${PF}/
+ doins doc/SFST-Manual.pdf doc/SFST-Tutorial.pdf
+ insinto /usr/share/${PN}
+ doins -r data/*
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins sfst.vim
+ insinto /usr/share/vim/vimfiles/ftdetect/
+ newins "${FILESDIR}"/ftdetect-sfst.vim sfst.vim
+ dodoc INSTALL-vim-syntax
+ fi
+ if use emacs ; then
+ elisp-install ${PN} *.el *.elc || die "could not install elisp"
+ fi
+}