aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2011-12-30 04:14:33 +0000
committerSébastien Fabbro <sebfabbro@gmail.com>2011-12-30 04:14:33 +0000
commitb52ad7937684719454c84f28fd13eacf352b35ac (patch)
tree887110cae7b45049ba243587dc6617b313e2c4a0 /sci-misc
parentdocumented status of go-parser (as a very simple implementation) which should... (diff)
downloadsci-b52ad7937684719454c84f28fd13eacf352b35ac.tar.gz
sci-b52ad7937684719454c84f28fd13eacf352b35ac.tar.bz2
sci-b52ad7937684719454c84f28fd13eacf352b35ac.zip
nco in tree
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/nco/Manifest3
-rw-r--r--sci-misc/nco/metadata.xml19
-rw-r--r--sci-misc/nco/nco-4.0.7.ebuild65
3 files changed, 0 insertions, 87 deletions
diff --git a/sci-misc/nco/Manifest b/sci-misc/nco/Manifest
deleted file mode 100644
index 30e60e0e4..000000000
--- a/sci-misc/nco/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST nco-4.0.7.tar.gz 4859089 RMD160 baadd326b0d5088639d8baa53c7888781308a244 SHA1 d0586b9c386152ace2d8d15138ad35850b78d34f SHA256 fbff6e8f316efbdc55a39ee1da0a38cddc7005c624facb7c82f632dea629c0de
-EBUILD nco-4.0.7.ebuild 1455 RMD160 811905e272ae170b7b13da76d0fac224ca5089b9 SHA1 2581d9f5709d036e77113f48d82ef712d6295c00 SHA256 c8b3e37728a31a3eec8cb0bec23aa5ba3a84727fdc4f9ec6f229005e6b526209
-MISC metadata.xml 866 RMD160 054c53be984a3638a603ddbe88aa24466272664c SHA1 63fd9f687572d71a006cd51deb648e764c52b543 SHA256 804e9546205b2965cda0cd1b81547aeb1b9fdc561526c5078d066af3a79b296f
diff --git a/sci-misc/nco/metadata.xml b/sci-misc/nco/metadata.xml
deleted file mode 100644
index 5dd3778e4..000000000
--- a/sci-misc/nco/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
- Command-line operators to analyze netCDF files
- NetCDF Operator is a suite of programs known as operators. The
- operators are stand-alone, command-line programs executable in a POSIX
- shell. Operators take one or more netCDF files as input, perform an
- operation (e.g., averaging or hyperslabbing), and produce a netCDF
- output file. NCO was originally designed to manipulate and analyze
- climate data, though it works on any netCDF format datasets.
-</longdescription>
-<use>
- <flag name='ncap2'>Build next generation netcdf arithmetic processor
- (needs <pkg>dev-java/antlr</pkg>)</flag>
- <flag name='udunits'>Add <pkg>sci-libs/udunits</pkg> files support</flag>
-</use>
-</pkgmetadata>
diff --git a/sci-misc/nco/nco-4.0.7.ebuild b/sci-misc/nco/nco-4.0.7.ebuild
deleted file mode 100644
index 6da2897fc..000000000
--- a/sci-misc/nco/nco-4.0.7.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Command line utilities for operating on netCDF files"
-HOMEPAGE="http://nco.sourceforge.net/"
-SRC_URI="http://dust.ess.uci.edu/nco/src/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc gsl mpi ncap2 static-libs udunits"
-
-RDEPEND="
- >=sci-libs/netcdf-4
- gsl? ( sci-libs/gsl )
- mpi? ( virtual/mpi )
- udunits? ( >=sci-libs/udunits-2 )"
-DEPEND="${RDEPEND}
- ncap2? ( !mpi? ( dev-java/antlr:0 ) )
- doc? ( virtual/latex-base )"
-
-pkg_setup() {
- if use mpi && use ncap2; then
- elog "mpi and ncap2 are still incompatible flags"
- elog "nco configure will automatically disables ncap2"
- fi
-}
-
-src_configure() {
- local myconf
- if has_version '>=sci-libs/netcdf-4[hdf5]'; then
- myconf="--enable-netcdf4"
- else
- myconf="--disable-netcdf4"
- fi
- econf \
- ${myconf} \
- --disable-udunits \
- $(use_enable gsl) \
- $(use_enable mpi) \
- $(use_enable ncap2) \
- $(use_enable static-libs static) \
- $(use_enable udunits udunits2)
-}
-
-src_compile() {
- # TODO: workout -j1 (probably lex crap race condition)
- emake -j1
- cd doc
- emake clean info
- use doc && VARTEXFONTS="${T}/fonts" emake html pdf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- cd doc
- dodoc ANNOUNCE ChangeLog MANIFEST NEWS README TAG TODO VERSION *.txt
- doinfo *.info*
- use doc && dohtml nco.html/* && dodoc nco.pdf
-}