aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-01-28 23:48:04 +0100
committerTomas Chvatal <scarabeus@gentoo.org>2009-01-28 23:48:04 +0100
commitde73163fc62819bbf2cc00deee8ded6da32cb923 (patch)
tree15695f3c93c1958c08ddd5ed3e4fd0f04cb7f53d /sci-misc
parentsci-chemistry/ccpn version bump to 2.0.6 (diff)
downloadsci-de73163fc62819bbf2cc00deee8ded6da32cb923.tar.gz
sci-de73163fc62819bbf2cc00deee8ded6da32cb923.tar.bz2
sci-de73163fc62819bbf2cc00deee8ded6da32cb923.zip
Bit cleanup in boinc.
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/Manifest4
-rw-r--r--sci-misc/boinc/boinc-6.4.5.ebuild50
-rw-r--r--sci-misc/boinc/files/boinc.conf2
3 files changed, 31 insertions, 25 deletions
diff --git a/sci-misc/boinc/Manifest b/sci-misc/boinc/Manifest
index aa01f7f24..2c340dd19 100644
--- a/sci-misc/boinc/Manifest
+++ b/sci-misc/boinc/Manifest
@@ -1,6 +1,6 @@
-AUX boinc.conf 706 RMD160 dc1a8faaabae2441bbaa23c4a07e9a1f9658ae38 SHA1 5239bdb08fb0ad16944ea68e8b54d3940ac3b091 SHA256 feac94f8f6a893f32908031d0df9dac0c7e0c65448b85c819ff0dd487b4b834a
+AUX boinc.conf 711 RMD160 b6bb25b9d10cbefd3de5d653e701e056e2de4587 SHA1 570929cb4ed50d4fc4408624c4d0d330e208609c SHA256 032f07145ee230f069ffdc93befe90c047fba4314aedfc8024bdb44c06798e9e
AUX boinc.init 2808 RMD160 65ce2f47a2fcc21476cab17eabcfaa4593eaa4c3 SHA1 14defce8894f5f1afcf7e56d14904e3a5b369e41 SHA256 63b0edd80ac82edd866a0c9578d7bec0e7a9afab3f7398707b7943dcabe4377c
DIST boinc-6.4.5.tar.bz2 7641082 RMD160 5d2cb9e645aec52c91fcf791eac8146a202594ca SHA1 6038e13c828b411b18a0f255454c3210d3581deb SHA256 f2ec1a11cc455b3f445470d5261ab37d76ffde53e98ecf3dbc6463793de58363
-EBUILD boinc-6.4.5.ebuild 3270 RMD160 a9b1cdb5dc9a60acd6e252e9516414a0dd1b4e64 SHA1 1588114117e8dfe753f906528e2fa6068f28a791 SHA256 a6e8b44b829aa7956f9790710d0e27f7aa808cac91a67e1e17d8db8e0cd1a00e
+EBUILD boinc-6.4.5.ebuild 3318 RMD160 3c8080a83530f1fc1d4552a07a860871ce73a217 SHA1 63433322e9f0f8b4c2449a4f0a9d91a579ee7177 SHA256 12218e7e5922a7349b6775a3d0e408860dc59f897343bea8b7cefbcbecd8485f
MISC ChangeLog 289 RMD160 a5b083d7c09f9733d6287c799966f443a0fd4f7b SHA1 0f66f6c05b7dd6fdae3a01d77b7556fa682d90d9 SHA256 1c09db09d8fab8f415d9a5a298d7a822bc2b0bd1549c3c77af8c04d89b0f60aa
MISC metadata.xml 471 RMD160 891334e296d850fe56e50b9544c0a7b733740a75 SHA1 adeee8a2ad636bfb0a4306f9abf6a4236aa28560 SHA256 38bca554773db57e79011dea226228dfdc5ea90a3047693b5d47b4bf924af9ea
diff --git a/sci-misc/boinc/boinc-6.4.5.ebuild b/sci-misc/boinc/boinc-6.4.5.ebuild
index 6e6a995f6..ebfda17f8 100644
--- a/sci-misc/boinc/boinc-6.4.5.ebuild
+++ b/sci-misc/boinc/boinc-6.4.5.ebuild
@@ -34,21 +34,26 @@ RDEPEND="
>=virtual/mysql-5.0
dev-python/mysql-python
)
- "
+"
DEPEND="${RDEPEND}
+ sys-devel/gettext
server? ( virtual/imap-c-client )
X? (
media-libs/freeglut
media-libs/jpeg
x11-libs/wxGTK:2.8[X,opengl]
)
- "
-
-LANGS="ar be bg ca cs da de el en_US es eu fi fr hr hu it ja lt lv nb nl pl pt
-pt_BR ro ru sk sl sv_SE tr uk zh_CN zh_TW"
-for LNG in ${LANGS}; do
- IUSE="${IUSE} linguas_${LNG}"
-done
+"
+
+src_prepare() {
+ # use system ssl certificates
+ mkdir "${S}"/curl
+ cp /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
+ # copy icons to correct location
+ cp "${S}"/sea/*.png "${S}"/clientgui/res/
+ # fix stripping
+ ## TODO
+}
src_configure() {
local wxconf=""
@@ -92,39 +97,40 @@ src_compile() {
}
src_install() {
- # TODO: no time to test now.
emake DESTDIR="${D}" install || die "make install failed"
mkdir -p "${D}"/var/lib/boinc/
- # certificates
- dosym /etc/ssl/certs/ca-certificates.crt /opt/${MY_PN}/ca-bundle.crt
- # cuda
- use cuda && dosym /opt/cuda/lib/libcudart.so /opt/${MY_PN}/libcudart.so
+ if use X; then
+ newicon "${S}"/sea/${PN}mgr.48x48.png ${PN}.png
+ make_desktop_entry /usr/bin/boinc_gui "${PN}" ${PN} "Education;Science" /var/lib/${PN}
+ fi
+ # cleanup cruft
+ rm "${D}"/usr/bin/ca-bundle.crt
}
pkg_preinst() {
- enewgroup ${MY_PN}
+ enewgroup ${PN}
if use cuda; then
- enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} "${MY_PN},video"
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},video"
else
- enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} "${MY_PN}"
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN}"
fi
}
pkg_postinst() {
echo
elog "You are using the source compiled version."
- elog "The manager can be found at /opt/bin/${MY_PN}"
+ elog "The manager can be found at /usr/bin/${PN}_gui"
elog
- elog "You need to attach to a project to do anything useful with ${MY_PN}."
- elog "You can do this by running /etc/init.d/${MY_PN} attach"
+ elog "You need to attach to a project to do anything useful with ${PN}."
+ elog "You can do this by running /etc/init.d/${PN} attach"
elog "The howto for configuration is located at:"
- elog "http://${MY_PN}.berkeley.edu/anonymous_platform.php"
+ elog "http://${PN}.berkeley.edu/anonymous_platform.php"
elog
# Add warning about the new password for the client, bug 121896.
elog "If you need to use the graphical client the password is in:"
- elog "/var/lib/${MY_PN}/gui_rpc_auth.cfg"
+ elog "/var/lib/${PN}/gui_rpc_auth.cfg"
elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/${MY_PN}"
+ elog "/etc/conf.d/${PN}"
elog "You should change this to something more memorable (can be even blank)."
elog
elog "Remember to launch init script before using manager. Or changing the password."
diff --git a/sci-misc/boinc/files/boinc.conf b/sci-misc/boinc/files/boinc.conf
index 884189a37..223b160b4 100644
--- a/sci-misc/boinc/files/boinc.conf
+++ b/sci-misc/boinc/files/boinc.conf
@@ -8,7 +8,7 @@ GROUP="boinc"
RUNTIMEDIR="/var/lib/boinc"
# Location of the boinc command line binary
-BOINCBIN="/opt/boinc/boinc"
+BOINCBIN="/usr/bin/boinc_client"
# Logfile (/dev/null for nowhere)
LOGFILE="/var/log/boinc.log"