aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-02-25 06:18:11 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-02-25 06:18:11 +0100
commit358522f1ad3cd111c80e38d3f5e72dc81e7a7fcb (patch)
tree5c374a3501e807f34531f31d55ccf3fa525579fb /sci-physics/atompaw
parentsci-biology/est2uni: current Manifest file (diff)
downloadsci-358522f1ad3cd111c80e38d3f5e72dc81e7a7fcb.tar.gz
sci-358522f1ad3cd111c80e38d3f5e72dc81e7a7fcb.tar.bz2
sci-358522f1ad3cd111c80e38d3f5e72dc81e7a7fcb.zip
A program to generate atomic data for the Projector Augmented Wave method of DFT calculations. Added to support sci-physics/abinit
Diffstat (limited to 'sci-physics/atompaw')
-rw-r--r--sci-physics/atompaw/ChangeLog11
-rw-r--r--sci-physics/atompaw/atompaw-3.0.1.ebuild60
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-physics/atompaw/ChangeLog b/sci-physics/atompaw/ChangeLog
new file mode 100644
index 000000000..4c273869c
--- /dev/null
+++ b/sci-physics/atompaw/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-physics/atompaw
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*atompaw-3.0.1 (25 Feb 2011)
+
+ 25 Feb 2011; Honza Macháček <Hloupy.Honza@centrum.cz>
+ +atompaw-3.0.1.ebuild:
+ A program to generate atomic data for the Projector Augmented Wave method of
+ DFT calculations. Added to support sci-physics/abinit
+
diff --git a/sci-physics/atompaw/atompaw-3.0.1.ebuild b/sci-physics/atompaw/atompaw-3.0.1.ebuild
new file mode 100644
index 000000000..51a4d99f7
--- /dev/null
+++ b/sci-physics/atompaw/atompaw-3.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="PAW atomic data generator"
+HOMEPAGE="http://www.wfu.edu/~natalie/papers/pwpaw/man.html"
+IUSE="doc libxc"
+SRC_URI="http://www.wfu.edu/~natalie/papers/pwpaw/${P}.tar.gz
+ doc? ( http://www.wfu.edu/~natalie/papers/pwpaw/atompaw.pdf
+ http://www.wfu.edu/~natalie/papers/pwpaw/atompaw-usersguide.pdf
+ http://www.wfu.edu/~natalie/papers/pwpaw/notes/atompaw/atompawEqns.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="virtual/lapack
+ virtual/blas
+ libxc? ( sci-libs/libxc[fortran] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ cp ${DISTDIR}/atompaw.pdf ${S}/
+ cp ${DISTDIR}/atompaw-usersguide.pdf ${S}/
+ cp ${DISTDIR}/atompawEqns.pdf ${S}/
+ fi
+}
+
+src_configure() {
+ local modules="-I/usr/$(get_libdir)/finclude"
+ econf $(use_enable libxc) \
+ --with-linalg-flavor=atlas \
+ --with-linalg-libs="$(pkg-config --libs lapack)" \
+ --with-libxc-incs="${modules}" \
+ --with-libxc-libs="${libs} -lxc" \
+ FC="$(tc-getFC)" FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}" \
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS:- ${CFLAGS:- -O2}}"
+}
+
+src_compile() {
+ emake -j1 || die "Make failed"
+}
+
+src_test() {
+ emake check || die "Test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc README || die "dodoc failed"
+
+ if use doc; then
+ dodoc atompaw.pdf atompaw-usersguide.pdf atompawEqns.pdf || die "PDF doc failed"
+ fi
+}