aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 10:23:20 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-22 10:23:20 +0100
commit4ce2a5473d33c7165b5cd588f2e8f226e23392ee (patch)
tree6006a56b7ce9c04902c694909afe5d9b977d1670 /sci-physics/atompaw
parentsci-physics/atompaw2abinit: Use tc-getPKG_CONFIG from toolchain-funcs.eclass ... (diff)
downloadsci-4ce2a5473d33c7165b5cd588f2e8f226e23392ee.tar.gz
sci-4ce2a5473d33c7165b5cd588f2e8f226e23392ee.tar.bz2
sci-4ce2a5473d33c7165b5cd588f2e8f226e23392ee.zip
sci-physics/atompaw: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; correct dep for pkgconfig to virtual
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'sci-physics/atompaw')
-rw-r--r--sci-physics/atompaw/ChangeLog5
-rw-r--r--sci-physics/atompaw/atompaw-3.0.1.9.ebuild14
-rw-r--r--sci-physics/atompaw/metadata.xml14
3 files changed, 18 insertions, 15 deletions
diff --git a/sci-physics/atompaw/ChangeLog b/sci-physics/atompaw/ChangeLog
index 66ddb4e1a..38dfd7881 100644
--- a/sci-physics/atompaw/ChangeLog
+++ b/sci-physics/atompaw/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> atompaw-3.0.1.9.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ correct dep for pkgconfig to virtual
+
*atompaw-3.0.1.9 (17 Jan 2013)
17 Jan 2013; Honza Macháček <Hloupy.Honza@centrum.cz>
diff --git a/sci-physics/atompaw/atompaw-3.0.1.9.ebuild b/sci-physics/atompaw/atompaw-3.0.1.9.ebuild
index e38535457..bbb78cafc 100644
--- a/sci-physics/atompaw/atompaw-3.0.1.9.ebuild
+++ b/sci-physics/atompaw/atompaw-3.0.1.9.ebuild
@@ -24,12 +24,14 @@ RDEPEND="
virtual/lapack
libxc? ( sci-libs/libxc[fortran] )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ virtual/pkgconfig"
DOCS=( README )
FORTRAN_STANDARD=90
+MAKEOPTS+=" -j1"
+
src_unpack() {
unpack ${P}.tar.gz
if use doc; then
@@ -46,19 +48,15 @@ src_configure() {
local myeconfargs=(
$(use_enable libxc)
--with-linalg-flavor=atlas
- --with-linalg-libs="$(pkg-config --libs lapack)"
+ --with-linalg-libs="$($(tc-getPKG_CONFIG) --libs lapack)"
--with-libxc-incs="-I/usr/include ${modules}"
--with-libxc-libs="${libs} -lxc"
- FC="$(tc-getFC)" FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
- CC="$(tc-getCC)" LDFLAGS="${LDFLAGS:- ${CFLAGS:- -O2}}"
+ FC="$(tc-getFC)" FCFLAGS="${FCFLAGS}"
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
)
autotools-utils_src_configure
}
-src_compile() {
- autotools-utils_src_compile -j1
-}
-
src_test() {
use test && autotools-utils_src_test
}
diff --git a/sci-physics/atompaw/metadata.xml b/sci-physics/atompaw/metadata.xml
index 6969910d3..9972fff60 100644
--- a/sci-physics/atompaw/metadata.xml
+++ b/sci-physics/atompaw/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-physics</herd>
- <maintainer>
- <email>sci@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="libxc">Use libxc for something</flag>
- </use>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="libxc">Use libxc for something</flag>
+ </use>
</pkgmetadata>