aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-01 08:52:28 +0200
committerJustin Lecher <jlec@gentoo.org>2014-07-01 08:52:28 +0200
commit6ec285dbfdde397189c30cf467ee238c9004ec01 (patch)
tree89eeab6b98e709543c3c69e90fdc6e6269cd7693 /sci-physics/clip/clip-4.0.0_beta2.ebuild
parentTweak src_install for OS X support. Added documentation in the ebuild itself. (diff)
parentadd Clip4, the Cologne Laue Indexiation Program (diff)
downloadsci-6ec285dbfdde397189c30cf467ee238c9004ec01.tar.gz
sci-6ec285dbfdde397189c30cf467ee238c9004ec01.tar.bz2
sci-6ec285dbfdde397189c30cf467ee238c9004ec01.zip
Merge branch 'jonasstein-master'
* jonasstein-master: add Clip4, the Cologne Laue Indexiation Program
Diffstat (limited to 'sci-physics/clip/clip-4.0.0_beta2.ebuild')
-rw-r--r--sci-physics/clip/clip-4.0.0_beta2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-physics/clip/clip-4.0.0_beta2.ebuild b/sci-physics/clip/clip-4.0.0_beta2.ebuild
new file mode 100644
index 000000000..b0ac76ec2
--- /dev/null
+++ b/sci-physics/clip/clip-4.0.0_beta2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+MY_P="Clip4_$(get_version_component_range 4)_source"
+
+DESCRIPTION="Interactive program for evaluation of Laue diffraction patterns"
+HOMEPAGE="http://clip4.sf.net/"
+SRC_URI="mirror://sourceforge/clip4/${MY_P}.zip"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-qt/qtcore
+ dev-qt/qtsvg
+ dev-qt/qtgui
+ dev-qt/qtwebkit
+ dev-qt/qtopengl
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare()
+{
+ sed -i -e 's|../eigen|/usr/include/eigen3|' \
+ -e 's|shell hg|shell true|g' Clip4.pro || die "sed failed"
+}
+
+src_install()
+{
+ dobin Clip
+ dodoc README.txt
+}