aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-22 23:59:10 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-22 23:59:10 +0100
commitfe418d2a22adb262aaa7f4b4aa136fe5200e8240 (patch)
treec86050e76cc1a0ab58fab2bde384018a89c5f8b1 /sci-physics/genfit/genfit-02.00.00.ebuild
parentUse zip'ed code snapshot instead of checking out tag from repository. (diff)
downloadsci-fe418d2a22adb262aaa7f4b4aa136fe5200e8240.tar.gz
sci-fe418d2a22adb262aaa7f4b4aa136fe5200e8240.tar.bz2
sci-fe418d2a22adb262aaa7f4b4aa136fe5200e8240.zip
Fix incorrect working directory (adapt to zipped file).
Diffstat (limited to 'sci-physics/genfit/genfit-02.00.00.ebuild')
-rw-r--r--sci-physics/genfit/genfit-02.00.00.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 46993c7d0..596f3e9e1 100644
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -9,9 +9,11 @@ inherit cmake-utils versionator
#ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/tags/v$(replace_all_version_separators '-')"
#ESVN_PROJECT="${PN}.${PV}"
+TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
+
DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
HOMEPAGE="http://genfit.sourceforge.net/Main.html"
-SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/genfit-code-1688-tags-v$(replace_all_version_separators '-').zip"
+SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
LICENSE="LGPL-3"
SLOT="0"
@@ -24,6 +26,8 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
+S=${WORKDIR}/${TAG_VER}
+
src_compile() {
cmake-utils_src_compile
use doc && cmake-utils_src_compile doc