aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2014-04-03 08:35:21 -0700
committerSébastien Fabbro <bicatali@gentoo.org>2014-04-03 08:35:21 -0700
commit87028c6d48207335e42580890a6229ab2981bd71 (patch)
tree9b77b2892515bd93f64d076ec010e60b5aec52ba /sci-physics/genfit
parentMerge pull request #215 from olifre/fix-sf-zip-snapshots (diff)
downloadsci-87028c6d48207335e42580890a6229ab2981bd71.tar.gz
sci-87028c6d48207335e42580890a6229ab2981bd71.tar.bz2
sci-87028c6d48207335e42580890a6229ab2981bd71.zip
Link fixed version ebuild to live one, add no keyword to live version
Diffstat (limited to 'sci-physics/genfit')
-rw-r--r--sci-physics/genfit/ChangeLog4
l---------[-rw-r--r--]sci-physics/genfit/genfit-02.00.00.ebuild60
-rw-r--r--sci-physics/genfit/genfit-9999.ebuild15
-rw-r--r--sci-physics/genfit/metadata.xml54
4 files changed, 41 insertions, 92 deletions
diff --git a/sci-physics/genfit/ChangeLog b/sci-physics/genfit/ChangeLog
index 589ad4814..abce61eaf 100644
--- a/sci-physics/genfit/ChangeLog
+++ b/sci-physics/genfit/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Apr 2014; Sebastien Fabbro <fabbros@gentoo.org> genfit-9999.ebuild,
+ metadata.xml:
+ Link fixed version ebuild to live one, add no keyword to live version
+
03 Apr 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
genfit-02.00.00.ebuild:
Use zip-snapshot mirrored by jlec, sourceforge cannot automatically recreate
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 5e095a52f..c4f24f2cb 100644..120000
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -1,59 +1 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit cmake-utils versionator
-
-if [[ ${PV} == *9999* ]]; then
- inherit subversion
- ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
- ESVN_PROJECT="${PN}.${PV}"
-else
- # .zip-snapshot can be recreated by visiting
- # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
- TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
- #SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
- SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S=${WORKDIR}/${TAG_VER}
-fi
-
-DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
-HOMEPAGE="http://genfit.sourceforge.net/Main.html"
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- sci-physics/root:=
- dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
- use examples && cmake-utils_src_compile tests
-}
-
-src_install() {
- cmake-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${BUILD_DIR}/bin"
- doins "${S}/test/makeGeom.C"
- doins "${S}/test/README"
- fi
- cd doc || die
- use doc && dohtml -r "${S}/doc/html/"*
- echo
- elog "Note that there is no support in this ebuild for RAVE yet,"
- elog "which is also not in portage."
- elog "It should be possible to use a local installation of RAVE"
- elog "and set:"
- elog " export RAVEPATH=<yourRaveDirectory>"
- echo
-}
+genfit-9999.ebuild \ No newline at end of file
diff --git a/sci-physics/genfit/genfit-9999.ebuild b/sci-physics/genfit/genfit-9999.ebuild
index 963de559e..af8350449 100644
--- a/sci-physics/genfit/genfit-9999.ebuild
+++ b/sci-physics/genfit/genfit-9999.ebuild
@@ -10,14 +10,18 @@ if [[ ${PV} == *9999* ]]; then
inherit subversion
ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
ESVN_PROJECT="${PN}.${PV}"
+ KEYWORDS=""
else
+ # .zip-snapshot can be recreated by visiting
+ # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
- SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+ #SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S=${WORKDIR}/${TAG_VER}
fi
-DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
+DESCRIPTION="Generic toolkit for track reconstruction in physics experiments"
HOMEPAGE="http://genfit.sourceforge.net/Main.html"
LICENSE="LGPL-3"
@@ -41,11 +45,10 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}
doins -r "${BUILD_DIR}/bin"
- doins "${S}/test/makeGeom.C"
- doins "${S}/test/README"
+ doins test/makeGeom.C
+ doins test/README
fi
- cd doc || die
- use doc && dohtml -r "${S}/doc/html/"*
+ use doc && dohtml -r doc/html/*
echo
elog "Note that there is no support in this ebuild for RAVE yet,"
elog "which is also not in portage."
diff --git a/sci-physics/genfit/metadata.xml b/sci-physics/genfit/metadata.xml
index b767bdd9f..5fae1b626 100644
--- a/sci-physics/genfit/metadata.xml
+++ b/sci-physics/genfit/metadata.xml
@@ -1,31 +1,31 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-physics</herd>
- <longdescription lang="en">
-GENFIT is an experiment-independent framework for track reconstruction for
-particle and nuclear physics. It consists of three modular components:
-- Track fitting algorithms
- Currently, GENFIT contains a Kalman Filter and a
- Deterministic Annealing Filter.
- Other algorithm modules can be added easily.
-- Track representations
- These modules hold the data of track track parameters and can perform
- extrapolations of these parameters.
- GENFIT is distributed with two well-tested track representations.
- Existing track extrapolation codes can be interfaced in a very
- straightforward way in this framework, using their native geometry
- and magnetic field interfaces.
-- Reconstruction hits
- The hit dimensionality and the orientation of planar tracking detectors
- can be chosen freely.
-GENFIT is especially useful for tracking systems which include detectors
-which do not measure the passage of particles on predefined planes,
-like TPCs or wire-based drift chambers. The concept of so-called
-virtual detector planes provides a simple mechanism to use these
-detector hits in a transparent way without any geometrical simplifications.
-GENFIT has been developed in the framework of the PANDA experiment at
-FAIR, Darmstadt, Germany.
-It is also used in the Belle-2, Fopi, and GEM-TPC experiments.
- </longdescription>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ GENFIT is an experiment-independent framework for track reconstruction for
+ particle and nuclear physics. It consists of three modular components:
+ - Track fitting algorithms
+ Currently, GENFIT contains a Kalman Filter and a
+ Deterministic Annealing Filter.
+ Other algorithm modules can be added easily.
+ - Track representations
+ These modules hold the data of track track parameters and can perform
+ extrapolations of these parameters.
+ GENFIT is distributed with two well-tested track representations.
+ Existing track extrapolation codes can be interfaced in a very
+ straightforward way in this framework, using their native geometry
+ and magnetic field interfaces.
+ - Reconstruction hits
+ The hit dimensionality and the orientation of planar tracking detectors
+ can be chosen freely.
+ GENFIT is especially useful for tracking systems which include detectors
+ which do not measure the passage of particles on predefined planes,
+ like TPCs or wire-based drift chambers. The concept of so-called
+ virtual detector planes provides a simple mechanism to use these
+ detector hits in a transparent way without any geometrical simplifications.
+ GENFIT has been developed in the framework of the PANDA experiment at
+ FAIR, Darmstadt, Germany.
+ It is also used in the Belle-2, Fopi, and GEM-TPC experiments.
+</longdescription>
</pkgmetadata>