aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2016-06-02 20:46:26 +0300
committerAndrew Savchenko <bircoph@gmail.com>2016-06-02 20:46:26 +0300
commit5e68a3da81c6d9bf49e34befae47d3e497c214cb (patch)
tree9629125be1feb58bc78dea7d6c269371ed52aa41 /sci-physics/qcl/qcl-0.6.4-r1.ebuild
parentsci-physics/qcl: adjust patch level for eapply defaults (diff)
downloadsci-5e68a3da81c6d9bf49e34befae47d3e497c214cb.tar.gz
sci-5e68a3da81c6d9bf49e34befae47d3e497c214cb.tar.bz2
sci-5e68a3da81c6d9bf49e34befae47d3e497c214cb.zip
sci-physics/qcl: rectify ebuild
- bump to EAPI 6; - add missing bison/flex deps; - plotutils and readline deps are now controlled by USE flags; - apply LDFLAGS properly (before list of object files). Package-Manager: portage-2.3.0_rc1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'sci-physics/qcl/qcl-0.6.4-r1.ebuild')
-rw-r--r--sci-physics/qcl/qcl-0.6.4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-physics/qcl/qcl-0.6.4-r1.ebuild b/sci-physics/qcl/qcl-0.6.4-r1.ebuild
new file mode 100644
index 000000000..0cf48e475
--- /dev/null
+++ b/sci-physics/qcl/qcl-0.6.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
+HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
+SRC_URI="
+ http://tph.tuwien.ac.at/~oemer/tgz/${P}.tgz
+ doc? (
+ http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf
+ )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc plotutils readline"
+
+REPEND="
+ plotutils? ( media-libs/plotutils[X,png] )
+ readline? (
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ )"
+DEPEND="${DEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.6.3-gcc43.patch
+ "${FILESDIR}/${P}"-makefile_v2.patch
+)
+
+src_configure() {
+ # there is no configure, Makefile must be modified
+ if ! use plotutils; then
+ sed -i 's/^PL/#PL/' Makefile || die
+ fi
+ if ! use readline; then
+ sed -i 's/^RL/#RL/' Makefile || die
+ fi
+}
+
+src_install() {
+ emake \
+ QCLDIR="${D}/usr/share/${PN}" \
+ QCLBIN="${D}/usr/bin" install
+ use doc && dodoc {structquprog,qcldoc,quprog}.pdf
+}