aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-06-02 19:08:17 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2014-06-02 19:08:17 +0200
commit8e1c26dee1b315620a9b4623cf9431e4c8a5a019 (patch)
treec77cf92ab1e5de1d76c139328f24075e906e2d0b /sci-physics/qcl/qcl-0.6.4.ebuild
parentMerge remote-tracking branch 'gentoo/master' into upstream-master (diff)
downloadsci-8e1c26dee1b315620a9b4623cf9431e4c8a5a019.tar.gz
sci-8e1c26dee1b315620a9b4623cf9431e4c8a5a019.tar.bz2
sci-8e1c26dee1b315620a9b4623cf9431e4c8a5a019.zip
sci-physics/qcl: version bump to 0.6.4
Diffstat (limited to 'sci-physics/qcl/qcl-0.6.4.ebuild')
-rw-r--r--sci-physics/qcl/qcl-0.6.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-physics/qcl/qcl-0.6.4.ebuild b/sci-physics/qcl/qcl-0.6.4.ebuild
new file mode 100644
index 000000000..9338be1cd
--- /dev/null
+++ b/sci-physics/qcl/qcl-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
+HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+SRC_URI="http://tph.tuwien.ac.at/~oemer/tgz/${P}.tgz
+ doc? ( http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf )"
+DEPEND="media-libs/plotutils
+ sys-libs/ncurses
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.3-gcc43.patch" "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_install() {
+ emake \
+ QCLDIR="${D}/usr/share/${PN}" \
+ QCLBIN="${D}/usr/bin" install
+ dodoc README CHANGES
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf || die
+ fi
+}