aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2012-05-30 02:59:34 +0400
committerAndrew Savchenko <bircoph@gmail.com>2012-05-30 02:59:34 +0400
commit2f8112e0becd3197a6c9df2518236fe6a8095c95 (patch)
tree0e7a03128d8e4b797b3ec006ab83f5f067642b5f /sci-physics/root/files
parentinitial commit (diff)
downloadsci-2f8112e0becd3197a6c9df2518236fe6a8095c95.tar.gz
sci-2f8112e0becd3197a6c9df2518236fe6a8095c95.tar.bz2
sci-2f8112e0becd3197a6c9df2518236fe6a8095c95.zip
sci-physics/root: html documentation generation
This adds htmldoc USE flag to generate what was previously app-doc/root-docs. Fonts for dot charts are fixed.
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.32.00-dotfont.patch58
-rw-r--r--sci-physics/root/files/root-5.32.00-htmldoc.patch50
-rw-r--r--sci-physics/root/files/root-5.34-htmldoc.patch58
3 files changed, 166 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-5.32.00-dotfont.patch b/sci-physics/root/files/root-5.32.00-dotfont.patch
new file mode 100644
index 000000000..85d6dea76
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-dotfont.patch
@@ -0,0 +1,58 @@
+--- root/html/src/TClassDocOutput.cxx.orig 2012-05-25 16:18:10.000000000 +0400
++++ root/html/src/TClassDocOutput.cxx 2012-05-29 21:36:53.813593012 +0400
+@@ -625,7 +625,7 @@
+ << "size=\"8,10\";" << endl
+ << "ratio=auto;" << endl
+ << "margin=0;" << endl
+- << "node [shape=plaintext,fontsize=40,width=4,height=0.75];" << endl
++ << "node [shape=plaintext,fontsize=40,width=4,height=0.75,fontname=\"DejaVu Serif\"];" << endl
+ << "\"" << fCurrentClass->GetName() << "\" [shape=ellipse];" << endl;
+
+ std::stringstream ssDep;
+@@ -704,7 +704,7 @@
+ outdot << ";" << endl;
+ } else if (writeAndMoreFor) {
+ outdot << " \"...andmore" << writeAndMoreFor->GetName()
+- << "\" [label=\"...and more\",fontname=\"Times-Italic\",fillcolor=lightgrey,style=filled];" << endl;
++ << "\" [label=\"...and more\",fontname=\"DejaVu Serif Italic\",fillcolor=lightgrey,style=filled];" << endl;
+ }
+ }
+ if (!levelExists) break;
+@@ -733,7 +733,7 @@
+ << "ranksep=0.1;" << endl
+ << "nodesep=0;" << endl
+ << "margin=0;" << endl;
+- outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10];" << endl;
++ outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10,fontname=\"DejaVu Serif\"];" << endl;
+
+ std::stringstream ssDep;
+ const int numColumns = 3;
+@@ -939,7 +939,7 @@
+ << "ranksep=0;" << endl
+ << "nodesep=0;" << endl
+ << "size=\"8,10\";" << endl
+- << "node [fontsize=20,shape=plaintext];" << endl;
++ << "node [fontsize=20,shape=plaintext,fontname=\"DejaVu Serif\"];" << endl;
+
+ for (std::list<std::string>::iterator iFile = listFilesToParse.begin();
+ iFile != listFilesToParse.end(); ++iFile) {
+@@ -999,7 +999,8 @@
+ << "ranksep=0.7;" << endl
+ << "nodesep=0.3;" << endl
+ << "size=\"8,8\";" << endl
+- << "ratio=compress;" << endl;
++ << "ratio=compress;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ TString libs(fCurrentClass->GetSharedLibs());
+ outdot << "\"All Libraries\" [URL=\"LibraryDependencies.html\",shape=box,rank=max,fillcolor=lightgray,style=filled];" << endl;
+@@ -1109,7 +1110,8 @@
+
+ dotout << "digraph G {" << endl
+ << "ratio=auto;" << endl
+- << "rankdir=RL;" << endl;
++ << "rankdir=RL;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ // loop on all classes
+ TClassDocInfo* cdi = 0;
diff --git a/sci-physics/root/files/root-5.32.00-htmldoc.patch b/sci-physics/root/files/root-5.32.00-htmldoc.patch
new file mode 100644
index 000000000..e6d498187
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-htmldoc.patch
@@ -0,0 +1,50 @@
+--- root/Makefile.orig 2012-05-23 21:07:07.000000000 +0400
++++ root/Makefile 2012-05-23 22:47:48.935680301 +0400
+@@ -1039,8 +1039,7 @@
+ releasenotes:
+ @$(MAKERELNOTES)
+
+-html: $(ROOTEXE) changelog releasenotes
+- @$(MAKELOGHTML)
++html: $(ROOTEXE) releasenotes
+ @$(MAKEHTML)
+
+ # Use DESTDIR to set a sandbox prior to calling "make install", e.g.:
+--- root/build/unix/makehtml.sh.orig 2012-05-23 23:25:45.000000000 +0400
++++ root/build/unix/makehtml.sh 2012-05-24 13:04:43.919062126 +0400
+@@ -6,12 +6,12 @@
+ cd tutorials
+ # we need tutorials/hsimple.root
+ if [ ! -f hsimple.root ]; then
+- $ROOT -l -b -q hsimple.C
++ ../$ROOT -l -b -q hsimple.C && exit 1
+ fi
+ cd tree
+ # we need tutorials/tree/cernstaff.root
+ if [ ! -f cernstaff.root ]; then
+- $ROOT -l -b -q cernbuild.C
++ ../../$ROOT -l -b -q cernbuild.C || exit 1
+ fi
+ cd $dir
+
+@@ -19,7 +19,7 @@
+ echo "Generating doc in directory htmldoc/..."
+ echo ""
+
+-$ROOT -l <<makedoc
++$ROOT -l <<makedoc || exit 1
+ THtml h;
+ h.LoadAllLibs();
+ h.MakeAll();
+--- root/html/src/THtml.cxx.orig 2012-05-25 16:18:10.000000000 +0400
++++ root/html/src/THtml.cxx 2012-05-29 19:22:40.810563296 +0400
+@@ -1913,6 +1913,9 @@
+ void THtml::CreateStyleSheet() const {
+ // Write the default ROOT style sheet.
+ CopyFileFromEtcDir("ROOT.css");
++ CopyFileFromEtcDir("info.png");
++ CopyFileFromEtcDir("root-banner.png");
++ CopyFileFromEtcDir("rootdrawing-logo.png");
+ CopyFileFromEtcDir("shadowAlpha.png");
+ CopyFileFromEtcDir("shadow.gif");
+ }
diff --git a/sci-physics/root/files/root-5.34-htmldoc.patch b/sci-physics/root/files/root-5.34-htmldoc.patch
new file mode 100644
index 000000000..a999d0ced
--- /dev/null
+++ b/sci-physics/root/files/root-5.34-htmldoc.patch
@@ -0,0 +1,58 @@
+--- root/Makefile.orig 2012-05-30 00:50:46.000000000 +0400
++++ root/Makefile 2012-05-30 00:51:05.839679686 +0400
+@@ -1088,16 +1088,7 @@
+ releasenotes:
+ @$(MAKERELNOTES)
+
+-html: $(ROOTEXE) changelog releasenotes
+-ifneq ($(USECONFIG),FALSE)
+- @if [ "x`which root.exe`" != "x$(DESTDIR)$(BINDIR)/root.exe" ] \
+- || [ "`which root.exe`" -ot "bin/root.exe" ]; then \
+- echo 'ERROR: root.exe has not been installed by this build.'; \
+- echo ' Run "make install" before running "make html".'; \
+- exit 1; \
+- fi
+-endif
+- @$(MAKELOGHTML)
++html: $(ROOTEXE) releasenotes
+ @$(MAKEHTML)
+
+ # Use DESTDIR to set a sandbox prior to calling "make install", e.g.:
+--- root/build/unix/makehtml.sh.orig 2012-05-23 23:25:45.000000000 +0400
++++ root/build/unix/makehtml.sh 2012-05-24 13:04:43.919062126 +0400
+@@ -6,12 +6,12 @@
+ cd tutorials
+ # we need tutorials/hsimple.root
+ if [ ! -f hsimple.root ]; then
+- $ROOT -l -b -q hsimple.C
++ ../$ROOT -l -b -q hsimple.C && exit 1
+ fi
+ cd tree
+ # we need tutorials/tree/cernstaff.root
+ if [ ! -f cernstaff.root ]; then
+- $ROOT -l -b -q cernbuild.C
++ ../../$ROOT -l -b -q cernbuild.C || exit 1
+ fi
+ cd $dir
+
+@@ -19,7 +19,7 @@
+ echo "Generating doc in directory htmldoc/..."
+ echo ""
+
+-$ROOT -l <<makedoc
++$ROOT -l <<makedoc || exit 1
+ THtml h;
+ h.LoadAllLibs();
+ h.MakeAll();
+--- root/html/src/THtml.cxx.orig 2012-05-25 16:18:10.000000000 +0400
++++ root/html/src/THtml.cxx 2012-05-29 19:22:40.810563296 +0400
+@@ -1913,6 +1913,9 @@
+ void THtml::CreateStyleSheet() const {
+ // Write the default ROOT style sheet.
+ CopyFileFromEtcDir("ROOT.css");
++ CopyFileFromEtcDir("info.png");
++ CopyFileFromEtcDir("root-banner.png");
++ CopyFileFromEtcDir("rootdrawing-logo.png");
+ CopyFileFromEtcDir("shadowAlpha.png");
+ CopyFileFromEtcDir("shadow.gif");
+ }