aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2015-02-23 20:55:43 +0300
committerAndrew Savchenko <bircoph@gmail.com>2015-02-23 20:55:43 +0300
commit50ecc91f9162478c5fcc3f8595a566da758feaf1 (patch)
tree3c588011b7a0624e6be46f329410d842784908fb /sci-physics/root/files
parentapp-doc/root-docs: remove old (diff)
downloadsci-50ecc91f9162478c5fcc3f8595a566da758feaf1.tar.gz
sci-50ecc91f9162478c5fcc3f8595a566da758feaf1.tar.bz2
sci-50ecc91f9162478c5fcc3f8595a566da758feaf1.zip
sci-physics/root/: remove old
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.32.00-prop-flags.patch15
-rw-r--r--sci-physics/root/files/root-5.34.18-tutorials-path.patch94
-rw-r--r--sci-physics/root/files/root-6.00.01-cling.patch19
3 files changed, 0 insertions, 128 deletions
diff --git a/sci-physics/root/files/root-5.32.00-prop-flags.patch b/sci-physics/root/files/root-5.32.00-prop-flags.patch
deleted file mode 100644
index 7dfeb1cc3..000000000
--- a/sci-physics/root/files/root-5.32.00-prop-flags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- root/config/Makefile.in.orig 2013-01-21 22:04:43.011452938 +0400
-+++ root/config/Makefile.in 2013-01-21 22:04:18.027352209 +0400
-@@ -25,9 +25,9 @@
- USECONFIG := @useconfig@
- MKLIBOPTIONS := @mkliboption@
-
--EXTRA_CFLAGS := -Iinclude @cflags@
--EXTRA_CXXFLAGS := -Iinclude @cflags@
--EXTRA_LDFLAGS := @ldflags@
-+EXTRA_CFLAGS := -Iinclude @cflags@ $(CFLAGS)
-+EXTRA_CXXFLAGS := -Iinclude @cflags@ $(CXXFLAGS)
-+EXTRA_LDFLAGS := @ldflags@ $(LDFLAGS)
- WINRTDEBUG := @winrtdebug@
-
- GLBPATCHFLAGS := @glbpatchcflags@
diff --git a/sci-physics/root/files/root-5.34.18-tutorials-path.patch b/sci-physics/root/files/root-5.34.18-tutorials-path.patch
deleted file mode 100644
index 8bf88594d..000000000
--- a/sci-physics/root/files/root-5.34.18-tutorials-path.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-diff --git a/config/RConfigure.in b/config/RConfigure.in
-index 5950401..e4fbfbf 100644
---- a/config/RConfigure.in
-+++ b/config/RConfigure.in
-@@ -11,6 +11,7 @@
- #define ROOTDATADIR "@datadir@"
- #define ROOTDOCDIR "@docdir@"
- #define ROOTMACRODIR "@macrodir@"
-+#define ROOTTUTDIR "@tutdir@"
- #define ROOTSRCDIR "@srcdir@"
- #define ROOTICONPATH "@iconpath@"
- #define EXTRAICONPATH "@extraiconpath@"
-diff --git a/configure b/configure
-index 131df92..2c8ea95 100755
---- a/configure
-+++ b/configure
-@@ -7537,6 +7537,7 @@ sed \
- -e "s|@prefix@|$prefix|" \
- -e "s|@srcdir@|$srcdir|" \
- -e "s|@ttffontdir@|$fontdir|" \
-+ -e "s|@tutdir@|$tutdir|" \
- -e "s|@setresuid@|$setresuid|" \
- -e "s|@hasmathmore@|$hasmathmore|" \
- -e "s|@haspthread@|$haspthread|" \
-diff --git a/core/base/src/TApplication.cxx b/core/base/src/TApplication.cxx
-index 95fb1e5..3830955 100644
---- a/core/base/src/TApplication.cxx
-+++ b/core/base/src/TApplication.cxx
-@@ -794,6 +794,22 @@ Long_t TApplication::ProcessRemote(const char *line, Int_t *)
- return 1;
- }
-
-+namespace {
-+ static int PrintFile(const char* filename) {
-+ TString sFileName(filename);
-+ gSystem->ExpandPathName(sFileName);
-+ if (gSystem->AccessPathName(sFileName)) {
-+ Error("ProcessLine()", "Cannot find file %s", filename);
-+ return 1;
-+ }
-+ std::ifstream instr(sFileName);
-+ TString content;
-+ content.ReadFile(instr);
-+ Printf("%s", content.Data());
-+ return 0;
-+ }
-+}
-+
- //______________________________________________________________________________
- Long_t TApplication::ProcessLine(const char *line, Bool_t sync, Int_t *err)
- {
-@@ -827,11 +843,41 @@ Long_t TApplication::ProcessLine(const char *line, Bool_t sync, Int_t *err)
- return 0;
- }
-
-- if (!strncmp(line, "?", 1)) {
-+ if (!strncmp(line, "?", 1) || !strncmp(line, ".help", 5)) {
- Help(line);
- return 1;
- }
-
-+ if (!strncmp(line, ".demo", 5)) {
-+ if (gROOT->IsBatch()) {
-+ Error("ProcessLine", "Cannot show demos in batch mode!");
-+ return 1;
-+ }
-+#ifdef ROOTTUTDIR
-+ ProcessLine(".x " ROOTTUTDIR "/demos.C");
-+#else
-+ ProcessLine(".x $(ROOTSYS)/tutorials/demos.C");
-+#endif
-+ return 0;
-+ }
-+
-+ if (!strncmp(line, ".license", 8)) {
-+#ifdef ROOTDOCDIR
-+ return PrintFile(ROOTDOCDIR "/LICENSE");
-+#else
-+ return PrintFile("$(ROOTSYS)/LICENSE");
-+#endif
-+ }
-+
-+ if (!strncmp(line, ".credits", 8)) {
-+#ifdef ROOTDOCDIR
-+ return PrintFile(ROOTDOCDIR "/CREDITS");
-+#else
-+ return PrintFile("$(ROOTSYS)/README/CREDITS");
-+#endif
-+
-+ }
-+
- if (!strncmp(line, ".pwd", 4)) {
- if (gDirectory)
- Printf("Current directory: %s", gDirectory->GetPath());
diff --git a/sci-physics/root/files/root-6.00.01-cling.patch b/sci-physics/root/files/root-6.00.01-cling.patch
deleted file mode 100644
index 146e89fde..000000000
--- a/sci-physics/root/files/root-6.00.01-cling.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit eea9517c17bd86beda895a5a8b3ffe59af18596f
-Author: Axel Naumann <Axel.Naumann@cern.ch>
-Date: Tue Jul 1 17:45:20 2014 +0200
-
- From Pere: go via TSystem to use prefix if defined (ROOT-6410).
-
-diff --git a/core/meta/src/TCling.cxx b/core/meta/src/TCling.cxx
-index baec571..4976d4e 100644
---- a/core/meta/src/TCling.cxx
-+++ b/core/meta/src/TCling.cxx
-@@ -4703,7 +4703,7 @@ void* TCling::LazyFunctionCreatorAutoload(const std::string& mangled_name) {
- TString lib;
- Ssiz_t posLib = 0;
- while (libs.Tokenize(lib, posLib)) {
-- if (Load(lib, kFALSE /*system*/) < 0) {
-+ if (gSystem->Load(lib, "", kFALSE /*system*/) < 0) {
- // The library load failed, all done.
- //fprintf(stderr, "load failed: %s\n", errmsg.c_str());
- return 0;