aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-01-06 00:36:20 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-01-06 00:36:20 +0800
commit0b0dfebc137e0a8b65cb1604b5ee514bbd4a18d1 (patch)
treea9b527800e9cf0c5545c5b160ffef88ad57b6541 /sci-physics/uproot-methods
parentsci-libs/awkward-array: initial commit. (diff)
downloadsci-0b0dfebc137e0a8b65cb1604b5ee514bbd4a18d1.tar.gz
sci-0b0dfebc137e0a8b65cb1604b5ee514bbd4a18d1.tar.bz2
sci-0b0dfebc137e0a8b65cb1604b5ee514bbd4a18d1.zip
sci-physics/uproot-methods: initial commit.
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-physics/uproot-methods')
-rw-r--r--sci-physics/uproot-methods/Manifest1
-rw-r--r--sci-physics/uproot-methods/metadata.xml7
-rw-r--r--sci-physics/uproot-methods/uproot-methods-0.7.2.ebuild20
3 files changed, 28 insertions, 0 deletions
diff --git a/sci-physics/uproot-methods/Manifest b/sci-physics/uproot-methods/Manifest
new file mode 100644
index 000000000..e9946ccd0
--- /dev/null
+++ b/sci-physics/uproot-methods/Manifest
@@ -0,0 +1 @@
+DIST uproot-methods-0.7.2.tar.gz 25121 BLAKE2B 3e7af6001769e0b72ba8e29db169e7a62d54c64b737dd6bccdbb52747acef753af0398846056b5858557f506242786194bcfe442fb01e07e485b42cf6f3f434b SHA512 ce1662890ac5795ad090543c11e5525f2b94f7551cdaf5de25bdb085992c0b330d60d0e77c11f4b7f823a79784f4fad7f843e3bf665ee8376dc0362dd4314000
diff --git a/sci-physics/uproot-methods/metadata.xml b/sci-physics/uproot-methods/metadata.xml
new file mode 100644
index 000000000..7203fb853
--- /dev/null
+++ b/sci-physics/uproot-methods/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-physics/uproot-methods/uproot-methods-0.7.2.ebuild b/sci-physics/uproot-methods/uproot-methods-0.7.2.ebuild
new file mode 100644
index 000000000..f6aab1a35
--- /dev/null
+++ b/sci-physics/uproot-methods/uproot-methods-0.7.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulate arrays of complex data structures as easily as Numpy."
+HOMEPAGE="https://github.com/scikit-hep/${PN}"
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/awkward-array[${PYTHON_USEDEP}]"
+DEPEND=""