aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2014-07-06 22:31:52 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2014-07-06 22:31:52 +0200
commit20fec395aeec140cb11e0cde9c7c486434e36f5a (patch)
treefd39f59c96baeb8a600a3d062161a0b28ede8d9e /sci-physics
parentNew live ebuild, using cmake-buildsystem (upstream switches to cmake for next... (diff)
downloadsci-20fec395aeec140cb11e0cde9c7c486434e36f5a.tar.gz
sci-20fec395aeec140cb11e0cde9c7c486434e36f5a.tar.bz2
sci-20fec395aeec140cb11e0cde9c7c486434e36f5a.zip
New live ebuild for VGM, adapting to fixes for cmake install paths in upstream (no need to manually install in ebuild anymore).
Released VGM-4.00 does not have these fixes yet, I am discussing with upstream whether they can also provide some tarballs of released versions (as sourceforge svn-snapshotting is unusable for us) and delay packaging of VGM-4.00 until then.
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/vgm/ChangeLog6
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild68
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-physics/vgm/ChangeLog b/sci-physics/vgm/ChangeLog
index 78f7e21fc..a3163895b 100644
--- a/sci-physics/vgm/ChangeLog
+++ b/sci-physics/vgm/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*vgm-9999 (06 Jul 2014)
+
+ 06 Jul 2014; Oliver Freyermuth <o.freyermuth@googlemail.com> +vgm-9999.ebuild:
+ New live ebuild for VGM, adapting to fixes for cmake install paths in upstream
+ (no need to manually install in ebuild anymore).
+
03 Apr 2014; Oliver Freyermuth <o.freyermuth@googlemail.com> vgm-3.06.ebuild:
Use zip-snapshot mirrored by jlec, sourceforge cannot automatically recreate
them and changes CRC each time
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
new file mode 100644
index 000000000..ddadd9970
--- /dev/null
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator subversion
+
+if [[ ${PV} == *9999* ]]; then
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/vgm/code/trunk/vgm"
+ KEYWORDS=""
+else
+ # .zip-snapshot can be recreated by visiting
+ # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
+ TAG_VER="${PN}-code-731-tags-v$(replace_all_version_separators '-')"
+ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
+ S=${WORKDIR}/${TAG_VER}/${PN}
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples +geant4 +root test xml"
+
+RDEPEND="
+ sci-physics/clhep:=
+ root? ( sci-physics/root:= )
+ geant4? ( >=sci-physics/geant-4.9.6 )
+ xml? ( dev-libs/xerces-c )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( geant4? ( xml? ( >=sci-physics/geant-4.9.6[gdml] ) ) )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_DIR="${EROOT}usr"
+ $(cmake-utils_use_with examples)
+ $(cmake-utils_use examples VGM_INSTALL_EXAMPLES)
+ $(cmake-utils_use_with geant4)
+ $(cmake-utils_use_with root)
+ $(cmake-utils_use_with test)
+ $(cmake-utils_use_with xml xercesc)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd packages
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test
+ ./test_suite.sh || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd doc || die
+ dodoc README todo.txt VGMhistory.txt VGM.html VGMversions.html
+ use doc && dohtml -r html/*
+}