aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2013-11-20 23:15:07 +0100
committerJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2013-11-20 23:15:07 +0100
commit39aa9892238b3fc59b194b9a1a5b5b47e4079dac (patch)
tree40eed1abe8bcae59ffdb9a49becefae0b5750921 /sci-physics
parentsci-physics/mc-tester: ebuild added (diff)
downloadsci-39aa9892238b3fc59b194b9a1a5b5b47e4079dac.tar.gz
sci-39aa9892238b3fc59b194b9a1a5b5b47e4079dac.tar.bz2
sci-39aa9892238b3fc59b194b9a1a5b5b47e4079dac.zip
sci-physics/mc-tester: ebuild improvements, thanks to jlec
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch12
-rw-r--r--sci-physics/mc-tester/mc-tester-1.25.0.ebuild14
2 files changed, 19 insertions, 7 deletions
diff --git a/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
index 3cf0e3033..180dcb029 100644
--- a/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
+++ b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
@@ -1,6 +1,6 @@
--- analyze/compare.sh
+++ analyze/compare.sh
-@@ -6,13 +6,13 @@
+@@ -6,13 +6,14 @@
#----------------------------------
# Change these variables
#----------------------------------
@@ -15,6 +15,16 @@
-MCTESTER_ANALYZE_DIR=${MCTESTER_DIR}/analyze
+MCTESTER_ANALYZE_DIR=${MCTESTER_DIR}/libexec/mc-tester/analyze
++MCTESTER_DATA_DIR=${MCTESTER_DIR}/share/mc-tester
export MC_TESTER_LIBS_DIR=${MCTESTER_DIR}/lib
WORKING_DIR=`pwd`
+@@ -24,7 +25,7 @@
+ cd $WORKING_DIR
+
+ #copy base .tex file needed for booklet and create
+-cp ${MCTESTER_ANALYZE_DIR}/tester.tex ./
++cp ${MCTESTER_DATA_DIR}/tester.tex ./
+ latex tester.tex
+ latex tester.tex
+ latex tester.tex
diff --git a/sci-physics/mc-tester/mc-tester-1.25.0.ebuild b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
index 80fb6bc47..43f835d4d 100644
--- a/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
+++ b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
@@ -32,22 +32,24 @@ src_prepare() {
src_configure() {
econf \
- --with-root="/usr" \
+ --with-root="${EPREFIX}/usr" \
--without-Pythia8 \
- $(use_with hepmc HepMC "/usr")
+ $(use_with hepmc HepMC "${EPREFIX}/usr")
}
src_compile() {
emake
- use doc && cd doc && make || die
+ use doc && cd doc && emake
}
src_install() {
emake PREFIX="${D}/usr" install
- exeinto /usr/bin
- newexe analyze/compare.sh mc-tester-compare
+ newbin analyze/compare.sh mc-tester-compare
+
insinto /usr/libexec/${PN}/analyze
- doins analyze/*.C analyze/*.tex
+ doins analyze/*.C
+ insinto /usr/share/${PN}
+ doins analyze/*.tex
if use doc; then
dohtml doc/doxygenDocs/html/*