aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-08-15 13:29:55 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-08-15 13:29:55 +0200
commit5dc13cc076640606a56984036c06d44311adfc5d (patch)
treee6a9d3da1cf8f5703d445d98c9c746b84eab5085 /sci-physics
parentMerge pull request #461 from mschubert/tophat_2.1.0 (diff)
downloadsci-5dc13cc076640606a56984036c06d44311adfc5d.tar.gz
sci-5dc13cc076640606a56984036c06d44311adfc5d.tar.bz2
sci-5dc13cc076640606a56984036c06d44311adfc5d.zip
[sci-physics/yoda] version bump
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/ChangeLog7
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.4.0.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/sci-physics/yoda/ChangeLog b/sci-physics/yoda/ChangeLog
index 72d87df97..9bba03c9f 100644
--- a/sci-physics/yoda/ChangeLog
+++ b/sci-physics/yoda/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-physics/yoda
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*yoda-1.4.0 (15 Aug 2015)
+
+ 15 Aug 2015; Jauhien Piatlicki <jauhien@gentoo.org> +yoda-1.4.0.ebuild:
+ version bump
+
*yoda-1.0.6 (06 May 2014)
06 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 6e5b4038b..c889926c0 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.0.6.tar.bz2 689998 SHA256 357732448d67a593e5ff004418f2a2a263a1401ffe84e021f8a714aa183eaa21 SHA512 e0e63d30259d0d5cf7589e7228ea80b029683832058930a79d4be532535e96504c0362d28881503fb98f9fd7ab6721d4975681464e24294ae55cd47dc671873f WHIRLPOOL 5214f0e961380708d600d04f058a2a29286a933b02d5dc33fa472c63a38414cd1ca5104d8dd1e6dd8cc78e16bad85a61bc1b9b47b1326d214e8439b133d1b521
+DIST YODA-1.4.0.tar.bz2 809432 SHA256 e76a129f7c2b72b53525fe0b712606eeeab0dc145daa070ebf0728f0384eaf48 SHA512 f1873888f3d2c28d42ac54fa9f3fa4a98e648a638ebceffce0a2f742c5fb6647fabd0de49c00407741e937600fc8a12d33ca26b8b9cd9b81c28a4d2e11f2bd3a WHIRLPOOL 6c8e0176b729d951351b3b9d574c91add5d6302aa76417241e560f3f3bbf38f4b60f41713d89a03a62b1c4ad3a98bd5342fd05901671e6aedf0c2c11dc36b024
diff --git a/sci-physics/yoda/yoda-1.4.0.ebuild b/sci-physics/yoda/yoda-1.4.0.ebuild
new file mode 100644
index 000000000..32e5bf37a
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=YODA-${PV}
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="http://yoda.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="c++11 python root static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )
+ root? ( sci-physics/root:0=[python=,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable c++11 stdcxx11)
+ $(use_enable python pyext)
+ $(use_enable root)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
+}