aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-07-05 20:31:32 +0300
committerJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-07-05 20:31:32 +0300
commit6ee4d8e07bde5a98db3f15c5a891fe10675519f8 (patch)
treee9afd647fac7b9d9c1a080f6b114bc8ad1ae7be6 /sci-physics
parentMask live ebuilds from sci-astronomy (diff)
downloadsci-6ee4d8e07bde5a98db3f15c5a891fe10675519f8.tar.gz
sci-6ee4d8e07bde5a98db3f15c5a891fe10675519f8.tar.bz2
sci-6ee4d8e07bde5a98db3f15c5a891fe10675519f8.zip
New ebuild sci-physics/LoopTools-2.7 for bug#424860
(Portage version: 2.2.0_alpha113/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/LoopTools/ChangeLog10
-rw-r--r--sci-physics/LoopTools/LoopTools-2.7.ebuild24
-rw-r--r--sci-physics/LoopTools/Manifest1
-rw-r--r--sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch29
-rw-r--r--sci-physics/LoopTools/metadata.xml15
5 files changed, 79 insertions, 0 deletions
diff --git a/sci-physics/LoopTools/ChangeLog b/sci-physics/LoopTools/ChangeLog
new file mode 100644
index 000000000..87f268cc9
--- /dev/null
+++ b/sci-physics/LoopTools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/LoopTools
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*LoopTools-2.7 (05 Jul 2012)
+
+ 05 Jul 2012; Jauhien Piatlicki (jauhien) piatlicki@gmail.com
+ +LoopTools-2.7.ebuild, +files/LoopTools-2.7-makefile.patch, +metadata.xml:
+ Initial release, new ebuild for bug#424860
+
diff --git a/sci-physics/LoopTools/LoopTools-2.7.ebuild b/sci-physics/LoopTools/LoopTools-2.7.ebuild
new file mode 100644
index 000000000..61672a55f
--- /dev/null
+++ b/sci-physics/LoopTools/LoopTools-2.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A package for evaluation of scalar and tensor one-loop integrals"
+HOMEPAGE="http://www.feynarts.de/looptools"
+SRC_URI="http://www.feynarts.de/looptools/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
diff --git a/sci-physics/LoopTools/Manifest b/sci-physics/LoopTools/Manifest
new file mode 100644
index 000000000..b706da96c
--- /dev/null
+++ b/sci-physics/LoopTools/Manifest
@@ -0,0 +1 @@
+DIST LoopTools-2.7.tar.gz 524561 RMD160 ed2e137ac52bd49fc14a9a74cfe5214beaef122c SHA1 79407069dc53b6bbd575265487f980250d819622 SHA256 582f157388d752c3701835b819085309ff7f140dca9f973ceb9d72c67d784260 SHA512 0580a1b147dba243ac56c8a6d7a42446413a044c1ce050cc0f8022eb6375e94f28e2e904c4398d5ab25359173f4ae13d61b8afa0e4eda9ae4e98d56bb22d4312 WHIRLPOOL 9b31ccf3b966c6c2af56237c0fc84fb8a7b95de012407ed7efa76c04ef6bd384f70770eeaf1b2ec65e9b1a536b4a2693fbd59df8d3467328098713fca843ea9f
diff --git a/sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch b/sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch
new file mode 100644
index 000000000..4dfc8474a
--- /dev/null
+++ b/sci-physics/LoopTools/files/LoopTools-2.7-makefile.patch
@@ -0,0 +1,29 @@
+--- makefile.in
++++ makefile.in
+@@ -1,8 +1,8 @@
+ BLD = build$(QUADSUFFIX)
+
+-LIBDIR = $(PREFIX)/lib$(LIBDIRSUFFIX)
+-INCLUDEDIR = $(PREFIX)/include
+-BINDIR = $(PREFIX)/bin
++LIBDIR = $(DESTDIR)/$(PREFIX)/lib$(LIBDIRSUFFIX)
++INCLUDEDIR = $(DESTDIR)/$(PREFIX)/include
++BINDIR = $(DESTDIR)/$(PREFIX)/bin
+
+ LIB = libooptools$(QUADSUFFIX).a
+ FE = lt$(QUADSUFFIX)$(EXE)
+@@ -38,13 +38,12 @@
+ cd $(BLD) && $(MAKE) $(ARGS) $@
+
+ install: lib frontend
+- -mkdir $(PREFIX)
++ -mkdir $(DESTDIR)$(PREFIX)
+ -mkdir $(LIBDIR) $(BINDIR) $(INCLUDEDIR)
+ cp -p $(BLD)/$(LIB) $(LIBDIR)
+ cp -p $(INCLUDE$(QUADSUFFIX)) $(INCLUDEDIR)
+- strip $(BLD)/$(FE)
+ cp -p $(BLD)/fcc $(BLD)/$(FE) $(BINDIR)
+- test ! -f $(BLD)/$(MFE) || { strip $(BLD)/$(MFE) ; cp -p $(BLD)/$(MFE) $(BINDIR); }
++ test ! -f $(BLD)/$(MFE) || { cp -p $(BLD)/$(MFE) $(BINDIR); }
+
+ force: $(BLD)/timestamp
diff --git a/sci-physics/LoopTools/metadata.xml b/sci-physics/LoopTools/metadata.xml
new file mode 100644
index 000000000..8752705f7
--- /dev/null
+++ b/sci-physics/LoopTools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+</maintainer>
+<longdescription>
+ A package for evaluation of scalar and tensor one-loop integrals
+ based on the FF package by G.J. van Oldenborgh.
+ It features an easy Fortran, C++, and Mathematica interface
+ to the scalar one-loop functions of FF and in addition provides
+ the 2-, 3-, and 4-point tensor coefficient functions.
+</longdescription>
+</pkgmetadata>