aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-01-11 11:40:02 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-01-11 11:40:02 +0100
commit73d5c6cedc0ca09111b3fa61df413fa1166dc9ef (patch)
treebde54a4262ec8056ab47142b83279ffefb5156dc /sci-physics
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-73d5c6cedc0ca09111b3fa61df413fa1166dc9ef.tar.gz
sci-73d5c6cedc0ca09111b3fa61df413fa1166dc9ef.tar.bz2
sci-73d5c6cedc0ca09111b3fa61df413fa1166dc9ef.zip
sci-physics/qcl: Move to EAPI=5, cleanup ebuilds
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/qcl/ChangeLog6
-rw-r--r--sci-physics/qcl/qcl-0.6.3-r1.ebuild18
-rw-r--r--sci-physics/qcl/qcl-0.6.4.ebuild11
3 files changed, 20 insertions, 15 deletions
diff --git a/sci-physics/qcl/ChangeLog b/sci-physics/qcl/ChangeLog
index 587799cd7..d01d0e99b 100644
--- a/sci-physics/qcl/ChangeLog
+++ b/sci-physics/qcl/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-physics/qcl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Jan 2015; Marius Brehler <marbre@linux.sungazer.de>,
+ qcl-0.6.4.ebuild, qcl-0.6.3-r1.ebuild:
+ Move to EAPI=5, cleanup ebuilds
+
*qcl-0.6.4 (02 Jun 2014)
02 Jun 2014; Jauhien Piatlicki <jauhien@gentoo.org> +qcl-0.6.4.ebuild,
diff --git a/sci-physics/qcl/qcl-0.6.3-r1.ebuild b/sci-physics/qcl/qcl-0.6.3-r1.ebuild
index 6419134e9..22da81b14 100644
--- a/sci-physics/qcl/qcl-0.6.3-r1.ebuild
+++ b/sci-physics/qcl/qcl-0.6.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=5
+
inherit eutils flag-o-matic
DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
@@ -21,19 +22,18 @@ DEPEND="media-libs/plotutils
sys-libs/readline"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}"-gcc43.patch
+ "${FILESDIR}/${P}"-makefile.patch
+)
src_install() {
emake \
QCLDIR="${D}/usr/share/${PN}" \
- QCLBIN="${D}/usr/bin" install \
- || die "emake install failed"
+ QCLBIN="${D}/usr/bin" install
dodoc README CHANGES
if use doc; then
insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf || die
+ doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf
fi
}
diff --git a/sci-physics/qcl/qcl-0.6.4.ebuild b/sci-physics/qcl/qcl-0.6.4.ebuild
index 9338be1cd..cf23884a3 100644
--- a/sci-physics/qcl/qcl-0.6.4.ebuild
+++ b/sci-physics/qcl/qcl-0.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -22,9 +22,10 @@ DEPEND="media-libs/plotutils
sys-libs/readline"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.6.3-gcc43.patch" "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.6.3-gcc43.patch
+ "${FILESDIR}/${P}"-makefile.patch
+)
src_install() {
emake \
@@ -33,6 +34,6 @@ src_install() {
dodoc README CHANGES
if use doc; then
insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf || die
+ doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf
fi
}