aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-10-25 23:11:47 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-02 12:30:11 +0100
commit85accf3105facb51086d99c9cf0500c3568362b8 (patch)
tree5a05cecd7f5b093e321b8270b5e2ca7b1fc0b665 /sci-physics
parentsci-biology/bidsschematools: updated dependency order (diff)
downloadsci-85accf3105facb51086d99c9cf0500c3568362b8.tar.gz
sci-85accf3105facb51086d99c9cf0500c3568362b8.tar.bz2
sci-85accf3105facb51086d99c9cf0500c3568362b8.zip
sci-physics/oneloop: new package, add 2020.07.31
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/sci/pull/1176 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/oneloop/Manifest1
-rw-r--r--sci-physics/oneloop/files/oneloop-2020.07.31-config.patch11
-rw-r--r--sci-physics/oneloop/metadata.xml12
-rw-r--r--sci-physics/oneloop/oneloop-2020.07.31.ebuild49
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-physics/oneloop/Manifest b/sci-physics/oneloop/Manifest
new file mode 100644
index 000000000..f698d0a23
--- /dev/null
+++ b/sci-physics/oneloop/Manifest
@@ -0,0 +1 @@
+DIST oneloop-2020.07.31.zip 166257 BLAKE2B 7869806c6e70388311b62ae1ad15b35292c81d5d87ff7f24ad53bb8e562631664545f36e3e32d6f31a39ca9489d7da64284ad10ed988cb7c4375626121d0a84f SHA512 eee46cfe60b1d887cb40033e63d7a04ca24b329692e443d28ecb9f070182d5c56ea5bbaefd2ae21b2776d907ea280ebf81cae0c332391e7e7e7d5e3be3084220
diff --git a/sci-physics/oneloop/files/oneloop-2020.07.31-config.patch b/sci-physics/oneloop/files/oneloop-2020.07.31-config.patch
new file mode 100644
index 000000000..4af47e066
--- /dev/null
+++ b/sci-physics/oneloop/files/oneloop-2020.07.31-config.patch
@@ -0,0 +1,11 @@
+--- a/Config 2022-05-19 17:34:51.000000000 +0200
++++ b/Config 2022-05-19 17:34:51.000000000 +0200
+@@ -3,7 +3,7 @@
+ #FFLAGS = -Wall
+
+ DPKIND = kind(1d0)
+-QPKIND = kind(1q0)
++#QPKIND = kind(1q0)
+ #DPKIND = selected_real_kind(15)
+ #QPKIND = 16
+ #DDTYPE = ddfun90
diff --git a/sci-physics/oneloop/metadata.xml b/sci-physics/oneloop/metadata.xml
new file mode 100644
index 000000000..bdee6992b
--- /dev/null
+++ b/sci-physics/oneloop/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-physics/oneloop/oneloop-2020.07.31.ebuild b/sci-physics/oneloop/oneloop-2020.07.31.ebuild
new file mode 100644
index 000000000..49b30f07e
--- /dev/null
+++ b/sci-physics/oneloop/oneloop-2020.07.31.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# python only needed for create.py to get binaries
+PYTHON_COMPAT=( python3_{8..11} )
+inherit toolchain-funcs python-any-r1
+
+DESCRIPTION="Library of one-loop scalar functions"
+HOMEPAGE="https://bitbucket.org/hameren/oneloop"
+SRC_URI="https://bitbucket.org/hameren/oneloop/get/3762b8bad6ad.zip -> ${P}.zip"
+S="${WORKDIR}/hameren-oneloop-3762b8bad6ad"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/unzip
+ virtual/fortran
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-config.patch
+)
+
+src_configure() {
+ tc-export FC
+ sed -i "/FC = /s/gfortran/${FC}/g" Config || die
+ sed -i "/FFLAGS = /s/ -O/${FFLAGS} -fPIC/g" Config || die
+}
+
+src_compile() {
+ tc-export FC
+ emake -f make_cuttools
+ ${EPYTHON} ./create.py || die "Failed to compile"
+ #./create.py dynamic || die
+ ${FC} ${LDFLAGS} -Wl,-soname,libavh_olo.so -shared -o libavh_olo.so avh_olo.o || die "Failed to link"
+}
+
+src_install() {
+ dolib.a libavh_olo.a
+ dolib.so libavh_olo.so
+ doheader avh_olo.mod
+}