aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@gentoo.org>2014-03-23 08:30:27 +0100
committerJustin <jlec@gentoo.org>2014-03-23 08:30:27 +0100
commitd295207cfcf820c62b83d56ad9d0f9fa744e6ebe (patch)
tree483ed61302614667e663ace39672e76f8d27525b /sci-physics
parentMerge pull request #206 from olifre/vgm (diff)
parentFix incorrect working directory (adapt to zipped file). (diff)
downloadsci-d295207cfcf820c62b83d56ad9d0f9fa744e6ebe.tar.gz
sci-d295207cfcf820c62b83d56ad9d0f9fa744e6ebe.tar.bz2
sci-d295207cfcf820c62b83d56ad9d0f9fa744e6ebe.zip
Merge pull request #205 from olifre/master
Initial version of genfit-ebuild.
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/genfit/ChangeLog19
-rw-r--r--sci-physics/genfit/Manifest1
-rw-r--r--sci-physics/genfit/genfit-02.00.00.ebuild54
-rw-r--r--sci-physics/genfit/metadata.xml31
4 files changed, 105 insertions, 0 deletions
diff --git a/sci-physics/genfit/ChangeLog b/sci-physics/genfit/ChangeLog
new file mode 100644
index 000000000..f074dc78a
--- /dev/null
+++ b/sci-physics/genfit/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for sci-physics/genfit
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 Mar 2014; <o.freyermuth@googlemail.com> genfit-02.00.00.ebuild:
+ Fix incorrect working directory (adapt to zipped file)
+
+ 22 Mar 2014; <o.freyermuth@googlemail.com> genfit-02.00.00.ebuild:
+ Use zip'ed snapshot instead of tag from repository.
+
+ 22 Mar 2014; <o.freyermuth@googlemail.com> genfit-02.00.00.ebuild, metadata.xml:
+ Address ebuild issues found in review (indentation, missing and superfluous
+ die's).
+
+*genfit-02.00.00 (22 Mar 2014)
+
+ 22 Mar 2014; <o.freyermuth@googlemail.com> +genfit-02.00.00.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/sci-physics/genfit/Manifest b/sci-physics/genfit/Manifest
new file mode 100644
index 000000000..4032b1f10
--- /dev/null
+++ b/sci-physics/genfit/Manifest
@@ -0,0 +1 @@
+DIST genfit-code-1688-tags-v02-00-00.zip 2251113 SHA256 06c1cf7281b4fb7b8cf2b1da174abd0a53fd742d7b11b173ee794fdeb84e4467 SHA512 cc80de2f3fa4a8efddd758b11e5810d1e994deaca0058721aeb6eff5c6a4f057ac76d4ac3c90a40a8fecaf17bc7e357b73ef50bc05e6e41f18806b63dc411c1a WHIRLPOOL 06ac48c9b96709d1e0fe88459ee42d6a4990b2e8a0ee105763b406647a8d8ff45cb38a886b2d9fadf802f9ddd9344c7696246da5c387912fcf3cfdc5f22b40cf
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
new file mode 100644
index 000000000..596f3e9e1
--- /dev/null
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator
+
+#ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/tags/v$(replace_all_version_separators '-')"
+#ESVN_PROJECT="${PN}.${PV}"
+
+TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
+
+DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
+HOMEPAGE="http://genfit.sourceforge.net/Main.html"
+SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ sci-physics/root
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+S=${WORKDIR}/${TAG_VER}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile doc
+ use examples && cmake-utils_src_compile tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${BUILD_DIR}/bin"
+ doins "${S}/test/makeGeom.C"
+ doins "${S}/test/README"
+ fi
+ cd doc || die
+ use doc && dohtml -r "${S}/doc/html/"*
+ echo
+ elog "Note that there is no support in this ebuild for RAVE yet,"
+ elog "which is also not in portage."
+ elog "It should be possible to use a local installation of RAVE"
+ elog "and set:"
+ elog " export RAVEPATH=<yourRaveDirectory>"
+ echo
+}
diff --git a/sci-physics/genfit/metadata.xml b/sci-physics/genfit/metadata.xml
new file mode 100644
index 000000000..b767bdd9f
--- /dev/null
+++ b/sci-physics/genfit/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
+GENFIT is an experiment-independent framework for track reconstruction for
+particle and nuclear physics. It consists of three modular components:
+- Track fitting algorithms
+ Currently, GENFIT contains a Kalman Filter and a
+ Deterministic Annealing Filter.
+ Other algorithm modules can be added easily.
+- Track representations
+ These modules hold the data of track track parameters and can perform
+ extrapolations of these parameters.
+ GENFIT is distributed with two well-tested track representations.
+ Existing track extrapolation codes can be interfaced in a very
+ straightforward way in this framework, using their native geometry
+ and magnetic field interfaces.
+- Reconstruction hits
+ The hit dimensionality and the orientation of planar tracking detectors
+ can be chosen freely.
+GENFIT is especially useful for tracking systems which include detectors
+which do not measure the passage of particles on predefined planes,
+like TPCs or wire-based drift chambers. The concept of so-called
+virtual detector planes provides a simple mechanism to use these
+detector hits in a transparent way without any geometrical simplifications.
+GENFIT has been developed in the framework of the PANDA experiment at
+FAIR, Darmstadt, Germany.
+It is also used in the Belle-2, Fopi, and GEM-TPC experiments.
+ </longdescription>
+</pkgmetadata>