aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-31 16:47:40 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 15:54:53 +0000
commitd4f991ffc9ca363f8439f2b10df08caf6faf250e (patch)
tree6adecc5925efd6328b2c563e3083376f4e3b5b92 /sci-physics
parentsci-libs/itk: drop old python targets (diff)
downloadsci-d4f991ffc9ca363f8439f2b10df08caf6faf250e.tar.gz
sci-d4f991ffc9ca363f8439f2b10df08caf6faf250e.tar.bz2
sci-d4f991ffc9ca363f8439f2b10df08caf6faf250e.zip
sci-physics/genfit: EAPI bump, drop 9999
9999 is 404 cmake-utils --> cmake use docs eclass to compile docs Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/sci/pull/1021 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/genfit/genfit-02.00.00.ebuild48
-rw-r--r--sci-physics/genfit/genfit-9999.ebuild57
2 files changed, 21 insertions, 84 deletions
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 2230d6415..9aa92b2ba 100644
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -1,53 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit cmake-utils versionator
-
-if [[ ${PV} == *9999* ]]; then
- inherit subversion
- ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
- ESVN_PROJECT="${PN}.${PV}"
- KEYWORDS=""
-else
- # .zip-snapshot can be recreated by visiting
- # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
- TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
- #SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
- SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S=${WORKDIR}/${TAG_VER}
-fi
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+
+inherit cmake docs
+
+TAG_VER=${PN}-code-1688-tags-v${PV//./-}
DESCRIPTION="Generic toolkit for track reconstruction in physics experiments"
HOMEPAGE="http://genfit.sourceforge.net/Main.html" # no https
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="doc examples"
+
+IUSE="examples"
RDEPEND="
sci-physics/root:=
- dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${TAG_VER}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
- use examples && cmake-utils_src_compile tests
+ cmake_src_compile
+ docs_compile
+ use examples && cmake_src_compile tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
insinto /usr/share/doc/${PF}
doins -r "${BUILD_DIR}/bin"
doins test/makeGeom.C
doins test/README
fi
- use doc && dohtml -r doc/html/*
echo
elog "Note that there is no support in this ebuild for RAVE yet,"
elog "which is also not in portage."
diff --git a/sci-physics/genfit/genfit-9999.ebuild b/sci-physics/genfit/genfit-9999.ebuild
deleted file mode 100644
index 2061c4dc1..000000000
--- a/sci-physics/genfit/genfit-9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils versionator
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/GenFit/GenFit.git"
- KEYWORDS=""
-else
- # .zip-snapshot can be recreated by visiting
- # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
- TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
- #SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
- SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S=${WORKDIR}/${TAG_VER}
-fi
-
-DESCRIPTION="Generic toolkit for track reconstruction in physics experiments"
-HOMEPAGE="http://genfit.sourceforge.net/Main.html" # no https
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND="
- sci-physics/root:=
- dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
- use examples && cmake-utils_src_compile tests
-}
-
-src_install() {
- cmake-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${BUILD_DIR}/bin"
- doins test/makeGeom.C
- doins test/README
- fi
- use doc && dohtml -r doc/html/*
- echo
- elog "Note that there is no support in this ebuild for RAVE yet,"
- elog "which is also not in portage."
- elog "It should be possible to use a local installation of RAVE"
- elog "and set:"
- elog " export RAVEPATH=<yourRaveDirectory>"
- echo
-}