aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-09 10:53:13 +0200
committerChristoph Junghans <ottxor@gentoo.org>2012-10-09 10:53:13 +0200
commite32eea28a574de8ad3729474e3001c42b11f23a7 (patch)
tree41fc74f880588e541fa05c85de2f1c1b37ba1863 /sci-physics
parent[sci-libs/openblas] Version bump (diff)
downloadsci-e32eea28a574de8ad3729474e3001c42b11f23a7.tar.gz
sci-e32eea28a574de8ad3729474e3001c42b11f23a7.tar.bz2
sci-e32eea28a574de8ad3729474e3001c42b11f23a7.zip
sync with gx86
(Portage version: 2.2.0_alpha136/git/Linux i686)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/ChangeLog4
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild30
2 files changed, 23 insertions, 11 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
index c273e468f..7264ecad2 100644
--- a/sci-physics/espresso/ChangeLog
+++ b/sci-physics/espresso/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Oct 2012; Christoph Junghans <ottxor@gentoo.org> espresso-9999.ebuild:
+ sync with gx86
+
06 May 2012; Christoph Junghans <ottxor@gentoo.org> espresso-9999.ebuild:
sync with gx86
@@ -46,4 +49,3 @@
16 May 2009; Christoph Junghans <kleiner_otti@gmx.de> ChangeLog:
Initial commit. Ebuild written by me. bug #266648
-
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index 01f7b5106..18df79b86 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.0.0.ebuild,v 1.1 2011/04/20 13:03:00 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.1.0.ebuild,v 1.5 2012/05/06 23:08:00 ottxor Exp $
EAPI=4
@@ -46,6 +46,10 @@ src_prepare() {
autotools-utils_src_prepare
eautoreconf
restore_config myconfig.h
+ if [[ ${CHOST} == *-darwin* ]]; then
+ #tclline uses stty, which has different exit code on Darwin
+ sed -i '/source.*tclline/s/^/#/' "scripts/init.tcl" || die
+ fi
}
src_configure() {
@@ -60,8 +64,8 @@ src_configure() {
src_compile() {
autotools-utils_src_compile
- use doc && autotools-utils_src_compile ug doxygen tutorials
- [[ ${PV} = 9999 ]] && use doc && autotools-utils_src_compile dg
+ use doc && autotools-utils_src_compile doxygen
+ [[ ${PV} = 9999 ]] && use doc && autotools-utils_src_compile ug dg tutorials
}
src_install() {
@@ -75,13 +79,19 @@ src_install() {
save_config ${AUTOTOOLS_BUILD_DIR}/src/myconfig-final.h
if use doc; then
- [[ ${PV} = 9999 ]] && \
- newdoc ${AUTOTOOLS_BUILD_DIR}/doc/dg/dg.pdf developer_guide.pdf
- newdoc ${AUTOTOOLS_BUILD_DIR}/doc/ug/ug.pdf user_guide.pdf
- dohtml -r ${AUTOTOOLS_BUILD_DIR}/doc/doxygen/html/*
- for i in ${AUTOTOOLS_BUILD_DIR}/doc/tutorials/*/[0-9]*.pdf; do
- newdoc ${i} tutorial_${i##*/}
- done
+ if [[ ${PV} = 9999 ]] ; then
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${AUTOTOOLS_BUILD_DIR}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ else
+ newdoc "${S}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${S}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ fi
+ dohtml -r "${AUTOTOOLS_BUILD_DIR}"/doc/doxygen/html/*
fi
if use examples; then