aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2015-07-18 12:44:37 +0300
committerAndrew Savchenko <bircoph@gmail.com>2015-07-18 12:44:37 +0300
commitedac8a8350c5bd22f8f73f170439290f9b38a71b (patch)
tree77a8b73aa4d29d9ed904bfe4c925c37e96d8ded9 /sci-physics
parentapp-doc/root-docs: version bump (diff)
downloadsci-edac8a8350c5bd22f8f73f170439290f9b38a71b.tar.gz
sci-edac8a8350c5bd22f8f73f170439290f9b38a71b.tar.bz2
sci-edac8a8350c5bd22f8f73f170439290f9b38a71b.zip
avoid unconditional pg_config sourcing by usex
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog4
-rw-r--r--sci-physics/root/root-5.34.32.ebuild5
2 files changed, 8 insertions, 1 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 10c7d9e22..61a91bd28 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.96 2012/03/29 18:21:49 bicatali Exp $
+ 18 Jul 2015; Andrew Savchenko <bircoph@gentoo.org> root-5.34.32.ebuild:
+ Do not use usex for postgres to avoid pg_config unconditional sourcing. See
+ bug 555246.
+
*root-5.34.32 (17 Jul 2015)
17 Jul 2015; Andrew Savchenko <bircoph@gentoo.org> +root-5.34.32.ebuild,
diff --git a/sci-physics/root/root-5.34.32.ebuild b/sci-physics/root/root-5.34.32.ebuild
index 283102f64..4b02cba53 100644
--- a/sci-physics/root/root-5.34.32.ebuild
+++ b/sci-physics/root/root-5.34.32.ebuild
@@ -310,7 +310,6 @@ src_configure() {
$(use_enable opengl)
$(use_enable oracle)
$(use_enable postgres pgsql)
- $(usex postgres "--with-pgsql-incdir=$(pg_config --includedir)" "")
$(use_enable prefix rpath)
$(use_enable pythia6)
$(use_enable pythia8)
@@ -330,6 +329,10 @@ src_configure() {
${EXTRA_ECONF}
)
+ # usex can't be used here, because pg_config may be not
+ # installed with USE="-postgres"
+ use postgres && myconf+=( --with-pgsql-incdir=$(pg_config --includedir) )
+
./configure ${myconf[@]} || die "configure failed"
}