aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <debdepba@dasganma.tk>2015-01-29 18:20:40 +0000
committerChris Kerr <debdepba@dasganma.tk>2015-01-29 18:20:40 +0000
commit514b1eb6c3e5cc0aea9972299107615324e900fb (patch)
tree80979229114db668a43a44f0c709b92b7a69788d /sci-visualization/mantid
parentNone of the python code uses the NeXus python library (diff)
downloadsci-514b1eb6c3e5cc0aea9972299107615324e900fb.tar.gz
sci-514b1eb6c3e5cc0aea9972299107615324e900fb.tar.bz2
sci-514b1eb6c3e5cc0aea9972299107615324e900fb.zip
Test that CASROOT has been set; suggestion by @junghans
Diffstat (limited to 'sci-visualization/mantid')
-rw-r--r--sci-visualization/mantid/mantid-3.3.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-visualization/mantid/mantid-3.3.0.ebuild b/sci-visualization/mantid/mantid-3.3.0.ebuild
index 16c36626f..4e756e637 100644
--- a/sci-visualization/mantid/mantid-3.3.0.ebuild
+++ b/sci-visualization/mantid/mantid-3.3.0.ebuild
@@ -75,8 +75,12 @@ src_configure() {
$(cmake-utils_use paraview MAKE_VATES)
$(cmake-utils_use_use pch PRECOMPILED_HEADERS)
$(cmake-utils_use_build test TESTING)
- -DCMAKE_PREFIX_PATH="${CASROOT}"
)
+ if use opencascade
+ then
+ [[ -z ${CASROOT} ]] && die "CASROOT environment variable not defined, that usually means you need to use 'eselect opencascade'."
+ mycmakeargs+=( -DCMAKE_PREFIX_PATH="${CASROOT}" )
+ fi
cmake-utils_src_configure
}