aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-02-17 15:14:26 -0500
committerHorea Christian <chr@chymera.eu>2023-02-17 15:14:26 -0500
commit636d6e9b37345f339947eb1897673c8a93aaead4 (patch)
tree62246a16926788ecee0f6c57b41ac6acc1007c1a /sci-visualization/mricrogl
parentdev-vcs/dandi-cli: drop 0.39.4, 0.45.1 (diff)
downloadsci-636d6e9b37345f339947eb1897673c8a93aaead4.tar.gz
sci-636d6e9b37345f339947eb1897673c8a93aaead4.tar.bz2
sci-636d6e9b37345f339947eb1897673c8a93aaead4.zip
sci-visualization/mricrogl: revbumps for deps and icon cache
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-visualization/mricrogl')
-rw-r--r--sci-visualization/mricrogl/mricrogl-1.2.20211007-r1.ebuild (renamed from sci-visualization/mricrogl/mricrogl-1.2.20211007.ebuild)32
-rw-r--r--sci-visualization/mricrogl/mricrogl-1.2.20220720-r1.ebuild (renamed from sci-visualization/mricrogl/mricrogl-1.2.20220720.ebuild)32
2 files changed, 54 insertions, 10 deletions
diff --git a/sci-visualization/mricrogl/mricrogl-1.2.20211007.ebuild b/sci-visualization/mricrogl/mricrogl-1.2.20211007-r1.ebuild
index 5a3ddea14..da8e446cf 100644
--- a/sci-visualization/mricrogl/mricrogl-1.2.20211007.ebuild
+++ b/sci-visualization/mricrogl/mricrogl-1.2.20211007-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
MY_PN="MRIcroGL"
-inherit desktop
+inherit desktop xdg-utils
DESCRIPTION="A simple medical imaging visualization tool"
HOMEPAGE="https://github.com/neurolabusc/MRIcroGL"
@@ -15,20 +15,27 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dicom python"
-RDEPEND="dicom? ( sci-biology/dcm2niix )"
+BDEPEND="dev-lang/lazarus"
DEPEND="
dev-lang/fpc
- dev-lang/lazarus
+ x11-misc/appmenu-gtk-module[gtk2]
"
+RDEPEND="dicom? ( sci-biology/dcm2niix )"
S="${WORKDIR}/${MY_PN}-${PV}"
src_compile() {
# Allegedly the Debian recipe contains some sort of Python support, wasn't able to test.
if use python; then
- lazbuild -B --lazarusdir="/usr/share/lazarus/" --pcp="system-lazarus-config" MRIcroGL_Debian.lpi || die
+ lazbuild -B \
+ --lazarusdir="/usr/share/lazarus/" \
+ --pcp="system-lazarus-config" \
+ MRIcroGL_Debian.lpi || die
else
- lazbuild -B --lazarusdir="/usr/share/lazarus/" --pcp="system-lazarus-config" MRIcroGL_NoPython.lpi || die
+ lazbuild -B \
+ --lazarusdir="/usr/share/lazarus/" \
+ --pcp="system-lazarus-config" \
+ MRIcroGL_NoPython.lpi || die
fi
}
@@ -42,3 +49,18 @@ src_install() {
make_desktop_entry MRIcroGL MRIcroGL /usr/share/icons/hicolor/scalable/apps/mricrogl.svg
popd
}
+
+pkg_postinst(){
+ xdg_icon_cache_update
+
+ ewarn "This package might exhibit nondeterministic lag at startup manifesting as a blank"
+ ewarn "window, which can either be closed (e.g. Alt+F4) manually leading to the actual"
+ ewarn "interface being launched, or will close itself after 10-20s and start the proper GUI"
+ ewarn "For more details on this look up: https://github.com/rordenlab/MRIcroGL/issues/49"
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/sci-visualization/mricrogl/mricrogl-1.2.20220720.ebuild b/sci-visualization/mricrogl/mricrogl-1.2.20220720-r1.ebuild
index 5a3ddea14..da8e446cf 100644
--- a/sci-visualization/mricrogl/mricrogl-1.2.20220720.ebuild
+++ b/sci-visualization/mricrogl/mricrogl-1.2.20220720-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
MY_PN="MRIcroGL"
-inherit desktop
+inherit desktop xdg-utils
DESCRIPTION="A simple medical imaging visualization tool"
HOMEPAGE="https://github.com/neurolabusc/MRIcroGL"
@@ -15,20 +15,27 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dicom python"
-RDEPEND="dicom? ( sci-biology/dcm2niix )"
+BDEPEND="dev-lang/lazarus"
DEPEND="
dev-lang/fpc
- dev-lang/lazarus
+ x11-misc/appmenu-gtk-module[gtk2]
"
+RDEPEND="dicom? ( sci-biology/dcm2niix )"
S="${WORKDIR}/${MY_PN}-${PV}"
src_compile() {
# Allegedly the Debian recipe contains some sort of Python support, wasn't able to test.
if use python; then
- lazbuild -B --lazarusdir="/usr/share/lazarus/" --pcp="system-lazarus-config" MRIcroGL_Debian.lpi || die
+ lazbuild -B \
+ --lazarusdir="/usr/share/lazarus/" \
+ --pcp="system-lazarus-config" \
+ MRIcroGL_Debian.lpi || die
else
- lazbuild -B --lazarusdir="/usr/share/lazarus/" --pcp="system-lazarus-config" MRIcroGL_NoPython.lpi || die
+ lazbuild -B \
+ --lazarusdir="/usr/share/lazarus/" \
+ --pcp="system-lazarus-config" \
+ MRIcroGL_NoPython.lpi || die
fi
}
@@ -42,3 +49,18 @@ src_install() {
make_desktop_entry MRIcroGL MRIcroGL /usr/share/icons/hicolor/scalable/apps/mricrogl.svg
popd
}
+
+pkg_postinst(){
+ xdg_icon_cache_update
+
+ ewarn "This package might exhibit nondeterministic lag at startup manifesting as a blank"
+ ewarn "window, which can either be closed (e.g. Alt+F4) manually leading to the actual"
+ ewarn "interface being launched, or will close itself after 10-20s and start the proper GUI"
+ ewarn "For more details on this look up: https://github.com/rordenlab/MRIcroGL/issues/49"
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}