aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois.bissey@canterbury.ac.nz>2012-02-09 13:20:43 +1300
committerFrançois Bissey <francois.bissey@canterbury.ac.nz>2012-02-09 13:21:59 +1300
commitea9f184fd9aab283ca255f6e663b2b18e778d107 (patch)
tree84f6f279a3d09f28aa29572073e3f50d503dbc3e /sci-visualization
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-ea9f184fd9aab283ca255f6e663b2b18e778d107.tar.gz
sci-ea9f184fd9aab283ca255f6e663b2b18e778d107.tar.bz2
sci-ea9f184fd9aab283ca255f6e663b2b18e778d107.zip
some clean up in paraview 3.12.0
(Portage version: 2.2.0_alpha85/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog4
-rw-r--r--sci-visualization/paraview/files/paraview-3.12.0-protobuf.patch30
-rw-r--r--sci-visualization/paraview/paraview-3.12.0.ebuild9
3 files changed, 36 insertions, 7 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index 8a71db863..85732fb4e 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Feb 2012; François Bissey <francois.bissey@canterbury.ac.nz>
+ paraview-3.12.0.ebuild, files/paraview-3.12.0-protobuf.patch:
+ clean up protobuf mess, go to EAPI 3 (for python QA)
+
*paraview-3.12.0 (07 Feb 2012)
07 Feb 2012; François Bissey <francois.bissey@canterbury.ac.nz>
diff --git a/sci-visualization/paraview/files/paraview-3.12.0-protobuf.patch b/sci-visualization/paraview/files/paraview-3.12.0-protobuf.patch
index a724e1be4..fe8f4b4a0 100644
--- a/sci-visualization/paraview/files/paraview-3.12.0-protobuf.patch
+++ b/sci-visualization/paraview/files/paraview-3.12.0-protobuf.patch
@@ -21,3 +21,33 @@
#########################################################################
# Configure mpeg2 encoding
+--- CMake/ParaViewMacros.cmake.orig 2012-02-09 13:12:07.518350208 +1300
++++ CMake/ParaViewMacros.cmake 2012-02-09 13:12:16.863356368 +1300
+@@ -214,6 +214,6 @@
+ COMMAND protoc_compiler
+ --cpp_out=dllexport_decl=VTK_PROTOBUF_EXPORT:${CMAKE_CURRENT_BINARY_DIR}
+ --proto_path ${path} ${absolute}
+- DEPENDS ${in_proto_file} protoc_compiler
++ DEPENDS ${in_proto_file}
+ )
+ ENDFUNCTION (protobuf_generate)
+--- ParaViewCore/ServerImplementation/CMakeLists.txt.orig 2012-02-09 13:14:15.230434986 +1300
++++ ParaViewCore/ServerImplementation/CMakeLists.txt 2012-02-09 13:15:04.214467797 +1300
+@@ -86,7 +86,7 @@
+ #------------------------------------------------------------------------------
+ # Compile protobuf resources.
+ # run it from a script so we can set necessary paths.
+-get_target_property(PROTOC_LOCATION protoc_compiler LOCATION)
++SET(PROTOC_LOCATION ${SYSTEM_PB})
+ if (WIN32)
+ get_filename_component(PROTOC_DIR ${PROTOC_LOCATION} PATH)
+ get_filename_component(PROTOC_PDIR ${PROTOC_DIR} PATH)
+@@ -101,7 +101,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/vtkPVMessage.pb.cc
+ COMMAND ${CMAKE_COMMAND}
+ ARGS -DOutDir=${CMAKE_CFG_INTDIR} -P ${CMAKE_CURRENT_BINARY_DIR}/ExecuteProtoC.cmake
+- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Resources/vtkPVMessage.proto protoc_compiler ${ParaView_CMAKE_DIR}/ExecuteProtoC.cmake.in
++ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Resources/vtkPVMessage.proto ${ParaView_CMAKE_DIR}/ExecuteProtoC.cmake.in
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ )
+
diff --git a/sci-visualization/paraview/paraview-3.12.0.ebuild b/sci-visualization/paraview/paraview-3.12.0.ebuild
index fbc6984b7..8f59eff36 100644
--- a/sci-visualization/paraview/paraview-3.12.0.ebuild
+++ b/sci-visualization/paraview/paraview-3.12.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="python? 2:2.6"
@@ -76,7 +76,7 @@ src_prepare() {
#epatch "${FILESDIR}"/${PN}-3.8.0-h5part.patch
# gcc fix for vtk
epatch "${FILESDIR}"/${P}-gcc46.patch
-
+ # use system provided protobuf and avoid http://paraview.org/Bug/view.php?id=12852
epatch "${FILESDIR}"/${P}-protobuf.patch
# lib64 fixes
@@ -88,11 +88,6 @@ src_prepare() {
# Install internal vtk binaries inside /usr/${PVLIBDIR}
sed -e 's:VTK_INSTALL_BIN_DIR \"/${PV_INSTALL_BIN_DIR}\":VTK_INSTALL_BIN_DIR \"/${PV_INSTALL_LIB_DIR}\":' \
-i CMake/ParaViewCommon.cmake || die "failed to patch vtk install location"
- sed -e "s:get_target_property(PROTOC_LOCATION protoc_compiler LOCATION):SET(PROTOC_LOCATION \${SYSTEM_PB}):" \
- -e "s:protoc_compiler::" \
- -i ParaViewCore/ServerImplementation/CMakeLists.txt
- sed -i "s:DEPENDS \${in_proto_file} protoc_compiler:DEPENDS \${in_proto_file}:" \
- CMake/ParaViewMacros.cmake
cd VTK
epatch "${FILESDIR}"/vtk-5.6.0-cg-path.patch