aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-02-08 13:02:02 +0100
committerAndreas Schäfer <gentryx@gmx.de>2013-02-08 13:02:02 +0100
commite459ae1677652986d24941915585b05feb756b7c (patch)
tree7c5da6c771121a02d523ccc8a47ec8bd127ef4ca /sys-apps/likwid
parentupdated Manifest (diff)
downloadsci-e459ae1677652986d24941915585b05feb756b7c.tar.gz
sci-e459ae1677652986d24941915585b05feb756b7c.tar.bz2
sci-e459ae1677652986d24941915585b05feb756b7c.zip
added proper quotes for variables, use fperms in favor of chmod
Diffstat (limited to 'sys-apps/likwid')
-rw-r--r--sys-apps/likwid/likwid-3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/likwid/likwid-3.0.ebuild b/sys-apps/likwid/likwid-3.0.ebuild
index 62605a735..dd49a87cc 100644
--- a/sys-apps/likwid/likwid-3.0.ebuild
+++ b/sys-apps/likwid/likwid-3.0.ebuild
@@ -13,14 +13,14 @@ SRC_URI="http://likwid.googlecode.com/files/${P}.0.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="access-daemon"
+IUSE="+access-daemon"
src_prepare() {
if use access-daemon ; then
epatch "${FILESDIR}/use_access_daemon.patch"
fi
epatch "${FILESDIR}/likwid.patch"
- sed -i -e "s:/usr/local:$D/usr:" config.mk || die "Couldn't set prefix!"
+ sed -i -e "s:/usr/local:${D}/usr:" config.mk || die "Couldn't set prefix!"
}
src_compile() {
@@ -31,6 +31,6 @@ src_compile() {
pkg_preinst()
{
if use access-daemon ; then
- chmod +s "${D}/usr/bin/likwid-accessD" || die "Couldn't set SUID for access daemon"
+ fperms 4755 /usr/bin/likwid-accessD
fi
}