aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-11-17 01:56:41 +0000
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-11-17 01:56:41 +0000
commit0aa76f75759c0566c92fb4d2adb4cae789574728 (patch)
tree7766015f989bf935361003606dd486bf8d340983 /sys-cluster/condor/files
parentsci-mathematics/Macaulay2-1.3.1 revbump (diff)
downloadsci-0aa76f75759c0566c92fb4d2adb4cae789574728.tar.gz
sci-0aa76f75759c0566c92fb4d2adb4cae789574728.tar.bz2
sci-0aa76f75759c0566c92fb4d2adb4cae789574728.zip
Initial condor ebuild
Diffstat (limited to 'sys-cluster/condor/files')
-rw-r--r--sys-cluster/condor/files/chkconfig_off.patch12
-rw-r--r--sys-cluster/condor/files/condor.confd2
-rw-r--r--sys-cluster/condor/files/condor.initd32
-rw-r--r--sys-cluster/condor/files/condor_config.generic.patch135
-rw-r--r--sys-cluster/condor/files/condor_config.local9
-rw-r--r--sys-cluster/condor/files/log_lock_run.patch40
-rw-r--r--sys-cluster/condor/files/no_basename.patch51
-rw-r--r--sys-cluster/condor/files/no_rpmdb_query.patch11
-rw-r--r--sys-cluster/condor/files/stdsoap2.h.patch.patch13
9 files changed, 305 insertions, 0 deletions
diff --git a/sys-cluster/condor/files/chkconfig_off.patch b/sys-cluster/condor/files/chkconfig_off.patch
new file mode 100644
index 000000000..66ac9cd20
--- /dev/null
+++ b/sys-cluster/condor/files/chkconfig_off.patch
@@ -0,0 +1,12 @@
+diff -ru condor-7.2.0/src/condor_examples/condor.init condor-7.2.0mf/src/condor_examples/condor.init
+--- condor-7.2.0/src/condor_examples/condor.init 2008-12-19 14:10:08.000000000 -0600
++++ condor-7.2.0mf/src/condor_examples/condor.init 2009-01-13 19:31:15.000000000 -0600
+@@ -2,7 +2,7 @@
+ #
+ # condor This script allows for starting and stopping Condor.
+ #
+-# chkconfig: 2345 90 10
++# chkconfig: - 90 10
+ # description: Condor is a high throughput computing batch processing
+ # platform.
+ # processname: condor_master
diff --git a/sys-cluster/condor/files/condor.confd b/sys-cluster/condor/files/condor.confd
new file mode 100644
index 000000000..16b46f179
--- /dev/null
+++ b/sys-cluster/condor/files/condor.confd
@@ -0,0 +1,2 @@
+CONDOR_CENTRAL_MANAGER=canfarpool.canfar.vpn
+CONDOR_OPT=""
diff --git a/sys-cluster/condor/files/condor.initd b/sys-cluster/condor/files/condor.initd
new file mode 100644
index 000000000..d3cf8a542
--- /dev/null
+++ b/sys-cluster/condor/files/condor.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+CONDOR_USER=condor
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting condor"
+ condor_configure --type=execute --central-manager=${CONDOR_CENTRAL_MANAGER} --owner ${CONDOR_USER}
+ pid=$(start-stop-daemon --start --quiet --user ${CONDOR_USER} \
+ --pidfile /var/run/condor.pid \
+ --exec /usr/sbin/condor_master -- ${CONDOR_OPTS})
+ retval=$?
+ echo ${CONDOR_PID} > /var/run/condor.pid
+ eend ${retval}
+}
+
+stop() {
+ ebegin "Stopping condor"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/condor.pid \
+ --exec /usr/sbin/condor_master
+ retval=$?
+ [ ${retval} -eq 0 ] && rm -f /var/lock/subsys/condor
+ eend ${retval}
+}
diff --git a/sys-cluster/condor/files/condor_config.generic.patch b/sys-cluster/condor/files/condor_config.generic.patch
new file mode 100644
index 000000000..b9d4058da
--- /dev/null
+++ b/sys-cluster/condor/files/condor_config.generic.patch
@@ -0,0 +1,135 @@
+diff --git a/src/condor_examples/condor_config.generic b/src/condor_examples/condor_config.generic
+index f3f60a5..94c146f 100644
+--- a/src/condor_examples/condor_config.generic
++++ b/src/condor_examples/condor_config.generic
+@@ -1,15 +1,35 @@
+ ######################################################################
++######################################################################
++## ##
++## N O T I C E: ##
++## ##
++## Customization of this file should be done via the ##
++## LOCAL_CONFIG_FILE. ##
++## ##
++######################################################################
++######################################################################
++
++
++######################################################################
+ ##
+ ## condor_config
+ ##
+ ## This is the global configuration file for condor. Any settings
+-## made here may potentially be overridden in the local configuration
+-## file. KEEP THAT IN MIND! To double-check that a variable is
+-## getting set from the configuration file that you expect, use
+-## condor_config_val -v <variable name>
++## found here * * s h o u l d b e c u s t o m i z e d i n
++## t h e l o c a l c o n f i g u r a t i o n f i l e. * *
++##
++## The local configuration file is specified by LOCAL_CONFIG_FILE
++## below.
++##
++## For a basic configuration, you may only want to start by
++## customizing CONDOR_ADMIN.
++##
++## Note: To double-check where a configuration variable is set from
++## you can use condor_config_val -v <variable name>,
++## e.g. condor_config_val -v CONDOR_ADMIN.
+ ##
+ ## The file is divided into four main parts:
+-## Part 1: Settings you MUST customize
++## Part 1: Settings you likely want to customize
+ ## Part 2: Settings you may want to customize
+ ## Part 3: Settings that control the policy of when condor will
+ ## start and stop jobs on your machines
+@@ -47,18 +62,15 @@
+ ## # # # # # # #
+ ## # # # # # # #####
+ ##
+-## Part 1: Settings you must customize:
++## Part 1: Settings you likely want to customize:
+ ######################################################################
+ ######################################################################
+
+-## What machine is your central manager?
+-CONDOR_HOST = central-manager-hostname.your.domain
+-
+ ##--------------------------------------------------------------------
+ ## Pathnames:
+ ##--------------------------------------------------------------------
+ ## Where have you installed the bin, sbin and lib condor directories?
+-RELEASE_DIR = /usr/local/condor
++RELEASE_DIR = /usr
+
+ ## Where is the local condor directory for each host?
+ ## This is where the local config file(s), logs and
+@@ -84,7 +96,7 @@ CONDOR_ADMIN = condor-admin@your.domain
+
+ ## Full path to a mail delivery program that understands that "-s"
+ ## means you want to specify a subject:
+-MAIL = /usr/bin/mail
++MAIL = /bin/mail
+
+ ##--------------------------------------------------------------------
+ ## Network domain parameters:
+@@ -93,13 +105,13 @@ MAIL = /usr/bin/mail
+ ## machines don't share a common UID space, set it to
+ ## UID_DOMAIN = $(FULL_HOSTNAME)
+ ## to specify that each machine has its own UID space.
+-UID_DOMAIN = your.domain
++UID_DOMAIN = $(FULL_HOSTNAME)
+
+ ## Internet domain of machines sharing a common file system.
+ ## If your machines don't use a network file system, set it to
+ ## FILESYSTEM_DOMAIN = $(FULL_HOSTNAME)
+ ## to specify that each machine has its own file system.
+-FILESYSTEM_DOMAIN = your.domain
++FILESYSTEM_DOMAIN = $(FULL_HOSTNAME)
+
+ ## This macro is used to specify a short description of your pool.
+ ## It should be about 20 characters long. For example, the name of
+@@ -218,7 +230,7 @@ HOSTALLOW_READ = *
+ ## HOSTALLOW_WRITE = *
+ ## but note that this will allow anyone to submit jobs or add
+ ## machines to your pool and is serious security risk.
+-HOSTALLOW_WRITE = YOU_MUST_CHANGE_THIS_INVALID_CONDOR_CONFIGURATION_VALUE
++HOSTALLOW_WRITE = $(FULL_HOSTNAME)
+ #HOSTALLOW_WRITE = *.your.domain, your-friend's-machine.other.domain
+ #HOSTDENY_WRITE = bad-machine.your.domain
+
+@@ -872,9 +883,10 @@ SPOOL = $(LOCAL_DIR)/spool
+ EXECUTE = $(LOCAL_DIR)/execute
+ BIN = $(RELEASE_DIR)/bin
+ LIB = $(RELEASE_DIR)/lib
+-INCLUDE = $(RELEASE_DIR)/include
++INCLUDE = $(RELEASE_DIR)/include/condor
+ SBIN = $(RELEASE_DIR)/sbin
+-LIBEXEC = $(RELEASE_DIR)/libexec
++LIBEXEC = $(RELEASE_DIR)/libexec/condor
++SHARE = $(RELEASE_DIR)/share/condor
+
+ ## If you leave HISTORY undefined (comment it out), no history file
+ ## will be created.
+@@ -1655,7 +1667,7 @@ JAVA_MAXHEAP_ARGUMENT = -Xmx
+ ## them here. However, do not remove the existing entries, as Condor
+ ## needs them.
+
+-JAVA_CLASSPATH_DEFAULT = $(LIB) $(LIB)/scimark2lib.jar .
++JAVA_CLASSPATH_DEFAULT = $(SHARE) $(SHARE)/scimark2lib.jar .
+
+ ## JAVA_CLASSPATH_ARGUMENT describes the command-line parameter
+ ## used to introduce a new classpath:
+diff --git a/src/condor_examples/customize b/src/condor_examples/customize
+index b1c5710..cb2dea1 100644
+--- a/src/condor_examples/customize
++++ b/src/condor_examples/customize
+@@ -54,7 +54,7 @@ sub get_platform_defaults {
+ $_ = $os;
+ SWITCH: {
+ if(/^Linux/) {
+- $mail_path="/usr/bin/mail";
++ $mail_path="/bin/mail";
+ $ps_path="/bin/ps auwx";
+ $console_devs="mouse, console";
+ last SWITCH;
diff --git a/sys-cluster/condor/files/condor_config.local b/sys-cluster/condor/files/condor_config.local
new file mode 100644
index 000000000..8979b6e1c
--- /dev/null
+++ b/sys-cluster/condor/files/condor_config.local
@@ -0,0 +1,9 @@
+CONDOR_DEVELOPERS = NONE
+CONDOR_HOST = $(FULL_HOSTNAME)
+COLLECTOR_NAME = Personal Condor
+START = TRUE
+SUSPEND = FALSE
+PREEMPT = FALSE
+KILL = FALSE
+DAEMON_LIST = COLLECTOR, MASTER, NEGOTIATOR, SCHEDD, STARTD
+NEGOTIATOR_INTERVAL = 20
diff --git a/sys-cluster/condor/files/log_lock_run.patch b/sys-cluster/condor/files/log_lock_run.patch
new file mode 100644
index 000000000..5f0991f7e
--- /dev/null
+++ b/sys-cluster/condor/files/log_lock_run.patch
@@ -0,0 +1,40 @@
+diff --git a/src/condor_examples/condor_config.generic b/src/condor_examples/con
+index 352f685..3f80b62 100644
+--- a/src/condor_examples/condor_config.generic
++++ b/src/condor_examples/condor_config.generic
+@@ -378,7 +378,7 @@
+ ## condor account, it's probably condor. Otherwise, it's whatever
+ ## you've set in the CONDOR_IDS environment variable. See the Admin
+ ## manual for details on this.
+-LOCK = $(LOG)
++LOCK = /var/lock/condor
+
+ ## If you don't use a fully qualified name in your /etc/hosts file
+ ## (or NIS, etc.) for either your official hostname or as an alias,
+@@ -878,15 +878,16 @@
+ ######################################################################
+
+ ## Pathnames
+-LOG = $(LOCAL_DIR)/log
++LOG = /var/log/condor
+ SPOOL = $(LOCAL_DIR)/spool
+ EXECUTE = $(LOCAL_DIR)/execute
+ BIN = $(RELEASE_DIR)/bin
+ LIB = $(RELEASE_DIR)/lib
+ INCLUDE = $(RELEASE_DIR)/include/condor
+ SBIN = $(RELEASE_DIR)/sbin
+ LIBEXEC = $(RELEASE_DIR)/libexec/condor
+ SHARE = $(RELEASE_DIR)/share/condor
++RUN = /var/run/condor
+
+ ## If you leave HISTORY undefined (comment it out), no history file
+ ## will be created.
+@@ -1559,7 +1560,7 @@
+ # UNIX); the name will be something like:
+ # \\.\pipe\condor_procd
+ #
+-PROCD_ADDRESS = $(LOCK)/procd_pipe
++PROCD_ADDRESS = $(RUN)/procd_pipe
+
+ # The procd currently uses a very simplistic logging system. Since this
+ # log will not be rotated like other Condor logs, it is only recommended
diff --git a/sys-cluster/condor/files/no_basename.patch b/sys-cluster/condor/files/no_basename.patch
new file mode 100644
index 000000000..e453c1626
--- /dev/null
+++ b/sys-cluster/condor/files/no_basename.patch
@@ -0,0 +1,51 @@
+diff --git a/src/condor_includes/basename.h b/src/condor_includes/basename.h
+index 923cc73..028411d 100644
+--- a/src/condor_includes/basename.h
++++ b/src/condor_includes/basename.h
+@@ -64,18 +64,6 @@ char* condor_dirname( const char* path );
+ char* condor_url_dirname( const char* path );
+
+ /*
+- DEPRECATED: because of non-const return value.
+-
+- A basename() function that is happy on both Unix and NT.
+- It returns a pointer to the last element of the path it was given,
+- or the whole string, if there are no directory delimiters. There's
+- no memory allocated, overwritten or changed in anyway.
+- PLEASE treat the return value as a _const_ char *!!! It's only
+- declared char * to avoid conflict with the system basename() declaration.
+-*/
+-/* const*/ char* basename( const char* path );
+-
+-/*
+ DEPRECATED: just in case we need changes along the lines of
+ condor_basename() some time in the future.
+
+diff --git a/src/condor_util_lib/basename.c b/src/condor_util_lib/basename.c
+index 8e1777c..ef71545 100644
+--- a/src/condor_util_lib/basename.c
++++ b/src/condor_util_lib/basename.c
+@@ -127,23 +127,6 @@ condor_url_dirname(const char *path)
+ }
+
+ /*
+- DEPRECATED: because of non-const return value.
+-
+- A basename() function that is happy on both Unix and NT.
+- It returns a pointer to the last element of the path it was given,
+- or the whole string, if there are no directory delimiters. There's
+- no memory allocated, overwritten or changed in anyway.
+- PLEASE treat the return value as a _const_ char *!!! It's only
+- declared char * to avoid conflict with the system basename() declaration.
+-*/
+-#if 0
+-/* const*/ char*
+- basename( const char* path ) {
+- return (char *)condor_basename( path );
+-}
+-#endif
+-
+-/*
+ DEPRECATED: just in case we need changes along the lines of
+ condor_basename() some time in the future.
+
diff --git a/sys-cluster/condor/files/no_rpmdb_query.patch b/sys-cluster/condor/files/no_rpmdb_query.patch
new file mode 100644
index 000000000..6c53503a9
--- /dev/null
+++ b/sys-cluster/condor/files/no_rpmdb_query.patch
@@ -0,0 +1,11 @@
+--- condor-7.2.1/src/configure.ac 2009-02-24 07:06:37.000000000 -0600
++++ condor-7.2.1mf/src/configure.ac 2009-02-24 07:05:46.000000000 -0600
+@@ -262,7 +262,7 @@
+ ;;
+ # Handle post-FC releases more robustly
+ * )
+- _cv_linux_distro=`$RPMQUERY -q --queryformat "F%{VERSION}" fedora-release`
++ _cv_linux_distro=F`cat /etc/fedora-release|$PERL -ne '/.* (.*) \((.*)\)/;print $1;'`
+ ;;
+ esac
+ elif test -f "/etc/redhat-release" ; then
diff --git a/sys-cluster/condor/files/stdsoap2.h.patch.patch b/sys-cluster/condor/files/stdsoap2.h.patch.patch
new file mode 100644
index 000000000..90face99b
--- /dev/null
+++ b/sys-cluster/condor/files/stdsoap2.h.patch.patch
@@ -0,0 +1,13 @@
+diff --git a/src/condor_daemon_core.V6/stdsoap2.h.patch b/src/condor_daemon_core.V6/stdsoap2.h.patch
+index a0fe3ed..c84abe7 100644
+--- a/src/condor_daemon_core.V6/stdsoap2.h.patch
++++ b/src/condor_daemon_core.V6/stdsoap2.h.patch
+@@ -47,7 +47,7 @@
+ @@ -418,8 +427,8 @@
+ #endif
+
+- #if defined(__cplusplus) && !defined(WITH_LEAN)
++ #if defined(__cplusplus) && !defined(WITH_LEAN) && !defined(WITH_COMPAT)
+ -# include <string>
+ -# include <iostream>
+ +# include <string.h>