aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-06-29 21:50:41 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2011-06-29 21:52:13 +0400
commitaf1becc28309a7351ad34b096bc1e1201da693bd (patch)
treec15d30ff2906310039575186b3c12aad2e41db39 /sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-af1becc28309a7351ad34b096bc1e1201da693bd.tar.gz
sci-af1becc28309a7351ad34b096bc1e1201da693bd.tar.bz2
sci-af1becc28309a7351ad34b096bc1e1201da693bd.zip
[sys-cluster/ganglia_jobmonarch] Import per bug #297587
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild')
-rw-r--r--sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild b/sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild
new file mode 100644
index 000000000..dc1b01006
--- /dev/null
+++ b/sys-cluster/ganglia_jobmonarch/ganglia_jobmonarch-0.3.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+WEBAPP_OPTIONAL="yes"
+inherit eutils webapp depend.php
+
+DESCRIPTION="Ganglia addons for Torque"
+HOMEPAGE="https://subtrac.sara.nl/oss/jobmonarch/"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/jobmonarch/latest/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vhosts"
+WEBAPP_MANUAL_SLOT="yes"
+
+GANGLIA="ganglia"
+JOBMONARCH="ganglia_jobmonarch"
+
+DEPEND="
+ sys-cluster/ganglia
+ dev-lang/php[gd,xml,ctype]
+ media-libs/gd
+ sys-cluster/pbs-python
+ dev-python/pypgsql
+ ${WEBAPP_DEPEND}"
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix.patch
+}
+
+src_install() {
+ insinto /etc
+ doins "${S}/jobmond/jobmond.conf"
+ doins "${S}/jobarchived/jobarchived.conf"
+
+ insinto /usr/share/jobmonarch/
+ doins "${S}/jobarchived/job_dbase.sql"
+
+ dodir /var/lib/jobarchive
+
+ insopts -m0755
+ insinto /sbin
+ doins "${S}/jobmond/jobmond.py"
+ doins "${S}/jobarchived/jobarchived.py"
+ doins "${S}/jobarchived/pipe_jobarchived.py"
+ doins "${FILESDIR}/job_monarch_link.sh"
+
+ newinitd "${FILESDIR}/jobmond.initd" jobmond
+ newinitd "${FILESDIR}/jobarchived.initd" jobarchived
+
+ cd "${S}/web/templates/job_monarch/"
+ rm images/*
+ rmdir images
+
+ cd "${S}"
+ webapp_src_preinst
+ insinto "${MY_HTDOCSDIR}"
+ doins -r web/*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/addons/job_monarch/conf.php
+ webapp_src_install
+
+ ewarn
+ ewarn "You must Execute: job_monarch_link.sh install ${GANGLIA} ${JOBMONARCH} to have the JobMonArch installed under ganglia"
+ ewarn
+ ewarn "You must Execute: job_monarch_link.sh uninstall ${GANGLIA} to remove link from ganglia directories"
+ ewarn
+}