aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 23:15:25 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-21 23:15:25 +0100
commitedcc2c3994fa87e67d786effe13a8f993fc65705 (patch)
tree505245641d5616e83aaf62712a8a6306ed47460a /sys-cluster/hpl
parent[dev-python/Forthon] Fix option parser to take into account that wrapper file... (diff)
downloadsci-edcc2c3994fa87e67d786effe13a8f993fc65705.tar.gz
sci-edcc2c3994fa87e67d786effe13a8f993fc65705.tar.bz2
sci-edcc2c3994fa87e67d786effe13a8f993fc65705.zip
sys-cluster/hpl: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; add missing dep on virtual/pkgconfig
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'sys-cluster/hpl')
-rw-r--r--sys-cluster/hpl/ChangeLog6
-rw-r--r--sys-cluster/hpl/Manifest2
-rw-r--r--sys-cluster/hpl/hpl-2.0-r1.ebuild20
-rw-r--r--sys-cluster/hpl/metadata.xml12
4 files changed, 24 insertions, 16 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index fdac651ee..e04d23ec1 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sys-cluster/hpl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> hpl-2.0-r1.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ add missing dep on virtual/pkgconfig
+
01 Feb 2011; Justin Bronder <jsbronder@gentoo.org> hpl-2.0-r1.ebuild:
Bump EAPI thanks to scarabeus.
diff --git a/sys-cluster/hpl/Manifest b/sys-cluster/hpl/Manifest
index 2a37cfd98..21c146598 100644
--- a/sys-cluster/hpl/Manifest
+++ b/sys-cluster/hpl/Manifest
@@ -1 +1 @@
-DIST hpl-2.0.tar.gz 591087 RMD160 f9182ee706147c118fcf95cc0db878e02698c18a SHA1 1c199640146e9d87916475aa153c45f30e42f803 SHA256 d8d118c310d34a5a2acf5a689270a9f7bea60245552d24af8641599651909bec
+DIST hpl-2.0.tar.gz 591087 SHA256 d8d118c310d34a5a2acf5a689270a9f7bea60245552d24af8641599651909bec
diff --git a/sys-cluster/hpl/hpl-2.0-r1.ebuild b/sys-cluster/hpl/hpl-2.0-r1.ebuild
index bec50921d..2db92137a 100644
--- a/sys-cluster/hpl/hpl-2.0-r1.ebuild
+++ b/sys-cluster/hpl/hpl-2.0-r1.ebuild
@@ -1,22 +1,26 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-1.0-r2.ebuild,v 1.1 2005/09/01 11:59:18 pbienst Exp $
EAPI=4
-inherit eutils mpi
-DESCRIPTION="Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+inherit eutils mpi toolchain-funcs
+
+DESCRIPTION="High-Performance Linpack Benchmark for Distributed-Memory Computers"
HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
+
LICENSE="HPL"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-
IUSE="doc"
-DEPEND="$(mpi_pkg_deplist)
+
+DEPEND="
+ $(mpi_pkg_deplist)
virtual/blas
virtual/lapack"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ virtual/pkgconfig"
src_prepare() {
local mpicc_path="$(mpi_pkg_cc)"
@@ -28,10 +32,10 @@ src_prepare() {
-e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
-e '/^MPdir\>/s,= .*,=,' \
-e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s,= .*,= $(pkg-config --libs-only-l blas lapack)," \
+ -e "/^LAlib\>/s,= .*,= $($(tc-getPKG_CONFIG) --libs-only-l blas lapack)," \
-e "/^LINKER\>/s,= .*,= ${mpicc_path}," \
-e "/^CC\>/s,= .*,= ${mpicc_path}," \
- -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS} $(pkg-config --libs-only-L blas lapack)|" \
+ -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS} $($(tc-getPKG_CONFIG) --libs-only-L blas lapack)|" \
Make.gentoo_hpl_fblas_x86 || die
}
diff --git a/sys-cluster/hpl/metadata.xml b/sys-cluster/hpl/metadata.xml
index db933d7a6..c4c0f8c68 100644
--- a/sys-cluster/hpl/metadata.xml
+++ b/sys-cluster/hpl/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>cluster</herd>
-<maintainer>
- <email>tantive@gentoo.org</email>
- <name>Michael Imhof</name>
- <description>Release manager, patch manager</description>
-</maintainer>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>tantive@gentoo.org</email>
+ <name>Michael Imhof</name>
+ <description>Release manager, patch manager</description>
+ </maintainer>
</pkgmetadata>