aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2014-07-21 23:00:02 +0200
committerAndreas Schäfer <gentryx@gmx.de>2014-07-21 23:00:02 +0200
commit0c47baa6e043d3c21aadcd312f5baccd7f28b425 (patch)
tree39bb8c45c994d6de685d1afe48ac30298381f6ea /sys-cluster/hpx
parentmerge (diff)
downloadsci-0c47baa6e043d3c21aadcd312f5baccd7f28b425.tar.gz
sci-0c47baa6e043d3c21aadcd312f5baccd7f28b425.tar.bz2
sci-0c47baa6e043d3c21aadcd312f5baccd7f28b425.zip
more corrections
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-0.9.8.ebuild13
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild2
2 files changed, 5 insertions, 10 deletions
diff --git a/sys-cluster/hpx/hpx-0.9.8.ebuild b/sys-cluster/hpx/hpx-0.9.8.ebuild
index 182746f93..ac3aad76f 100644
--- a/sys-cluster/hpx/hpx-0.9.8.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.8.ebuild
@@ -9,14 +9,17 @@ PYTHON_COMPAT=( python{2_6,2_7} )
if [ ${PV} == "9999" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
- SRC_URI=""
KEYWORDS=""
S="${WORKDIR}/${PN}"
- CMAKE_USE_DIR="${S}"
else
SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
+ PATCHES=(
+ "${FILESDIR}"/${P}-install-path.patch
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-cmake_dir.patch
+ )
fi
inherit cmake-utils fortran-2 multilib python-single-r1
@@ -48,12 +51,6 @@ DEPEND="${RDEPEND}
"
REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-PATCHES=(
- "${FILESDIR}"/hpx-0.9.8-install-path.patch
- "${FILESDIR}"/hpx-0.9.8-multilib.patch
- "${FILESDIR}"/hpx-0.9.8-cmake_dir.patch
-)
-
pkg_setup() {
use test && python-single-r1_pkg_setup
}
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 8d76801b1..5e56db937 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -9,9 +9,7 @@ PYTHON_COMPAT=( python{2_6,2_7} )
if [ ${PV} == "9999" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
- SRC_URI=""
KEYWORDS=""
- CMAKE_USE_DIR="${S}"
else
SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"