aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-30 23:22:54 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-12-30 23:22:54 +0000
commit45cd6c9621fa2179c614f07223e01cb8002d95aa (patch)
tree63e7cac6ffad3a1bf1246af35f1492e177d62ad9 /sys-cluster/htcondor/htcondor-8.0.0.ebuild
parentsci-mathematics/dsfmt: format metadata (diff)
downloadsci-45cd6c9621fa2179c614f07223e01cb8002d95aa.tar.gz
sci-45cd6c9621fa2179c614f07223e01cb8002d95aa.tar.bz2
sci-45cd6c9621fa2179c614f07223e01cb8002d95aa.zip
sys-cluster/htcondor: drop broken package
really broken, needs systemd only or major changes to make it work with elogind (which are not supported by upstream) Needs a lot of dependencies not in tree Suggested replacement sys-cluster/slurm or use binary packages or local compilations Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-cluster/htcondor/htcondor-8.0.0.ebuild')
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild114
1 files changed, 0 insertions, 114 deletions
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
deleted file mode 100644
index bc2cde521..000000000
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-CMAKE_MIN_VERSION=2.8
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit cmake-utils python-single-r1 user
-
-DESCRIPTION="Workload management system for compute-intensive jobs"
-HOMEPAGE="http://www.cs.wisc.edu/htcondor/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/V${PV//./_}.tar.gz -> ${P}.tar.gz"
-#SRC_URI="condor_src-${PV}-all-all.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boinc cgroup contrib curl doc kerberos libvirt minimal postgres python soap ssl test X xml"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="
- sys-libs/zlib
- >=dev-libs/libpcre-7.6
- $(python_gen_cond_dep '
- dev-libs/boost[${PYTHON_USEDEP}]
- ')
- net-nds/openldap
- boinc? ( sci-misc/boinc )
- cgroup? ( >=dev-libs/libcgroup-0.37 )
- curl? ( >=net-misc/curl-7.19.7[ssl?] )
- libvirt? ( >=app-emulation/libvirt-0.6.2 )
- kerberos? ( virtual/krb5 )
- X? ( x11-libs/libX11 )
- postgres? ( >=dev-db/postgresql-8.2.4:= )
- python? ( ${PYTHON_DEPS} )
- soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
- ssl? ( >=dev-libs/openssl-0.9.8i:0 )
- xml? ( >=dev-libs/libxml2-2.7.3 )"
-
-DEPEND="${CDEPEND}
- test? ( dev-util/valgrind )"
-
-RDEPEND="${CDEPEND}
- mail-client/mailx"
-
-S="${WORKDIR}/condor-${PV}"
-PATCHES=(
- "${FILESDIR}"/condor_shadow_dlopen-${PV}.patch
- "${FILESDIR}"/condor_config.generic.patch
- "${FILESDIR}"/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch
- "${FILESDIR}"/packaging_directories-${PV}.patch
- "${FILESDIR}"/fix_sandbox_violations-${PV}.patch
-)
-
-pkg_setup() {
- enewgroup condor
- enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
-}
-
-src_configure() {
- # All the hard coded -DWITH_X=OFF flags are for packages that aren't in portage
- # I also haven't included support for HAVE_VMWARE because I don't know what it requires
- local mycmakeargs="
- -DCONDOR_PACKAGE_BUILD=ON
- -DCMAKE_INSTALL_PREFIX=/
- -DWITH_BLAHP=OFF
- -DWITH_CAMPUSFACTORY=OFF
- -DWITH_CLUSTER_RA=OFF
- -DWITH_COREDUMPER=OFF
- -DWITH_CREAM=OFF
- -DWITH_GLOBUS=OFF
- -DWITH_LIBDELTACLOUD=OFF
- -DWITH_BLAHP=OFF
- -DWITH_QPID=OFF
- -DWITH_UNICOREGAHP=OFF
- -DWITH_VOMS=OFF
- -DWITH_WSO2=OFF
- -DWITH_MANAGEMENT=OFF
- $(cmake-utils_use_has boinc BACKFILL)
- $(cmake-utils_use_has boinc)
- $(cmake-utils_use_with cgroup LIBCGROUP)
- $(cmake-utils_use_want contrib)
- $(cmake-utils_use_with curl)
- $(cmake-utils_use_want doc MAN_PAGES)
- $(cmake-utils_use_with libvirt)
- $(cmake-utils_use_has X KBDD)
- $(cmake-utils_use_with kerberos KRB5)
- $(cmake-utils_use_with postgres POSTGRESQL)
- $(cmake-utils_use_with python PYTHON_BINDINGS)
- $(cmake-utils_use minimal CLIPPED)
- $(cmake-utils_use_with soap AVIARY)
- $(cmake-utils_use_with soap GSOAP)
- $(cmake-utils_use_with ssl OPENSSL)
- $(cmake-utils_use_build test TESTING)
- $(cmake-utils_use_with xml LIBXML2)"
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- dodir /var/lib/condor
- dodir /var/log/condor
- dodir /var/run/condor
- dodir /var/lock/condor
-
- fperms 750 /var/lib/condor /var/log/condor
- fperms 755 /var/run/condor
- fperms 0775 /var/lock/condor
- fowners condor:condor /var/lib/condor /var/log/condor /var/run/condor
-}