aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-06-17 20:52:25 +0100
committerChris Kerr <cjk34@cam.ac.uk>2013-06-17 20:52:25 +0100
commit6d3e0bc8e58a833002041b464f5a8bf689664f6f (patch)
tree34f059127cd5e6ae871c090679b92b9972586955 /sys-cluster/htcondor/htcondor-8.0.0.ebuild
parentDeleted old ebuilds now they aren't needed to copy code from (diff)
downloadsci-6d3e0bc8e58a833002041b464f5a8bf689664f6f.tar.gz
sci-6d3e0bc8e58a833002041b464f5a8bf689664f6f.tar.bz2
sci-6d3e0bc8e58a833002041b464f5a8bf689664f6f.zip
Fixed repoman complaints
Diffstat (limited to 'sys-cluster/htcondor/htcondor-8.0.0.ebuild')
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index 79d4c68b7..d5f570fb2 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -4,9 +4,9 @@
EAPI=5
CMAKE_MIN_VERSION=2.8
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit cmake-utils python-single-r1
+inherit cmake-utils python-single-r1 user
DESCRIPTION="Workload management system for compute-intensive jobs"
HOMEPAGE="http://www.cs.wisc.edu/htcondor/"
@@ -15,11 +15,11 @@ SRC_URI="condor_src-${PV}-all-all.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="boinc cgroup contrib curl dmtcp doc kbdd kerberos libvirt management minimal postgres python soap ssl test xml"
+IUSE="boinc cgroup contrib curl dmtcp doc kerberos libvirt management minimal postgres python soap ssl test X xml"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="sys-libs/zlib
+CDEPEND="sys-libs/zlib
>=dev-libs/libpcre-7.6
>=dev-libs/boost-1.49.0[${PYTHON_USEDEP}]
net-nds/openldap
@@ -29,16 +29,18 @@ DEPEND="sys-libs/zlib
dmtcp? ( sys-apps/dmtcp )
libvirt? ( >=app-emulation/libvirt-0.6.2 )
kerberos? ( virtual/krb5 )
- kbdd? ( x11-libs/libX11 )
+ X? ( x11-libs/libX11 )
management? ( net-libs/qmf )
postgres? ( >=dev-db/postgresql-base-8.2.4 )
python? ( ${PYTHON_DEPS} )
soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
ssl? ( >=dev-libs/openssl-0.9.8i )
- test? ( dev-util/valgrind )
xml? ( >=dev-libs/libxml2-2.7.3 )"
-RDEPEND="${DEPEND}
+DEPEND="${CDEPEND}
+ test? ( dev-util/valgrind )"
+
+RDEPEND="${CDEPEND}
mail-client/mailx"
RESTRICT=fetch
@@ -80,7 +82,7 @@ src_configure() {
$(cmake-utils_use_with curl)
$(cmake-utils_use_want doc MAN_PAGES)
$(cmake-utils_use_with libvirt)
- $(cmake-utils_use_has kbdd)
+ $(cmake-utils_use_has X KBDD)
$(cmake-utils_use_with kerberos KRB5)
$(cmake-utils_use_with postgres POSTGRESQL)
$(cmake-utils_use_with python PYTHON_BINDINGS)