aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-01-05 17:18:26 -0700
committerChristoph Junghans <ottxor@gentoo.org>2015-01-05 17:18:26 -0700
commitae8c8f93658125d916689faee4a18e58a9b46373 (patch)
treeeafbef987d67305366431e4812cb6b6f8437969e /sys-cluster/htcondor
parent2 new upstream patches of sci-chemistry/nwchem-6.5_p26243 added, USE_NOIO uns... (diff)
downloadsci-ae8c8f93658125d916689faee4a18e58a9b46373.tar.gz
sci-ae8c8f93658125d916689faee4a18e58a9b46373.tar.bz2
sci-ae8c8f93658125d916689faee4a18e58a9b46373.zip
version bump, untested (fixes #220)
Package-Manager: portage-2.2.14
Diffstat (limited to 'sys-cluster/htcondor')
-rw-r--r--sys-cluster/htcondor/ChangeLog5
-rw-r--r--sys-cluster/htcondor/Manifest1
-rw-r--r--sys-cluster/htcondor/htcondor-8.3.2.ebuild111
3 files changed, 117 insertions, 0 deletions
diff --git a/sys-cluster/htcondor/ChangeLog b/sys-cluster/htcondor/ChangeLog
index 476c00499..1dafb4820 100644
--- a/sys-cluster/htcondor/ChangeLog
+++ b/sys-cluster/htcondor/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*htcondor-8.3.2 (06 Jan 2015)
+
+ 06 Jan 2015; Christoph Junghans <ottxor@gentoo.org> +htcondor-8.3.2.ebuild:
+ version bump, untested (fixes #220)
+
05 Jan 2015; Christoph Junghans <ottxor@gentoo.org> htcondor-8.0.0.ebuild:
fixed deps
diff --git a/sys-cluster/htcondor/Manifest b/sys-cluster/htcondor/Manifest
index fe70962d9..fcebb1f53 100644
--- a/sys-cluster/htcondor/Manifest
+++ b/sys-cluster/htcondor/Manifest
@@ -1 +1,2 @@
DIST condor_src-8.0.0-all-all.tar.gz 18636227 SHA256 b1fe7cedcab17d713a64b57dbb2a5f0426979316b8f309f9492ff60f7b43d3a8 SHA512 a335d0cb200f1899711f6f87968a01a2f5dcd37fede2ef973f2863a3f628d6f04421abbaaa22a310711ea1367af3a4f68e31c5e91e8cee1149cc5957d6ac0119 WHIRLPOOL 4c755644cd2ba5f7414ac3c8374df141b98d3e830f07a0ea0e0cc46b575ac8b42c1e47135cb9a87342bd41309b03df1693de1836cd250ea7e6ace1c3445ebd25
+DIST htcondor-8.3.2.tar.gz 18451391 SHA256 e7e0c2e9bb0983c4cb1ec5f5e748fb7879a4570fef9f88979a5935f972bdc80b SHA512 588d2dd4586be6d135a658cc54b01ed2c02a1127495af68c73f69d33df98bdafe7e1fc248950e4af3ca14fc1bd6329f003a61daf875580646eddabe6201b353c WHIRLPOOL 0edc3ad1bdb3af1f69b00097641af730bab25869822f58d2f157eddefe19ef5f7be6ea9865cee363089f3aeb9bf24f3d073f15e31eaac2c5acbc28954111b12c
diff --git a/sys-cluster/htcondor/htcondor-8.3.2.ebuild b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
new file mode 100644
index 000000000..638715b2d
--- /dev/null
+++ b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+CMAKE_MIN_VERSION=2.8
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cmake-utils python-single-r1 user vcs-snapshot
+
+DESCRIPTION="Workload management system for compute-intensive jobs"
+HOMEPAGE="http://htcondorproject.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/V${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+#KEYWORDS="~amd64 ~x86"
+IUSE="boinc cgroup contrib curl dmtcp doc kerberos libvirt management minimal postgres python soap ssl test X xml"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="sys-libs/zlib
+ >=dev-libs/libpcre-7.6
+ >=dev-libs/boost-1.49.0[${PYTHON_USEDEP}]
+ net-nds/openldap
+ boinc? ( sci-misc/boinc )
+ cgroup? ( >=dev-libs/libcgroup-0.37 )
+ curl? ( >=net-misc/curl-7.19.7[ssl?] )
+ dmtcp? ( sys-apps/dmtcp )
+ libvirt? ( >=app-emulation/libvirt-0.6.2 )
+ kerberos? ( virtual/krb5 )
+ X? ( x11-libs/libX11 )
+ management? ( net-libs/qmf )
+ postgres? ( >=dev-db/postgresql-8.2.4 )
+ python? ( ${PYTHON_DEPS} )
+ soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
+ ssl? ( >=dev-libs/openssl-0.9.8i )
+ xml? ( >=dev-libs/libxml2-2.7.3 )"
+
+DEPEND="${CDEPEND}
+ test? ( dev-util/valgrind )"
+
+RDEPEND="${CDEPEND}
+ virtual/mailx"
+
+pkg_setup() {
+ enewgroup condor
+ enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/condor_shadow_dlopen-${PV}.patch"
+ epatch "${FILESDIR}/condor_config.generic.patch"
+ epatch "${FILESDIR}/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch"
+ epatch "${FILESDIR}/packaging_directories-8.0.0.patch"
+ epatch "${FILESDIR}/fix_sandbox_violations-8.0.0.patch"
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # All the hard coded -DWITH_X=OFF flags are for packages that aren't in portage
+ # I also haven't included support for HAVE_VMWARE because I don't know what it requires
+ local mycmakeargs="
+ -DCONDOR_PACKAGE_BUILD=ON
+ -DCMAKE_INSTALL_PREFIX=/
+ -DWITH_BLAHP=OFF
+ -DWITH_CAMPUSFACTORY=OFF
+ -DWITH_CLUSTER_RA=OFF
+ -DWITH_COREDUMPER=OFF
+ -DWITH_CREAM=OFF
+ -DWITH_GLOBUS=OFF
+ -DWITH_LIBDELTACLOUD=OFF
+ -DWITH_BLAHP=OFF
+ -DWITH_QPID=OFF
+ -DWITH_UNICOREGAHP=OFF
+ -DWITH_VOMS=OFF
+ -DWITH_WSO2=OFF
+ $(cmake-utils_use_has boinc BACKFILL)
+ $(cmake-utils_use_has boinc)
+ $(cmake-utils_use_with cgroup LIBCGROUP)
+ $(cmake-utils_use_want contrib)
+ $(cmake-utils_use_with curl)
+ $(cmake-utils_use_want doc MAN_PAGES)
+ $(cmake-utils_use_with libvirt)
+ $(cmake-utils_use_has X KBDD)
+ $(cmake-utils_use_with kerberos KRB5)
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with python PYTHON_BINDINGS)
+ $(cmake-utils_use_with management)
+ $(cmake-utils_use minimal CLIPPED)
+ $(cmake-utils_use_with soap AVIARY)
+ $(cmake-utils_use_with soap GSOAP)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use_with xml LIBXML2)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodir /var/lib/condor
+ dodir /var/log/condor
+ dodir /var/run/condor
+ dodir /var/lock/condor
+
+ fperms 750 /var/lib/condor /var/log/condor
+ fperms 755 /var/run/condor
+ fperms 0775 /var/lock/condor
+ fowners condor:condor /var/lib/condor /var/log/condor /var/run/condor
+}