aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjsbronder <jsbronder@32389bae-6d03-0410-99cf-db05cde120eb>2008-11-05 02:48:55 +0000
committerjsbronder <jsbronder@32389bae-6d03-0410-99cf-db05cde120eb>2008-11-05 02:48:55 +0000
commit476d06be03986817e429926a068cf7bf16ee3955 (patch)
tree24b9c03fe2dca1744976782e97ef048b2aef074d /sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
parentIntegrate Joel's fixes for #220877 into mpich2 (fpic ->fPIC) (diff)
downloadsci-476d06be03986817e429926a068cf7bf16ee3955.tar.gz
sci-476d06be03986817e429926a068cf7bf16ee3955.tar.bz2
sci-476d06be03986817e429926a068cf7bf16ee3955.zip
sys-cluster/mpe2 needs to handle building without empi.
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1334 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild')
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
index 67c113a93..68a68e9e8 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
@@ -41,7 +41,13 @@ pkg_setup() {
local i
mpi_pkg_setup
- MPE_IMP=$(mpi_built_with)
+ if [ -n "${MPI_IMP}" ]; then
+ MPE_IMP=$(mpi_built_with)
+ else
+ # Hack until mpi.eclass is fixed to store ${PN}
+ has_version "sys-cluster/openmpi" && MPE_IMP="openmpi"
+ has_version "sys-cluster/mpich2" && MPE_IMP="mpich2"
+ fi
if use fortran ; then
FORTRAN="g77 gfortran ifort ifc"