aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-16 17:07:35 -0700
committerChristoph Junghans <ottxor@gentoo.org>2015-02-16 17:07:35 -0700
commite2549a4ec7ad969184eae1a491e451868c4b32c2 (patch)
treeb5d7aa0d3305ba9f1a648a7468baa3415be07955 /sys-cluster/mpich2
parentadded multilib mpi for testing (diff)
downloadsci-e2549a4ec7ad969184eae1a491e451868c4b32c2.tar.gz
sci-e2549a4ec7ad969184eae1a491e451868c4b32c2.tar.bz2
sci-e2549a4ec7ad969184eae1a491e451868c4b32c2.zip
added multilib mpi for testing
Package-Manager: portage-2.2.14
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/ChangeLog8
-rw-r--r--sys-cluster/mpich2/mpich2-1.5-r1.ebuild125
2 files changed, 131 insertions, 2 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 62400dc4d..0d8cea555 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-cluster/mpich2
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mpich2-1.5-r1 (17 Feb 2015)
+
+ 17 Feb 2015; Christoph Junghans <ottxor@gentoo.org> +mpich2-1.5-r1.ebuild:
+ added multilib mpi for testing
+
04 Dec 2013; Justin Lecher <jlec@gentoo.org> -mpich2-1.2.1_p1-r2.ebuild,
-mpich2-1.4.1_p1.ebuild, metadata.xml:
Drop old
@@ -176,4 +181,3 @@
sys-cluster/mpich2/mpich2-1.0.8.ebuild:
sys-cluster/mpich-1.0.8 bugfixes, no revbump. Fix some doc file locations
(#255748). Fix sandbox errors (254167).
-
diff --git a/sys-cluster/mpich2/mpich2-1.5-r1.ebuild b/sys-cluster/mpich2/mpich2-1.5-r1.ebuild
new file mode 100644
index 000000000..a1ae784bf
--- /dev/null
+++ b/sys-cluster/mpich2/mpich2-1.5-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.5.ebuild,v 1.9 2013/07/09 22:26:38 jsbronder Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2 multilib-minimal
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mcs.anl.gov/research/projects/mpich2/index.php"
+SRC_URI="http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="mpich2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cxx doc fortran mpi-threads romio threads"
+
+COMMON_DEPEND="
+ >=dev-libs/libaio-0.3.109-r5[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-1.10.0-r2[${MULTILIB_USEDEP}]
+ romio? ( net-fs/nfs-utils )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-cluster/mpich
+ !sys-cluster/openmpi"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpicxx.h
+ /usr/include/mpi.h
+ /usr/include/mpif.h
+ /usr/include/opa_config.h
+)
+
+pkg_setup() {
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
+
+ if use mpi-threads && ! use threads; then
+ ewarn "mpi-threads requires threads, assuming that's what you want"
+ fi
+}
+
+src_prepare() {
+ # Using MPICH2LIB_LDFLAGS doesn't seem to full work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich2.pc.in \
+ src/env/*.in \
+ || die
+}
+
+multilib_src_configure() {
+ local c="--enable-shared"
+
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories.
+
+ if use mpi-threads; then
+ # MPI-THREAD requries threading.
+ c="${c} --with-thread-package=pthreads"
+ c="${c} --enable-threads=runtime"
+ else
+ if use threads ; then
+ c="${c} --with-thread-package=pthreads"
+ else
+ c="${c} --with-thread-package=none"
+ fi
+ c="${c} --enable-threads=single"
+ fi
+
+ export MPICH2LIB_CFLAGS=${CFLAGS}
+ export MPICH2LIB_CPPFLAGS=${CPPFLAGS}
+ export MPICH2LIB_CXXFLAGS=${CXXFLAGS}
+ export MPICH2LIB_FFLAGS=${FFLAGS}
+ export MPICH2LIB_FCFLAGS=${FCFLAGS}
+ export MPICH2LIB_LDFLAGS=${LDFLAGS}
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ ECONF_SOURCE=${S} econf ${c} \
+ --with-pm=hydra \
+ --disable-mpe \
+ --disable-fast \
+ --enable-smpcoll \
+ --enable-versioning \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(use_enable fortran fortran all)
+}
+
+multilib_src_test() {
+ emake -j1 check
+}
+
+multilib_src_install() {
+ default
+
+ #fortran modules are arch-specific, follow OpenMPI and put them in lib
+ if use fortran; then
+ mv "${ED}"/usr/include/*.mod "${ED}"/usr/$(get_libdir) || die
+ fi
+}
+
+multilib_src_install_all() {
+ dodir /usr/share/doc/${PF}
+ dodoc COPYRIGHT README{,.envvar} CHANGES RELEASE_NOTES
+ newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ newdoc src/mpi/romio/README README.romio
+ fi
+
+ if ! use doc; then
+ rm -rf "${D}"usr/share/doc/${PF}/www*
+ fi
+}