aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@ultrabug.net>2011-01-03 11:38:22 +0100
committerUltrabug <ultrabug@ultrabug.net>2011-01-03 11:38:22 +0100
commit2b674a7e96accafa8e9ac356242f796d96ebaea8 (patch)
treeaf3407f8b156423c847bba1cbd3dc7bc55bba26f /sys-cluster
parentVersion Bump (diff)
downloadsci-2b674a7e96accafa8e9ac356242f796d96ebaea8.tar.gz
sci-2b674a7e96accafa8e9ac356242f796d96ebaea8.tar.bz2
sci-2b674a7e96accafa8e9ac356242f796d96ebaea8.zip
[sys-cluster/corosync] version bump
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/Manifest5
-rw-r--r--sys-cluster/corosync/corosync-1.3.0.ebuild58
-rw-r--r--sys-cluster/corosync/files/corosync-docs.patch37
-rw-r--r--sys-cluster/corosync/files/corosync.initd23
-rw-r--r--sys-cluster/corosync/files/corosync.logrotate5
5 files changed, 128 insertions, 0 deletions
diff --git a/sys-cluster/corosync/Manifest b/sys-cluster/corosync/Manifest
new file mode 100644
index 000000000..91bfbd10b
--- /dev/null
+++ b/sys-cluster/corosync/Manifest
@@ -0,0 +1,5 @@
+AUX corosync-docs.patch 1022 RMD160 9da3f7a1cdac81449062d5350442d3074f7af436 SHA1 5a128926e053e25ca96c8c6ade3a4f376f481137 SHA256 0c988b55ea471d9c413c0143d2a523a683a324c23de5dd82bcba62676eea6857
+AUX corosync.initd 601 RMD160 b7f519ba3a7bf8bbcd56e581a123711bfff9e653 SHA1 1ca9c0baa0bf35cf96400913128bcffa858d62b6 SHA256 8e5a18febe55a08b8b5be80ca2e3b81cdf961784d7a2f246b9064825d3a847bc
+AUX corosync.logrotate 93 RMD160 593cacdb73f77f1c4b6f27804480a67ca265aadd SHA1 f26f84cb7d275e8f94ae15466a455ae332fcacbd SHA256 97ce0519c66e04936ff110ef530a73c7c6b48fa34a8cb8c178c2120daf67db6c
+DIST corosync-1.3.0.tar.gz 683458 RMD160 11d1560c62a23df4111237b07e708aabfee1e665 SHA1 d2bb5ca7b0ee780d01da8f671334242ca00d7bf0 SHA256 4f9e399befcb595a1671f7ddb54dbf53e1faad6416da1415e2d787e6d2eb94a5
+EBUILD corosync-1.3.0.ebuild 1238 RMD160 f23a7b83ba9475f4985d4f6e8f4fdb13f70f0cd9 SHA1 2e1665be72ae28369088028c2b3b08fd199f6ff7 SHA256 788502070c6c3e2852210ef10908213ed5ec926f3257adf5aeeb9ce5f492f333
diff --git a/sys-cluster/corosync/corosync-1.3.0.ebuild b/sys-cluster/corosync/corosync-1.3.0.ebuild
new file mode 100644
index 000000000..5e2609926
--- /dev/null
+++ b/sys-cluster/corosync/corosync-1.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit base autotools
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="ftp://ftp:${PN}.org@${PN}.org/downloads/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc infiniband ssl"
+
+RDEPEND="!sys-cluster/heartbeat
+ ssl? ( dev-libs/nss )
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docs.patch"
+)
+
+DOCS=( "README.recovery" "README.devmap" "SECURITY" "TODO" "AUTHORS" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install both static and shared libs
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable ssl nss) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ base_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN} || die
+
+ keepdir /var/lib/corosync
+}
diff --git a/sys-cluster/corosync/files/corosync-docs.patch b/sys-cluster/corosync/files/corosync-docs.patch
new file mode 100644
index 000000000..198db980a
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-docs.patch
@@ -0,0 +1,37 @@
+Make docs optional
+
+--- configure.ac
++++ configure.ac
+@@ -432,7 +432,7 @@
+ fi
+
+ # final build of *FLAGS
+-CFLAGS="$ENV_CFLAGS $OPT_CFLAGS $GDB_FLAGS $OS_CFLAGS \
++CFLAGS="$ENV_CFLAGS $OS_CFLAGS \
+ $COVERAGE_CFLAGS $EXTRA_WARNINGS $WERROR_CFLAGS $NSS_CFLAGS"
+ CPPFLAGS="$ENV_CPPFLAGS $ANSI_CPPFLAGS $OS_CPPFLAGS"
+ LDFLAGS="$ENV_LDFLAGS $COVERAGE_LDFLAGS $OS_LDFLAGS"
+@@ -458,7 +458,10 @@
+ AC_SUBST([DARWIN_OPTS])
+ AC_SUBST([SOLARIS_OPTS])
+
+-AM_CONDITIONAL(BUILD_HTML_DOCS, test -n "${GROFF}")
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc],[Build html documentation])
++)
++AM_CONDITIONAL(BUILD_HTML_DOCS, [test -n "${GROFF}" && test "x$enable_doc" = "xyes"] )
+
+ AC_SUBST([LINT_FLAGS])
+
+--- Makefile.am
++++ Makefile.am
+@@ -41,9 +41,6 @@
+ config.guess config.sub missing install-sh \
+ autoheader automake autoconf
+
+-dist_doc_DATA = LICENSE INSTALL README.devmap \
+- README.recovery SECURITY TODO AUTHORS
+-
+ corosysconfdir = ${COROSYSCONFDIR}
+
+ corosysconf_DATA = conf/corosync.conf.example
diff --git a/sys-cluster/corosync/files/corosync.initd b/sys-cluster/corosync/files/corosync.initd
new file mode 100644
index 000000000..6c134bd93
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/files/corosync.initd,v 1.2 2010/11/17 07:07:03 xarthisius Exp $
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting Corosync Cluster Engine"
+ start-stop-daemon --start -q --exec /usr/sbin/corosync \
+ --pidfile /var/run/corosync.pid --make-pidfile --background \
+ -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Corosync Cluster Engine"
+ start-stop-daemon --stop -q --pidfile /var/run/corosync.pid
+ eend $?
+}
diff --git a/sys-cluster/corosync/files/corosync.logrotate b/sys-cluster/corosync/files/corosync.logrotate
new file mode 100644
index 000000000..6c0952dcb
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync.logrotate
@@ -0,0 +1,5 @@
+/var/log/cluster/corosync.log {
+ missingok
+ notifempty
+ sharedscripts
+}