aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 16:28:48 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 16:28:48 +0100
commit955584b7b0077bed0a8551086b3ac027b6972033 (patch)
treea3c74c5ece415ffb8560969903c2be48b1baef82 /sys-cluster
parentsci-chemistry/coot: Chop DESCRIPTION to 80 chars (diff)
downloadsci-955584b7b0077bed0a8551086b3ac027b6972033.tar.gz
sci-955584b7b0077bed0a8551086b3ac027b6972033.tar.bz2
sci-955584b7b0077bed0a8551086b3ac027b6972033.zip
sys-cluster/gasnet: Chop DESCRIPTION to 80 chars
* Bump EAPI to 6 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/gasnet/gasnet-1.24.0.ebuild18
-rw-r--r--sys-cluster/gasnet/gasnet-9999.ebuild27
-rw-r--r--sys-cluster/gasnet/metadata.xml2
3 files changed, 23 insertions, 24 deletions
diff --git a/sys-cluster/gasnet/gasnet-1.24.0.ebuild b/sys-cluster/gasnet/gasnet-1.24.0.ebuild
index 5b2261fa3..c1dc53a19 100644
--- a/sys-cluster/gasnet/gasnet-1.24.0.ebuild
+++ b/sys-cluster/gasnet/gasnet-1.24.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils
+inherit autotools
MY_P="${PN^^[gasn]}-${PV}"
-DESCRIPTION="networking middleware layer to implementing partitioned global address space (PGAS) language"
+DESCRIPTION="Networking middleware for partitioned global address space (PGAS) language"
HOMEPAGE="http://gasnet.lbl.gov/"
SRC_URI="http://gasnet.lbl.gov/${MY_P}.tar.gz"
@@ -22,9 +22,11 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- find . \( -name Makefile.am -or -name "*.mak" \) -exec sed -i '/^docdir/s/^/#/' {} + || die
- AUTOTOOLS_AUTORECONF=yes
- autotools-utils_src_prepare
+ find . \
+ \( -name Makefile.am -or -name "*.mak" \) \
+ -exec sed -i '/^docdir/s/^/#/' {} + || die
+ default
+ eautoreconf
}
src_configure() {
@@ -32,5 +34,5 @@ src_configure() {
$(use_enable threads pthreads)
$(use_enable mpi)
)
- autotools-utils_src_configure
+ econf ${myeconfargs[@]}
}
diff --git a/sys-cluster/gasnet/gasnet-9999.ebuild b/sys-cluster/gasnet/gasnet-9999.ebuild
index e1270c76b..dc60493f5 100644
--- a/sys-cluster/gasnet/gasnet-9999.ebuild
+++ b/sys-cluster/gasnet/gasnet-9999.ebuild
@@ -1,27 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils
+inherit autotools git-r3
MY_P="${PN^^[gasn]}-${PV}"
-DESCRIPTION="networking middleware layer to implementing partitioned global address space (PGAS) language"
+DESCRIPTION="Networking middleware for partitioned global address space (PGAS) language"
HOMEPAGE="http://gasnet.lbl.gov/"
-
-if [[ $PV = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://bitbucket.org/berkeleylab/${PN}.git"
- AUTOTOOLS_AUTORECONF=yes
-else
- KEYWORDS="~amd64"
- SRC_URI="http://gasnet.lbl.gov/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-fi
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
+KEYWORDS=""
IUSE="mpi threads"
DEPEND="mpi? ( virtual/mpi )"
@@ -35,10 +27,15 @@ pkg_setup() {
echo
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_enable threads pthreads)
$(use_enable mpi)
)
- autotools-utils_src_configure
+ econf ${myeconfargs[@]}
}
diff --git a/sys-cluster/gasnet/metadata.xml b/sys-cluster/gasnet/metadata.xml
index 3ffc9db48..a5ee3aaf0 100644
--- a/sys-cluster/gasnet/metadata.xml
+++ b/sys-cluster/gasnet/metadata.xml
@@ -5,7 +5,7 @@
<email>ottxor@gentoo.org</email>
<name>Christoph Junghans</name>
</maintainer>
-<maintainer type="project">
+ <maintainer type="project">
<email>cluster@gentoo.org</email>
<name>Gentoo Cluster Project</name>
</maintainer>