aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-21 22:18:31 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-21 22:18:31 +0000
commit9cce8488b9b2fa9b5b3a538e4de15f78c4e39c8e (patch)
tree465ae461137f4770489be97f68517b1303281be8 /sys-cluster
parenttorque-2.0.0_p8.ebuild: forced fPIC and added PBS_SERVER_NAME (diff)
downloadsci-9cce8488b9b2fa9b5b3a538e4de15f78c4e39c8e.tar.gz
sci-9cce8488b9b2fa9b5b3a538e4de15f78c4e39c8e.tar.bz2
sci-9cce8488b9b2fa9b5b3a538e4de15f78c4e39c8e.zip
torque-2.0.0_p8.ebuild: now pic only for libpbs with a patch
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@140 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/torque/ChangeLog3
-rw-r--r--sys-cluster/torque/Manifest5
-rw-r--r--sys-cluster/torque/files/torque-2.0.0_p8-libpbs-pic.patch12
-rw-r--r--sys-cluster/torque/torque-2.0.0_p8.ebuild6
4 files changed, 21 insertions, 5 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 7ed38ea4e..c04ebc57b 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -12,7 +12,8 @@
+files/torque-2.0.0_p8-setuid-safety.patch
+files/torque-2.0.0_p8-respect-destdir.patch
Version bump. Closes bug #115189. Updated metadata.xml.
- Thanks to Lukasz Flis <foxman@krosno24.pl> and everyone on the bug.
+ Thanks to Lukasz Flis <foxman@krosno24.pl>, Eric Thibodeau <kyron@neuralbs.com>
+ and everyone else on the bug.
18 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>;
torque-1.2.0_p5-r2.ebuild:
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index 02eb9a700..d95ed5a16 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -1,9 +1,10 @@
-MD5 8f4ec2f75f76444de417537a72180200 ChangeLog 5441
+MD5 3d3fcde6bd30b5b6a9f15355ba520176 ChangeLog 5486
MD5 cf4938ca2752c9563ec72aac156f6b47 files/digest-torque-2.0.0_p8 67
MD5 7647c23d0d5189ae7a9c2a4322ce1bb6 files/torque-2.0.0_p8-destdir-fixes.patch 539
+MD5 9f25beb5f23e2ec65b02a6dc174fc452 files/torque-2.0.0_p8-libpbs-pic.patch 557
MD5 5f41eb14cea3408472c133849550faef files/torque-2.0.0_p8-makedepend.patch 754
MD5 b551147a374f034bf251490ce985be6b files/torque-2.0.0_p8-respect-destdir.patch 21832
MD5 3ea9d3a2e1cff3ccd224f0e0b33da6d5 files/torque-2.0.0_p8-respect-ldflags.patch 2710
MD5 f362dc4addcab08a5d537913b99c9484 files/torque-2.0.0_p8-setuid-safety.patch 997
MD5 873d7e3e93527942f580edbddb57061b metadata.xml 647
-MD5 a0ca5498617cc42f9c51cca663cf7e70 torque-2.0.0_p8.ebuild 4516
+MD5 5578565d8e5d8a91274c5bcec2aa5ab4 torque-2.0.0_p8.ebuild 4601
diff --git a/sys-cluster/torque/files/torque-2.0.0_p8-libpbs-pic.patch b/sys-cluster/torque/files/torque-2.0.0_p8-libpbs-pic.patch
new file mode 100644
index 000000000..c08e9947b
--- /dev/null
+++ b/sys-cluster/torque/files/torque-2.0.0_p8-libpbs-pic.patch
@@ -0,0 +1,12 @@
+diff -Naur torque-2.0.0p8/src/lib/Libpbs/Makefile.in torque-2.0.0p8.new/src/lib/Libpbs/Makefile.in
+--- torque-2.0.0p8/src/lib/Libpbs/Makefile.in 2006-01-27 18:42:09.000000000 +0000
++++ torque-2.0.0p8.new/src/lib/Libpbs/Makefile.in 2006-03-21 21:59:09.525967999 +0000
+@@ -93,7 +93,7 @@
+ INCS = -I@top_builddir@/src/include -I$(top_srcdir)/src/include \
+ -I$(srcdir)/../Libdis -I$(srcdir)/../Libifl
+
+-CFLAGS = @CFLAGS@ $(INCS) @DEFS@ -DIFF_PATH=\"$(IFF_PATH)\"
++CFLAGS = @CFLAGS@ $(INCS) @DEFS@ -DIFF_PATH=\"$(IFF_PATH)\" -fPIC
+
+ TARGET = libpbs.a
+
diff --git a/sys-cluster/torque/torque-2.0.0_p8.ebuild b/sys-cluster/torque/torque-2.0.0_p8.ebuild
index 8a9fd9fd0..0e4e754ac 100644
--- a/sys-cluster/torque/torque-2.0.0_p8.ebuild
+++ b/sys-cluster/torque/torque-2.0.0_p8.ebuild
@@ -3,7 +3,7 @@
# $Header: $
-inherit flag-o-matic eutils
+inherit autotools flag-o-matic eutils
MY_P="${P/_}"
DESCRIPTION="Resource manager and queuing system based on OpenPBS"
@@ -52,16 +52,18 @@ src_unpack() {
|| die "epatch for setuid failed"
epatch ${FILESDIR}/${P}-makedepend.patch \
|| die "epatch for makedepend failed"
+ epatch ${FILESDIR}/${P}-libpbs-pic.patch \
+ || die "epatch for libpbs PIC compiling failed"
sed -i \
-e "s|/tmp/|\${TMPDIR}/|g" \
${S}/buildutils/makedepend-sh || die "sed for makedepend failed"
+
}
src_compile() {
append-flags -DJOB_DELETE_NANNY
- append-flags -fPIC
local myconf=""
if use server; then