aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-17 17:15:28 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-17 17:15:28 +0000
commitd8d7b3c178c6b0c8465ecbc966251d8d2f09bfa7 (patch)
tree60e4259f1a86e026fa0eba8b721c2a251e93431e /sys-cluster
parentmajor update for umfpack-4.6 (diff)
downloadsci-d8d7b3c178c6b0c8465ecbc966251d8d2f09bfa7.tar.gz
sci-d8d7b3c178c6b0c8465ecbc966251d8d2f09bfa7.tar.bz2
sci-d8d7b3c178c6b0c8465ecbc966251d8d2f09bfa7.zip
openmpi-1.0.2: version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@175 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/Manifest4
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.0.11
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.0.21
-rw-r--r--sys-cluster/openmpi/openmpi-1.0.2.ebuild (renamed from sys-cluster/openmpi/openmpi-1.0.1.ebuild)19
5 files changed, 22 insertions, 9 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 8eda05660..cff7be0aa 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -2,9 +2,9 @@
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*openmpi-1.0.1 (15 Mar 2006)
+*openmpi-1.0.2 (17 Apr 2006)
- 15 Mar 2006; Sebastien Fabbro <seb@ist.utl.pt>
- +openmpi-1.0.1.ebuild, +metadata.xml
+ 17 Apr 2006; Sebastien Fabbro <seb@ist.utl.pt>
+ +openmpi-1.0.2.ebuild, +metadata.xml
Initial import. Closing bug #126295.
Thanks for Eric Thibodeau <kyron@neuralbs.com> for his input.
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index c6163f02d..8e2ca8a23 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,4 +1,6 @@
-MD5 5857c1a5ccb8ec1a1b24454e7f74a2d9 ChangeLog 342
+MD5 ec3d27ee675ab193dbfe2561e6988349 ChangeLog 342
MD5 914db9dc84c9ae3fdc732b8fb13fe21c files/digest-openmpi-1.0.1 67
+MD5 23219ab14ab5b826dfad619ae053acc3 files/digest-openmpi-1.0.2 67
MD5 c92d111706d0769823a1ff19c0abaacf metadata.xml 541
MD5 5dfd31d0de72fcffd0742bbae52da8ec openmpi-1.0.1.ebuild 2102
+MD5 10dcbb78442a9559f79c3d6c38323828 openmpi-1.0.2.ebuild 2290
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.0.1 b/sys-cluster/openmpi/files/digest-openmpi-1.0.1
deleted file mode 100644
index 4bf9b85f7..000000000
--- a/sys-cluster/openmpi/files/digest-openmpi-1.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8abccca5cdddc81a6d9d9e22b3bb6db9 openmpi-1.0.1.tar.bz2 3027217
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.0.2 b/sys-cluster/openmpi/files/digest-openmpi-1.0.2
new file mode 100644
index 000000000..4f37e073b
--- /dev/null
+++ b/sys-cluster/openmpi/files/digest-openmpi-1.0.2
@@ -0,0 +1 @@
+MD5 fd32861d643f9fe539a01d0d5b836f41 openmpi-1.0.2.tar.bz2 3195850
diff --git a/sys-cluster/openmpi/openmpi-1.0.1.ebuild b/sys-cluster/openmpi/openmpi-1.0.2.ebuild
index 07dbb95b9..a199e6a2c 100644
--- a/sys-cluster/openmpi/openmpi-1.0.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.0.2.ebuild
@@ -22,6 +22,17 @@ LICENSE="BSD"
FORTRAN="gfortran g77"
+pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is higly experimental."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ sleep 5
+ fi
+ fortran_pkg_setup
+}
+
src_compile() {
OMPISLOT=${PV}-"gcc-$(gcc-version)"
@@ -39,7 +50,7 @@ src_compile() {
myconf="${myconf} --sysconfdir=/etc/${PN}/${OMPISLOT}"
myconf="${myconf} --enable-pretty-print-stacktrace"
- if use threads; then
+ if use threads; then
myconf="${myconf} --enable-mpi-threads"
myconf="${myconf} --with-progress-threads"
myconf="${myconf} --with-threads=posix"
@@ -51,13 +62,13 @@ src_compile() {
myconf="${myconf} --disable-mpi-f90" || \
myconf="${myconf} --enable-mpi-f90"
fi
-
+
if use static; then
myconf="${myconf} --enable-static"
myconf="${myconf} --disable-shared"
myconf="${myconf} --without-memory-manager"
fi
-
+
use pbs && myconf="${myconf} $(use_with pbs tm /usr/$(get_libdir)/pbs)"
append-ldflags -Wl,-z,-noexecstack
@@ -74,6 +85,6 @@ src_install () {
p=${c/${D}/}
dosym ${p} ${p/-${OMPISLOT}/}
done
-
+
dodoc README AUTHORS NEWS VERSION
}