aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:05:26 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:05:26 -0400
commit7101e80d6d97124ae6e2cef7b0aa2889ee896659 (patch)
tree0ed6bb6d81c45e76ded46778d9ff6105fea7e7f5 /sys-devel/gdebugger/gdebugger-6.2.438.ebuild
parentCreate destination directory just before first file copy. (diff)
downloadsci-7101e80d6d97124ae6e2cef7b0aa2889ee896659.tar.gz
sci-7101e80d6d97124ae6e2cef7b0aa2889ee896659.tar.bz2
sci-7101e80d6d97124ae6e2cef7b0aa2889ee896659.zip
Create directories just before installing files to them.
Diffstat (limited to 'sys-devel/gdebugger/gdebugger-6.2.438.ebuild')
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
index 2a45c3962..be3e939e5 100644
--- a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -35,9 +35,6 @@ S="${WORKDIR}/${My_PN}${PV}-${_arch}"
_destination=/opt/${My_PN}
src_install() {
- dodir /usr/bin
- dodir /usr/share/applications
-
cd ${WORKDIR}
dodir `dirname ${_destination}`
cp -a ${S} ${D}${_destination}
@@ -46,10 +43,12 @@ src_install() {
# link to it in /usr/bin thus cannot work. Instead, copy it to /usr/bin and
# remove the autodetection of the script's directory and hardcode it to ${_destination}.
# Then create a lowercase symbolic link to this new launcher.
+ dodir /usr/bin
cp ${D}${_destination}/${My_PN} ${D}/usr/bin/${My_PN}
sed "s|gDEBuggerBinariesDir=.*|gDEBuggerBinariesDir=\"${_destination}\"|g" -i ${D}/usr/bin/${My_PN}
dosym /usr/bin/${My_PN} /usr/bin/${PN}
+ dodir /usr/share/applications
cat >> ${D}/usr/share/applications/${PN}.desktop <<- EOF
[Desktop Entry]
Name=${My_PN}