aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 12:47:55 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 12:47:55 -0400
commitdf50dd5f7f7c42b0ba90d144df5c08089db207cb (patch)
treefd16d3acfcc0e6a61c8af8ecc6e6303bb61951ea /sys-devel/gdebugger/gdebugger-6.2.438.ebuild
parentAssert sed execution with "die". (diff)
downloadsci-df50dd5f7f7c42b0ba90d144df5c08089db207cb.tar.gz
sci-df50dd5f7f7c42b0ba90d144df5c08089db207cb.tar.bz2
sci-df50dd5f7f7c42b0ba90d144df5c08089db207cb.zip
Revert "Don't use "cp" for copying files/folders into ${D}, use insinto/doins -r instead."
This reverts commit 1c3745a31ad9e256164dd82bd8720d28c9158325. Original code was actually cleaner.
Diffstat (limited to 'sys-devel/gdebugger/gdebugger-6.2.438.ebuild')
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
index b9334d5ab..3721b73a7 100644
--- a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -31,16 +31,13 @@ DEPEND="${RDEPEND}"
RESTRICT="mirror strip"
-_dest_folder=/opt
-_destination=${_dest_folder}/${My_PN}
-
-_extracted_folder=${My_PN}${PV}-${_arch}
-S="${WORKDIR}/${_extracted_folder}"
+S="${WORKDIR}/${My_PN}${PV}-${_arch}"
+_destination=/opt/${My_PN}
src_install() {
- insinto ${_dest_folder}
- doins -r ${S}
- mv ${D}${_dest_folder}/${_extracted_folder} ${D}/${_destination}
+ cd ${WORKDIR}
+ dodir `dirname ${_destination}`
+ cp -a ${S} ${D}${_destination}
# The included launcher gets the directory where it is being run; a symbolic
# link to it in /usr/bin thus cannot work. Instead, copy it to /usr/bin and