aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-05-14 17:49:33 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2011-05-14 17:49:33 +0400
commite254402217f445c960b1093f0f06f6b09ca6eb98 (patch)
tree89cc9e821f25a630aa57c45589c8c62ebf974016 /sys-devel/spl/spl-0.6.0_rc4.ebuild
parentsci-mathematics/giac: fix when no fltk (diff)
downloadsci-e254402217f445c960b1093f0f06f6b09ca6eb98.tar.gz
sci-e254402217f445c960b1093f0f06f6b09ca6eb98.tar.bz2
sci-e254402217f445c960b1093f0f06f6b09ca6eb98.zip
[sys-devel/spl] Update to recent version
(Portage version: 2.2.0_alpha32/git/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-devel/spl/spl-0.6.0_rc4.ebuild')
-rw-r--r--sys-devel/spl/spl-0.6.0_rc4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-devel/spl/spl-0.6.0_rc4.ebuild b/sys-devel/spl/spl-0.6.0_rc4.ebuild
new file mode 100644
index 000000000..f4d6f93ec
--- /dev/null
+++ b/sys-devel/spl/spl-0.6.0_rc4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+WANT_AUTOMAKE="1.11"
+AT_M4DIR=./config # for aclocal called by eautoreconf
+inherit linux-info eutils autotools
+
+DESCRIPTION="Solaris Porting Layer - a Linux kernel module providing some Solaris kernel APIs"
+HOMEPAGE="http://wiki.github.com/behlendorf/spl/"
+SRC_URI="http://github.com/downloads/behlendorf/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 -x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/linux-sources-2.6
+ "
+RDEPEND=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.0-includedir.patch
+ eautoreconf
+}
+
+src_configure() {
+ set_arch_to_kernel
+ econf \
+ --with-config=all \
+ --with-linux="${KERNEL_DIR}" \
+ --with-linux-obj="${KERNEL_DIR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ dosym /usr/include/spl/spl_config.h /usr/include/spl/module/spl_config.h \
+ || die
+}