aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:27:57 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:27:57 -0400
commit1c3745a31ad9e256164dd82bd8720d28c9158325 (patch)
treea9b2778db2e123a87d264bbc7eba6e62ef2293f4 /sys-devel
parentCreate directories just before installing files to them. (diff)
downloadsci-1c3745a31ad9e256164dd82bd8720d28c9158325.tar.gz
sci-1c3745a31ad9e256164dd82bd8720d28c9158325.tar.bz2
sci-1c3745a31ad9e256164dd82bd8720d28c9158325.zip
Don't use "cp" for copying files/folders into ${D}, use insinto/doins -r instead.
Note that an "mv" seems nessary to rename the installed folder (${My_PN} instead of ${My_PN}${PV}-${_arch}) and new variables ${_dest_folder} and ${_extracted_folder} are now used to prevent having ugly "basename" and "dirname" calls.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
index be3e939e5..c21232489 100644
--- a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -31,13 +31,16 @@ DEPEND="${RDEPEND}"
RESTRICT="mirror strip"
-S="${WORKDIR}/${My_PN}${PV}-${_arch}"
-_destination=/opt/${My_PN}
+_dest_folder=/opt
+_destination=${_dest_folder}/${My_PN}
+
+_extracted_folder=${My_PN}${PV}-${_arch}
+S="${WORKDIR}/${_extracted_folder}"
src_install() {
- cd ${WORKDIR}
- dodir `dirname ${_destination}`
- cp -a ${S} ${D}${_destination}
+ insinto ${_dest_folder}
+ doins -r ${S}
+ mv ${D}${_dest_folder}/${_extracted_folder} ${D}/${_destination}
# The included launcher gets the directory where it is being run; a symbolic
# link to it in /usr/bin thus cannot work. Instead, copy it to /usr/bin and