aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:03:59 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-30 11:03:59 -0400
commit913362aa3327f0d7d28c46c6717cab8ce7b2d945 (patch)
treec31d5a56124c35ca2bff57b19fffb449ee2c7860 /sys-devel
parentGo into WORKDIR instead of ".." (diff)
downloadsci-913362aa3327f0d7d28c46c6717cab8ce7b2d945.tar.gz
sci-913362aa3327f0d7d28c46c6717cab8ce7b2d945.tar.bz2
sci-913362aa3327f0d7d28c46c6717cab8ce7b2d945.zip
Create destination directory just before first file copy.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
index 9d58016ae..2a45c3962 100644
--- a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -35,11 +35,11 @@ S="${WORKDIR}/${My_PN}${PV}-${_arch}"
_destination=/opt/${My_PN}
src_install() {
- dodir /opt
dodir /usr/bin
dodir /usr/share/applications
cd ${WORKDIR}
+ dodir `dirname ${_destination}`
cp -a ${S} ${D}${_destination}
# The included launcher gets the directory where it is being run; a symbolic