aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2011-06-30 09:28:19 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2011-06-30 09:28:19 -0400
commitadf984e1511df9c07f22c0117b8d8da3e945595e (patch)
treee549ac79a5356fbf6e1c6b08a258890a975b7646 /sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild
parenttest (diff)
parent[sys-cluster/ganglia_jobmonarch] Dont need to compile (diff)
downloadsci-adf984e1511df9c07f22c0117b8d8da3e945595e.tar.gz
sci-adf984e1511df9c07f22c0117b8d8da3e945595e.tar.bz2
sci-adf984e1511df9c07f22c0117b8d8da3e945595e.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci into guillaume
Conflicts: sci-mathematics/scilab/Manifest
Diffstat (limited to 'sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild')
-rw-r--r--sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild b/sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild
index 0dd97ab0d..436fa5019 100644
--- a/sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild
+++ b/sys-infiniband/openib-mvapich2/openib-mvapich2-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,28 +6,30 @@
# the type of HCA to configure for. This needs to be fixed to take out the
# interactivity.
-SLOT="0"
-LICENSE="BSD"
-
-KEYWORDS="~x86 ~amd64"
-
-DESCRIPTION="MVAPICH2 MPI-over-infiniband package auto-configured for OpenIB."
+inherit fortran-2
+DESCRIPTION="MVAPICH2 MPI-over-infiniband package auto-configured for OpenIB"
HOMEPAGE="http://nowlab.cse.ohio-state.edu/projects/mpi-iba/"
SRC_URI="http://nowlab.cse.ohio-state.edu/projects/mpi-iba/download-mvapich2/mvapich2-$PV.tar.gz"
-S="${WORKDIR}/mvapich2-$PV"
-
-IUSE="threads debug medium-cluster large-cluster"
+SLOT="0"
+LICENSE="BSD"
+IUSE="debug large-cluster medium-cluster threads"
+KEYWORDS="~x86 ~amd64"
DEPEND="
- || ( sys-infiniband/libibverbs
- sys-infiniband/openib-userspace )
- || ( sys-infiniband/librdmacm
- sys-infiniband/openib-userspace )"
+ || (
+ sys-infiniband/libibverbs
+ sys-infiniband/openib-userspace )
+ || (
+ sys-infiniband/librdmacm
+ sys-infiniband/openib-userspace )"
RDEPEND="${DEPEND}"
+S="${WORKDIR}/mvapich2-$PV"
+
pkg_setup() {
+ fortran-2_pkg_setup
ARCH=
VCLUSTER=_SMALL_CLUSTER
HAVE_MPD_RING="-DUSE_MPD_RING"
@@ -112,4 +114,3 @@ pkg_postinst() {
einfo "echo 512000000 > /proc/sys/kernel/shmmax"
einfo "echo -e '* soft memlock 500000\n* hard memlock 500000' > /etc/security/limits.conf"
}
-